500 Internal Server Error

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

500 Internal Server Error

Сообщение Shimon197628 »

С недавнего времени, при обновлении страницы стало выскакивать такое сообщение: 500 Internal Server Error
Вроде бы ничего не делал, что могло привести к ошибкам.
Что это может быть?
Версия phpBB: 3.0.11
Аватара пользователя
Pazh
Former team member
Сообщения: 2317
Стаж: 16 лет 10 месяцев
Благодарил (а): 42 раза
Поблагодарили: 506 раз

Re: 500 Internal Server Error

Сообщение Pazh »

[FAQ] error.log - описание и примеры угадать что конкретно у тебя на сервере никто не сможет по тем данным что ты предоставил
Помощь в ЛС/email только за WM или ЮMoney
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

Pazh писал(а):[FAQ] error.log - описание и примеры
А где мне искать "error_log"? Не могу найти его...
Аватара пользователя
Pazh
Former team member
Сообщения: 2317
Стаж: 16 лет 10 месяцев
Благодарил (а): 42 раза
Поблагодарили: 506 раз

Re: 500 Internal Server Error

Сообщение Pazh »

А ты весь пост прочитал по указанной ссылке? Похоже что нет
Помощь в ЛС/email только за WM или ЮMoney
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

В панели управления выбираете нужный домен, далее пункт "Логи
У меня нет пункта логи... :(
Аватара пользователя
Pazh
Former team member
Сообщения: 2317
Стаж: 16 лет 10 месяцев
Благодарил (а): 42 раза
Поблагодарили: 506 раз

Re: 500 Internal Server Error

Сообщение Pazh »

тогда писать хостеру - где мои логи ошибок?
Помощь в ЛС/email только за WM или ЮMoney
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

Я кажется понял в чем ошибка.
Дней "х" назад, я поставил "временной диапазон онлайн-статистики", вместо 15 минут - 5.
И сначало было нормально, но видимо потом расход ресурсов сервера увеличился и это давало ошибку. Ну как я это понимаю. Вернул на место время и вроде ошибка больше не возникает.
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

Нет, спустя время, ошибка вернулась.

Нашел этот журнал ошибок:

Выделил несколько последних
Помогите :o :shock:

Код: Выделить всё

/home/lstoursc/public_html/jesus-forum.com/index.php, referer: http://www.jesus-forum.com/ucp.php?mode=register&sid=8284d4acf7f3ae17296b32090befd817
[Mon Dec 10 02:20:21 2012] [error] [client 188.186.202.197] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/ucp.php, referer: http://www.jesus-forum.com/ucp.php?mode=register&sid=8284d4acf7f3ae17296b32090befd817
[Mon Dec 10 02:20:07 2012] [error] [client 188.186.202.197] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/index.php, referer: http://www.jesus-forum.com/ucp.php?mode=register&sid=8284d4acf7f3ae17296b32090befd817
[Mon Dec 10 02:20:07 2012] [error] [client 188.186.202.197] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/ucp.php, referer: http://www.jesus-forum.com/ucp.php?mode=register&sid=8284d4acf7f3ae17296b32090befd817
[Mon Dec 10 02:19:43 2012] [error] [client 77.240.164.11] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/index.php, referer: http://jesus-forum.com/ucp.php?mode=login
[Mon Dec 10 02:19:43 2012] [error] [client 77.240.164.11] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/ucp.php, referer: http://jesus-forum.com/ucp.php?mode=login
[Mon Dec 10 02:19:37 2012] [error] [client 220.250.58.170] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/index.php, referer: http://www.jesus-forum.com/ucp.php?mode=login&sid=05179830f289646d41c5946a8a3eb6e7
[Mon Dec 10 02:19:37 2012] [error] [client 220.250.58.170] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/ucp.php, referer: http://www.jesus-forum.com/ucp.php?mode=login&sid=05179830f289646d41c5946a8a3eb6e7
[Mon Dec 10 02:19:33 2012] [error] [client 220.250.58.170] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/index.php, referer: http://www.jesus-forum.com/ucp.php?mode=register
[Mon Dec 10 02:19:33 2012] [error] [client 220.250.58.170] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/ucp.php, referer: http://www.jesus-forum.com/ucp.php?mode=register
[Mon Dec 10 02:19:04 2012] [error] [client 109.186.11.56] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/index.php, referer: http://jesus-forum.com/posting.php?mode=edit&f=125&p=3378
[Mon Dec 10 02:19:04 2012] [error] [client 109.186.11.56] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/index.php, referer: http://jesus-forum.com/posting.php?mode=edit&f=125&p=3378
[Mon Dec 10 02:18:45 2012] [error] [client 113.212.70.195] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/index.php, referer: http://ls-tours.com/guest/index.php
[Mon Dec 10 02:18:45 2012] [error] [client 113.212.70.195] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/guest/index.php, referer: http://ls-tours.com/guest/index.php
[Mon Dec 10 02:17:18 2012] [error] [client 109.186.11.56] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/index.php, referer: http://jesus-forum.com/index.php
[Mon Dec 10 02:17:18 2012] [error] [client 109.186.11.56] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/viewforum.php, referer: http://jesus-forum.com/index.php
Аватара пользователя
Pazh
Former team member
Сообщения: 2317
Стаж: 16 лет 10 месяцев
Благодарил (а): 42 раза
Поблагодарили: 506 раз

Re: 500 Internal Server Error

Сообщение Pazh »

Не хватает памяти. Вопрос какой: места на диске, оперативки или memory_limit
Помощь в ЛС/email только за WM или ЮMoney
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

Pazh писал(а):Не хватает памяти
А как проверить?

Добавлено спустя 1 час 42 минуты 34 секунды:
Нашел в разделе Resource Usage Overview такую надпись:

Your site has been limited within the past 24 hours
CPU resources were limited for your site
Virtual memory resources were limited for your site

Как мне это решить? Из-за чего вырастает такое потребление памяти?
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

Простите, за глупый вопрос.
Если я заново переставлю форум, это может помочь?
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: 500 Internal Server Error

Сообщение Татьяна5 »

Shimon197628, перестановка форума не повлияет на ресурсы сервера (только если повышенное потребление ресурсов не вызвано каким-либо модом)
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

Скажите, в последнее время у нас стали выкладывать много картинок с разных сайтов, таких как http://www.radikal.ru/
Это может влиять на нагрузку?
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

Скажите, а может такое быть, что влияет браузер?
Не знаю, совпадение это или нет. Я пользуюсь Опера и там очень часто выдает эту ошибку. Просто для проверки перешел на Firefox и прошло уже много времени, а ошибка не выскочила.
Повторюсь, я не знаю, совпадение это или нет.
Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Стаж: 20 лет 4 месяца
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 454 раза

Re: 500 Internal Server Error

Сообщение Палыч »

Shimon197628
Кеш в опере очистите, в том числе дисковый
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.

Вернуться в «Поддержка phpBB 3.0.х»