Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Общая ошибка
SQL ERROR [ mysqli ]
[0]
SQL
No values specified for SQL IN comparison
BACKTRACE
FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()
FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()
FILE: [ROOT]/includes/db/dbal.php
LINE: 432
CALL: dbal->sql_error()
FILE: [ROOT]/includes/functions_user.php
LINE: 540
CALL: dbal->sql_in_set()
FILE: [ROOT]/includes/acp/acp_users.php
LINE: 198
CALL: user_delete()
FILE: [ROOT]/includes/functions_module.php
LINE: 507
CALL: acp_users->main()
FILE: [ROOT]/adm/index.php
LINE: 74
CALL: p_master->load_active()
Тем не менее пользователь успешно удаляется. С какого момента началось, неясно, обнаружилось случайно. Есть ли возможность определить, в чём проблема, не копая поочерёдно все установленные моды (их много)?
Последний раз редактировалось Sheer 15.12.2012 14:37, всего редактировалось 1 раз.
Причина:bb-код
Не все то WINDOWS, что висит... phpBB только учусь. ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
$sql = 'SELECT w.warning_id FROM ' . WARNINGS_TABLE . ' w, ' . BANLIST_TABLE . ' b
WHERE w.warning_end = b.ban_end
AND ' . $db->sql_in_set('b.ban_id', $unban_sql);
Получается, что значение ban_id не определено, о чем, собственно, и сообщение об ошибке
Не все то WINDOWS, что висит... phpBB только учусь. ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
Не все то WINDOWS, что висит... phpBB только учусь. ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
в коде пять штук. В инструкции ничего не сказано, поэтому я добавил нужное перед той такой строкой, которая встречается первой. А надо было перед последней.
Если устанавливать моды по инструкции, такого быть не может.
Есть предыдущий шаг, если начинаете искать данное вхождение именно с того места в файле, которое правилось на предыдущем шаге, всё устанавливается правильно.
Так что - дело вовсе не в бобине.
Я тоже так сначала подумал, НО здесь ты немного не прав -
1. там всего одна вставка в файл includes/functions_user.php
2. похоже с выходом новой версии phpbb там действительно добавилась еще одна строка с $sql = 'DELETE FROM ' . BANLIST_TABLE . ', причем перед той куда нужно вставить код мода, отличие от искомой только в том что в новой строке есть еще один tab в начале, но кто это не заметил может проскочить и получить такой трабл (поиску не мешает найти именно ее самой первой и как раз по инструкции установки модов туда и надо вставить код мода). Так что надо наверно для однозначности поменять условие поиска в моде Advanced warnings for phpBB3