User Blog Mod: доработки

Поддержка старых модов или модов, созданных авторами не из нашего сообщества, а также любые вопросы, связанные с модами для phpBB 3.0.x, кроме относящихся к форуму Для авторов (phpBB 3.0.x).
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: User Blog Mod: доработки

Сообщение Sheer »

Krabsss писал(а):нашел ошибку
Нет там ошибки. В файле blog/includes/constants.php определяются константы BLOGS_REPLY_TRACKS_TABLE и BLOGS_TRACKS_TABLE. Без этого работать не будет. Другое дело надо на заменить

Код: Выделить всё

	global $config, $user, $db;
	include($phpbb_root_path . 'blog/includes/constants.php' . $phpEx);
на

Код: Выделить всё

	global $config, $user, $db, $phpEx, $phpbb_root_path;
	include($phpbb_root_path . 'blog/includes/constants.' . $phpEx);
Krabsss писал(а):Надеюсь
И не надейся.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
Krabsss
phpBB 1.4.4
Сообщения: 174
Стаж: 14 лет 1 месяц
Откуда: Санкт-Петербург
Благодарил (а): 5 раз
Поблагодарили: 7 раз

Re: User Blog Mod: доработки

Сообщение Krabsss »

Sheer писал(а):И не надейся
это уж точно, когда пользователь удаляет запись в своем дневнике, то она все равно остается, только админ может удалить полностью
1d207c338124.jpg
Добавлено спустя 9 минут 51 секунду:
как сделать, чтобы пользователи могли окончательно удалять свои записи?
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
evrus01
Former team member
Сообщения: 1274
Стаж: 15 лет 6 месяцев
Откуда: Москва
Благодарил (а): 107 раз
Поблагодарили: 234 раза

Re: User Blog Mod: доработки

Сообщение evrus01 »

Возможность окончательного удаления только у админа.
Аватара пользователя
miba
phpBB 2.0.4
Сообщения: 432
Стаж: 19 лет 8 месяцев
Благодарил (а): 86 раз
Поблагодарили: 7 раз

Re: User Blog Mod: доработки

Сообщение miba »

А не знаете, что может быть? При попытке удаления сообщения выдаёт:

Код: Выделить всё

Общая ошибка
SQL ERROR [ mysql4 ]

BIGINT UNSIGNED value is out of range in '(`miba_dog`.`phpbb_blogs_categories`.`blog_count` - 1)' [1690]

SQL

UPDATE phpbb_blogs_categories SET blog_count = blog_count - 1 WHERE category_id = '2'

BACKTRACE

FILE: [ROOT]/blog/includes/functions.php
LINE: 467
CALL: msg_handler()

FILE: (not given by php)
LINE: (not given by php)
CALL: blog_error_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: [ROOT]/blog/includes/functions_categories.php
LINE: 60
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/blog/blog/delete.php
LINE: 138
CALL: put_blogs_in_cats()

FILE: [ROOT]/blog.php
LINE: 315
CALL: include('[ROOT]/blog/blog/delete.php')

FILE: [ROOT]/blog/view/blog.php
LINE: 53
CALL: include('[ROOT]/blog.php')
Аватара пользователя
Pazh
Former team member
Сообщения: 2317
Стаж: 16 лет 10 месяцев
Благодарил (а): 42 раза
Поблагодарили: 506 раз

Re: User Blog Mod: доработки

Сообщение Pazh »

Похоже blog_count у тебя 0, а при удалении оно не может стать отрицательным т.к. UNSIGNED
Помощь в ЛС/email только за WM или ЮMoney
Аватара пользователя
miba
phpBB 2.0.4
Сообщения: 432
Стаж: 19 лет 8 месяцев
Благодарил (а): 86 раз
Поблагодарили: 7 раз

Re: User Blog Mod: доработки

Сообщение miba »

ты как всегда, выручаешь, чтобы я без тебя делал? :-) помогло
Erlang
phpBB 2.0.15
Сообщения: 1033
Стаж: 22 года 2 месяца
Откуда: Москва
Благодарил (а): 293 раза
Поблагодарили: 7 раз

Re: User Blog Mod: доработки

Сообщение Erlang »

Nekstati писал(а):Удаляем из шапки ссылку «Мой блог», оставляем только ссылку «Блоги».
После обновления форума ссылка перестала работать.
Т. е. при
/forum/blog/
выдает 404
А при
/forum/blog/blog.php
всё работает.

Где искать косяк подскажите плз...
С уважением,
Сергей
Hardis
phpBB 1.2.1
Сообщения: 25
Стаж: 14 лет 1 месяц
Благодарил (а): 3 раза

Re: User Blog Mod: доработки

Сообщение Hardis »

Столкнулся с проблемой при голосованиях в блоге. При выборе одного варианта ответа и нажатия кнопки "Проголосовать" выходит сообщение: "Вы выбрали слишком много вариантов ответа при голосовании." В поиске не нашел решения данной проблемы. Буду благодарен, если кто-то сталкивался с этим и поможет решить.
Аватара пользователя
angst66
phpBB 3.0.0 RC3
Сообщения: 1584
Стаж: 14 лет 8 месяцев
Благодарил (а): 90 раз
Поблагодарили: 165 раз

Re: User Blog Mod: доработки

Сообщение angst66 »

Hardis
phpBB 1.2.1
Сообщения: 25
Стаж: 14 лет 1 месяц
Благодарил (а): 3 раза

Re: User Blog Mod: доработки

Сообщение Hardis »

Стереть из шаблона - не вариант. Мне нужны голосования в блогах.
Я пока так решил эту проблему. Может кто-то может решить лучше.

В файле blog/vote.php добавил проверку:

Найти

Код: Выделить всё

if (sizeof($voted_id) > blog_data::$blog[$blog_id]['poll_max_options'] || blog_data::$blog[$blog_id]['poll_length'] < time())
Добавить ДО

Код: Выделить всё

if (blog_data::$blog[$blog_id]['poll_length'] != 0){
Найти

Код: Выделить всё

	trigger_error('TOO_MANY_VOTE_OPTIONS');
}
Добавить ПОСЛЕ
Gisher
phpBB 2.0.12
Сообщения: 857
Стаж: 19 лет 11 месяцев
Благодарил (а): 11 раз
Поблагодарили: 13 раз

Re: User Blog Mod: доработки

Сообщение Gisher »

Erlang попробуй создать файл .htaccess с содержимым
DirectoryIndex blog.php
и закинуть в папку blog
Аватара пользователя
angst66
phpBB 3.0.0 RC3
Сообщения: 1584
Стаж: 14 лет 8 месяцев
Благодарил (а): 90 раз
Поблагодарили: 165 раз

Re: User Blog Mod: доработки

Сообщение angst66 »

В блогах создал категории, распределил посты по категориям. Вопрос. Как сделать , чтобы при прохождении в определенную категорию человек попадал на последную запись в этой категории? Сейчас он попадает на случайную запись.
Erlang
phpBB 2.0.15
Сообщения: 1033
Стаж: 22 года 2 месяца
Откуда: Москва
Благодарил (а): 293 раза
Поблагодарили: 7 раз

Re: User Blog Mod: доработки

Сообщение Erlang »

Gisher
не помогает :О(
Аналогичная проблема при заходе в личный блог пользователя через профиль на форуме.

Тут не может быть конфликта?
Из установочной инструкции

Код: Выделить всё

<IfModule mod_rewrite.c>
RewriteEngine on

Rewriterule ^blog/(.+)/(.+).html$		./blog/view/blog.php?page=$1&mode=$2 [NC]
Rewriterule ^blog/(.+).html$			./blog/blog.php?page=$1 [NC]
Rewriterule ^blog/(.+)/$				./blog/view/blog.php?page=$1 [NC]
Rewriterule ^blog/$						./blog/blog.php [NC]

RewriteCond %{REQUEST_FILENAME} !-f
Rewriterule ^blog/(.+)/(.+)$		./blog/view/blog.php?page=$1&mode=$2 [NC]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^blog/(.+)$ ./blog/blog.php?page=$1 [NC]
</IfModule>
С уважением,
Сергей
Аватара пользователя
angst66
phpBB 3.0.0 RC3
Сообщения: 1584
Стаж: 14 лет 8 месяцев
Благодарил (а): 90 раз
Поблагодарили: 165 раз

Re: User Blog Mod: доработки

Сообщение angst66 »

Вопрос назрел. Как разрешить HTML в блогах?
Аватара пользователя
angst66
phpBB 3.0.0 RC3
Сообщения: 1584
Стаж: 14 лет 8 месяцев
Благодарил (а): 90 раз
Поблагодарили: 165 раз

Re: User Blog Mod: доработки

Сообщение angst66 »

angst66 писал(а):Как разрешить HTML в блогах?
Нашел http://www.lithiumstudios.org/forum/vie ... =42&t=1199 , для тех у кого установлен [Русский перевод] Enable HTML

Вернуться в «Поддержка модов для phpBB 3.0.x»