При загрузке изображений MySQL server has gone away [2006]

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Vityas
phpBB 1.4.4
Сообщения: 179
Стаж: 17 лет 5 месяцев
Благодарил (а): 59 раз

При загрузке изображений MySQL server has gone away [2006]

Сообщение Vityas »

Добрый день. На форуме для хостинга изображений используется мод siu_phpbb3_russian, который загружает из на сервис postimage.org

Второй день форумчане жалуются на невозможность загрузки фото. При этом у самого подобная проблема не проявляется, однако перелогинившись под тестовым юзером тоже получил эту ошибку. Т.е. под админом она не выскакивает.

Код: Выделить всё

SQL ERROR [ mysqli ]

MySQL server has gone away [2006]

SQL

SELECT bbcode_id, bbcode_tag, bbcode_helpline FROM phpbb3071_bbcodes WHERE display_on_posting = 1 ORDER BY bbcode_order

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 182
CALL: dbal->sql_error()

FILE: [ROOT]/includes/functions_display.php
LINE: 957
CALL: dbal_mysqli->sql_query()

FILE: [ROOT]/posting.php
LINE: 1629
CALL: display_custom_bbcodes()

Ответ от хостера:
С данным вопросом необходимо обратиться к разработчику сайта (форума),
предоставив ему информацию по ограничениям на нашем хостинге:
http://my.activecloud.com/ru/index.php? ... View/65/0/
Версия phpBB*: 3.0.11
Версия PHP: 5.3.18
Используемая СУБД и её версия: MySQL(i) 5.5.30-30.2-log
Ссылка на конференцию: http://forum.superkot.com
Есть ли у вас тестовый аккаунт**: test - testtest
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: При загрузке изображений MySQL server has gone away [200

Сообщение MIT »

Vityas писал(а):MySQL server has gone away
Vityas писал(а):С данным вопросом необходимо обратиться к разработчику сайта (форума),
Да ну конечно, ага. У них рухнул MySQL, а виноват форум. Счаз.
Vityas
phpBB 1.4.4
Сообщения: 179
Стаж: 17 лет 5 месяцев
Благодарил (а): 59 раз

Re: При загрузке изображений MySQL server has gone away [200

Сообщение Vityas »

При этом, в это же время, под админом все грузится без вопросов...
Vityas
phpBB 1.4.4
Сообщения: 179
Стаж: 17 лет 5 месяцев
Благодарил (а): 59 раз

Re: При загрузке изображений MySQL server has gone away [200

Сообщение Vityas »

Мда... Отличный ответ прислали из отдела администрирования:

Данная ошибка происходит при обрыве соединения с mysql сервером. Рекомендуем обратиться к разработчкикам для оптимизации кода и запросов в БД


Товарищи, помогите с проблемой...
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: При загрузке изображений MySQL server has gone away [200

Сообщение MIT »

Vityas, понимаю, что ты сейчас попал в ситуацию, когда тебя будут «отфутболивать» две стороны, но.

Но есть официальная документация MySQL, в которой довольно подробно написано о причинах возникновения такой ошибки. Её суть: во время обработки запроса к базе данных, база данных загнулась и сдохла, не отдав никакого ответа.
Самые частые причины:
1) Превышение какого-нибудь временного лимита на получение данных из базы. Это значит, что сервер базы данных просто не справляется с нагрузкой (и при том — не обязательно твоей).
2) Произошла ошибка на сетевом уровне в коммуникации с сервером базы данных (кто-то выдернул сетевой кабель от сервера с базами, например).

И то, и другое — по виде хостера. Форум тут не при чём. Если бы это была проблема логики форума, то от подобных вопросов форумы поддержки бы уже ломились, но это не так.

Пусть хостер отрывает свою задницу от стула и идёт разбираться.
Vityas
phpBB 1.4.4
Сообщения: 179
Стаж: 17 лет 5 месяцев
Благодарил (а): 59 раз

Re: При загрузке изображений MySQL server has gone away [200

Сообщение Vityas »

Это все логично. Меня только удивляет, что под админской учеткой эта ошибка ни как не воспроизводится.
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: При загрузке изображений MySQL server has gone away [200

Сообщение MIT »

Это ни о чём не говорит. У тебя и у пользователей не каждый раз ошибка возникает, небось.
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: При загрузке изображений MySQL server has gone away [200

Сообщение nissin »

Vityas писал(а):На форуме для хостинга изображений используется мод siu_phpbb3_russian, который загружает из на сервис postimage.org
Я думаю, что MySQL сервер не хочет ждать пока изображение загрузиться на сервис и закрывает соединение. Ограничение хостера:
- Значение wait_timeout (время, которое поток ждет повторного обращения) для сервера баз данных = 30
Если без этого мода никак переходите на VPS (выделенный сервер).
Vityas
phpBB 1.4.4
Сообщения: 179
Стаж: 17 лет 5 месяцев
Благодарил (а): 59 раз

Re: При загрузке изображений MySQL server has gone away [200

Сообщение Vityas »

Спасибо за ответ. Скорее всего именно так и есть. После перебранки с хостером наконец перенаправила 2 линию поддержки, с ними и пришли к выводу, что по таймауту сбрасывается. После этого залез в тему с большим кол-вом фото и заметил, что с s13.postimage.org изображения отдаются с перебоями. Вероятно из-за этого и возникла проблема. Сегодня сервис вроде работает без тормозов и ошибка тоже перестала выскакивать.

Всем спасибо за помощь в решении проблемы!
aleksndr
phpBB 1.4.4
Сообщения: 159
Стаж: 12 лет 7 месяцев
Благодарил (а): 2 раза

Re: При загрузке изображений MySQL server has gone away [2006]

Сообщение aleksndr »

То же при загрузке внешних изображений с разрешением 1080р(если их много в одной теме или хост где они находятся ,долго грузится

Код: Выделить всё

SQL ERROR [ mysql4 ]

MySQL server has gone away [2006]

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 430
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 249
CALL: phpbb\db\driver\driver->sql_transaction()

FILE: [ROOT]/includes/functions_posting.php
LINE: 1655
CALL: phpbb\db\driver\factory->sql_transaction()

FILE: [ROOT]/posting.php
LINE: 1403
CALL: submit_post()
VDS linux 
1 vCPUпроцессор
1 GBпамять
30-80 GBдиск*
∞ GBтрафик
Аватара пользователя
LONER
phpBB 3.0.0 RC1
Сообщения: 1486
Стаж: 10 лет 8 месяцев
Благодарил (а): 164 раза
Поблагодарили: 247 раз

Re: При загрузке изображений MySQL server has gone away [2006]

Сообщение LONER »

MySQL server has gone away [2006]
Как исправить “MySQL server has gone away” (error 2006)

Отправлено спустя 6 минут 21 секунду:
aleksndr, можешь прям в панели сделать. Такое же и для apache2, nginx есть.

Изображение
Правильно заданный вопрос и описание проблемы - 70% их решения...
aleksndr
phpBB 1.4.4
Сообщения: 159
Стаж: 12 лет 7 месяцев
Благодарил (а): 2 раза

Re: При загрузке изображений MySQL server has gone away [2006]

Сообщение aleksndr »

можешь прям в панели сделать. Такое же и для apache2, nginx есть.
Спасибище,как всегда выручил!

Вернуться в «Поддержка phpBB 3.0.х»