Ошибки в индексах базы данных
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
Sheer
- Former team member
- Сообщения: 12113
- Стаж: 19 лет 7 месяцев
- Откуда: Калининград не Кенигсберг
- Благодарил (а): 54 раза
- Поблагодарили: 2756 раз
Re: Ошибки в индексах базы данных
Да я б не парился, а установил MySQLDumper на сервере, и снял бы дам им, причем выборочно - без поисковых индексов (нафиг они нужны!?)
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
-
Booker
- phpBB 2.0.7a
- Сообщения: 627
- Стаж: 15 лет 3 месяца
- Благодарил (а): 165 раз
- Поблагодарили: 21 раз
Re: Ошибки в индексах базы данных
А как снять без индексов?
При восстановлении выдаёт: Fatal error: Maximum execution time of 60 seconds exceeded in Z:\home\localhost\www\MySQLDumper\restore.php on line 131
Не пойму, где это ограничение выставлено, вроде все настройки перерыл.
Но тем не менее таблицы теперь хотя бы открываются.
При восстановлении выдаёт: Fatal error: Maximum execution time of 60 seconds exceeded in Z:\home\localhost\www\MySQLDumper\restore.php on line 131
Не пойму, где это ограничение выставлено, вроде все настройки перерыл.
Но тем не менее таблицы теперь хотя бы открываются.
-
Sheer
- Former team member
- Сообщения: 12113
- Стаж: 19 лет 7 месяцев
- Откуда: Калининград не Кенигсберг
- Благодарил (а): 54 раза
- Поблагодарили: 2756 раз
Re: Ошибки в индексах базы данных
В php.iniBooker писал(а):где это ограничение выставлено
Код: Выделить всё
; Maximum execution time of each script, in seconds
; http://php.net/max-execution-time
; Note: This directive is hardcoded to 0 for the CLI SAPI
max_execution_time = 60Добавлено спустя 1 минуту 6 секунд:A PHP script has a maximum execution time that is usually set to 30 seconds on most server installations. A script running longer than this limit will simply stop working. This behavior makes backing up large databases impossible. Maybe you already had this specific problem when using other tools.
При создании резервной копии можно выбирать таблицы, которые будут включены в дамп.Booker писал(а):А как снять без индексов?
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
-
Sheer
- Former team member
- Сообщения: 12113
- Стаж: 19 лет 7 месяцев
- Откуда: Калининград не Кенигсберг
- Благодарил (а): 54 раза
- Поблагодарили: 2756 раз
Re: Ошибки в индексах базы данных
Если на локалке, то например
Также можно поменять в .htaccess, например так
Y:\usr\local\php5\php.iniТакже можно поменять в .htaccess, например так
Код: Выделить всё
php_value max_execution_time 120Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
-
Татьяна5
- Поддержка

- Сообщения: 13159
- Стаж: 15 лет 1 месяц
- Благодарил (а): 236 раз
- Поблагодарили: 3750 раз
Re: Ошибки в индексах базы данных
админка - Система - Общие задачи - Сведения о PHP - Loaded Configuration File (написан путь)Booker писал(а):А php.ini где лежит?
Это если на сервере
-
MIT
- Former team member
- Сообщения: 2500
- Стаж: 17 лет 6 месяцев
- Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
- Благодарил (а): 3 раза
- Поблагодарили: 351 раз
Re: Ошибки в индексах базы данных
Просто для внесения ясности: это не совсем комментарий. Это условный комментарий MySQL, для обратной совместимости со старыми версиями.Booker писал(а):Код: Выделить всё
/*!40103 SET @OLD_TIME_ZONE=@@TIME_ZONE */;
40103 — минимальный номер версии Мускуля, который понимает конструкцию.-
Sheer
- Former team member
- Сообщения: 12113
- Стаж: 19 лет 7 месяцев
- Откуда: Калининград не Кенигсберг
- Благодарил (а): 54 раза
- Поблагодарили: 2756 раз
Re: Ошибки в индексах базы данных
А какая разница? Ну вообще-то там все на английском (первая половина кодовой таблицы). Поэтому ANSI.
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
-
Balamut
- Former team member
- Сообщения: 2214
- Стаж: 21 год 6 месяцев
- Откуда: {postrow.POSTER_FROM}
- Поблагодарили: 146 раз
Re: Ошибки в индексах базы данных
С учетом того, что пациент пользовался для создания бекапа, восстанавливать эту хрень должен тот же, кто наивно возомнил себя основоположником нового стандарта.
Где бекап делали, там и спрашивайте, как его восстанновить. Хотите нормальный бекап - пользуетесь sxd , mysqldumper'Ом phpmyadmin'ом, чем хотите.
К поддержке phpBB это не имеет ни какого отношения.
От меня: требуйте ssh и не любите наше серое вещество.
Где бекап делали, там и спрашивайте, как его восстанновить. Хотите нормальный бекап - пользуетесь sxd , mysqldumper'Ом phpmyadmin'ом, чем хотите.
К поддержке phpBB это не имеет ни какого отношения.
От меня: требуйте ssh и не любите наше серое вещество.
//
// That's all, Folks!
// -------------------------------------------------
// That's all, Folks!
// -------------------------------------------------
-
Booker
- phpBB 2.0.7a
- Сообщения: 627
- Стаж: 15 лет 3 месяца
- Благодарил (а): 165 раз
- Поблагодарили: 21 раз
Re: Ошибки в индексах базы данных
Да, да, спасибо за вразумление. Базы данных вообще к phpbb отношения не имеют, он сам по себе.

