Ошибка при редактировании первого поста

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
salom
phpBB 1.2.0
Сообщения: 11
Стаж: 13 лет 1 месяц

Ошибка при редактировании первого поста

Сообщение salom »

После установки многочисленных полезных модов для форума появилась такая неприятная вещь. При редактировании первого сообщения темы, будь то изменение темы или правка сообщения, выскакивает вот такая неприятная вещь:
Общая ошибка
SQL ERROR [ mysqli ]

Out of range value adjusted for column 'bbcode_count' at row 1 [1264]

SQL

UPDATE phpbb_stats_bbcodes SET bbcode_count = (bbcode_count - 2) WHERE bbcode = '[/b:'

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 182
CALL: dbal->sql_error()

FILE: [ROOT]/statistics/includes/functions.php
LINE: 1917
CALL: dbal_mysqli->sql_query()

FILE: [ROOT]/posting.php
LINE: 1340
CALL: save_bbcode_smiley_count()
Но она бывает почему то не всегда... подскажите пожалуйста уважаемые гуру, что делать?
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: Ошибка при редактировании первого поста

Сообщение MIT »

salom писал(а):phpbb_stats_bbcodes
Нет в phpBB твкой таблицы. Видимо, какой-то из полезных модов был написан без соответствующего старания.
salom писал(а):Out of range value adjusted for column
Эта ошибка означает, что полю базы данных выбран неверный тип (размер) данных, либо, что в качестве значения пытается записаться отрицательное число при том, что значения в ячейке могут быть только положительными.
salom
phpBB 1.2.0
Сообщения: 11
Стаж: 13 лет 1 месяц

Re: Ошибка при редактировании первого поста

Сообщение salom »

MIT писал(а):Нет в phpBB твкой таблицы. Видимо, какой-то из полезных модов был написан без соответствующего старания.
у меня такая таблица есть, в ней вот такие поля:
bbcode varchar(255) utf8_bin
bbcode_count mediumint(8)

Эти ошибки могут быть из-за слишком большого поста? он у меня просто большой и включает в себя спойлер
salom
phpBB 1.2.0
Сообщения: 11
Стаж: 13 лет 1 месяц

Re: Ошибка при редактировании первого поста

Сообщение salom »

Проблему решил, нужно было изменить тип поля на bbcode_coun varchar t255
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: Ошибка при редактировании первого поста

Сообщение MIT »

salom писал(а):ти ошибки могут быть из-за слишком большого поста?
Без понятия. Я не представляю что это за мод, что он делает и зачем нужен.
salom писал(а):bbcode_count mediumint(8)
Посмотри, является ли поле unsigned (беззнаковым). Если является, то в качестве временного решения могу предложить убрать этот флаг, что бы поле могло содержать и отрицательные значения.
Но по-моему налицо некорректная работа мода. Если он считает количество использованных в тексте ББ-кодов, то вряд ли это количество может быть отрицательным.

Добавлено спустя 1 минуту 3 секунды:
salom писал(а):изменить тип поля на bbcode_coun varchar t255
Хреновая затея: математические операции с текстовом типом поля очень медленные.
salom
phpBB 1.2.0
Сообщения: 11
Стаж: 13 лет 1 месяц

Re: Ошибка при редактировании первого поста

Сообщение salom »

на что лучше изменить? mediumint(100)?

Добавлено спустя 2 минуты 14 секунд:
Да было беззнаковым, я это тоже убрал

Добавлено спустя 1 минуту 36 секунд:
Вообщем в итоге убрал только unsigned (беззнаковым) и все пока работает. Спасибо!

Вернуться в «Поддержка phpBB 3.0.х»