Проблемы после переноса на другой хостинг
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
oleja
- phpBB 1.0.0
- Сообщения: 2
- Стаж: 13 лет 10 месяцев
Проблемы после переноса на другой хостинг
Здравствуйте. Перенесли phpBB 3.06 на другой хостинг, залили дамп бд, поменяли config.php. Появились следующие проблемы:
- не работает цитирование (в логах ошибка "template->_tpl_load_file(): File /message_body.html does not exist or is empty", хотя файл message_body.html на месте)
- если очистить кэш и сессии из админки форума - не работают личные сообщения.
//В логах еще вот такая ошибка встречается: "PHP Warning: strtr(): The second argument is not an array in /includes/session.php on line 2191"
Подскажите пожалуйста, как их решить? Что было сделано неверно при переносе?
- не работает цитирование (в логах ошибка "template->_tpl_load_file(): File /message_body.html does not exist or is empty", хотя файл message_body.html на месте)
- если очистить кэш и сессии из админки форума - не работают личные сообщения.
//В логах еще вот такая ошибка встречается: "PHP Warning: strtr(): The second argument is not an array in /includes/session.php on line 2191"
Подскажите пожалуйста, как их решить? Что было сделано неверно при переносе?
-
владимир1983
- phpBB 3.2.6
- Сообщения: 5954
- Стаж: 16 лет 4 месяца
- Откуда: Сергиев Посад
- Благодарил (а): 373 раза
- Поблагодарили: 727 раз
Re: Проблемы после переноса на другой хостинг
А как осуществлялся переезд? Конфиги сервера одинаковые?oleja писал(а):Что было сделано неверно при переносе?
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
Нет человека - нет проблемы. (c)
-
oleja
- phpBB 1.0.0
- Сообщения: 2
- Стаж: 13 лет 10 месяцев
Re: Проблемы после переноса на другой хостинг
владимир1983, заархивировали файлы на старом хостинге, разархивировали на новом. Заменили настройки подключения к бд в config.php, накатили дамп бд.
Просто удивляет, что в целом все работает, а такие мелочи, как цитирование - нет. (в бд цитирование сохраняется в виде bb-тегов)
Просто удивляет, что в целом все работает, а такие мелочи, как цитирование - нет. (в бд цитирование сохраняется в виде bb-тегов)
-
владимир1983
- phpBB 3.2.6
- Сообщения: 5954
- Стаж: 16 лет 4 месяца
- Откуда: Сергиев Посад
- Благодарил (а): 373 раза
- Поблагодарили: 727 раз
Re: Проблемы после переноса на другой хостинг
Возможно побились файлы, попробуйте перезалить файлы по ftp с бепкапа кроме конфига.
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
Нет человека - нет проблемы. (c)
-
alexs13
- phpBB 1.0.0
- Сообщения: 3
- Стаж: 12 лет 10 месяцев
- Благодарил (а): 1 раз
Re: Проблемы после переноса на другой хостинг
SQL ERROR [MySQL4] Доступ запрещен для пользователей »u818871964_alexs" @ '10 .2.1.9 '(не используя пароль: НЕТ) [1045] Произошла ошибка SQL при выборке на этой странице. Пожалуйста, сообщите администратору, если ошибка будет повторяться.
выдает вот такую ошибку, что не в порядке , подскажите пожалуйста.
выдает вот такую ошибку, что не в порядке , подскажите пожалуйста.
-
Татьяна5
- Поддержка

- Сообщения: 13159
- Стаж: 15 лет 1 месяц
- Благодарил (а): 236 раз
- Поблагодарили: 3750 раз
Re: Проблемы после переноса на другой хостинг
alexs13, либо название БД/имя пользователя/пароль в
config.php, либо права доступа для пользователя u818871964_alexs к базе данных-
alexs13
- phpBB 1.0.0
- Сообщения: 3
- Стаж: 12 лет 10 месяцев
- Благодарил (а): 1 раз
Re: Проблемы после переноса на другой хостинг
Спасибо Татьяна, config.php, все правильно отредактировал, а с правами у админа хостинга спрашивать что ли?
-
Sheer
- Former team member
- Сообщения: 12113
- Стаж: 19 лет 7 месяцев
- Откуда: Калининград не Кенигсберг
- Благодарил (а): 54 раза
- Поблагодарили: 2756 раз
Re: Проблемы после переноса на другой хостинг
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
-
Vik_Ko
- phpBB 1.0.0
- Сообщения: 3
- Стаж: 10 лет 6 месяцев
Re: Проблемы после переноса на другой хостинг
Все перезалил, появилась надпись:
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/class_loader.php on line 160: require(./ext/boardtools/upload/event/listener.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/class_loader.php on line 160: require(./ext/boardtools/upload/event/listener.php): failed to open stream: No such file or directory
Проверил, файл "listener.php" на том месте, где и должен быть: /ext/boardtools/upload/event/listener.php
Подскажите, что еще подправить?
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/class_loader.php on line 160: require(./ext/boardtools/upload/event/listener.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/class_loader.php on line 160: require(./ext/boardtools/upload/event/listener.php): failed to open stream: No such file or directory
Проверил, файл "listener.php" на том месте, где и должен быть: /ext/boardtools/upload/event/listener.php
Подскажите, что еще подправить?
-
Vik_Ko
- phpBB 1.0.0
- Сообщения: 3
- Стаж: 10 лет 6 месяцев
Re: Проблемы после переноса на другой хостинг
Поставил на listener.php права доступа 777, но изменений нет..
-
Татьяна5
- Поддержка

- Сообщения: 13159
- Стаж: 15 лет 1 месяц
- Благодарил (а): 236 раз
- Поблагодарили: 3750 раз
-
Vik_Ko
- phpBB 1.0.0
- Сообщения: 3
- Стаж: 10 лет 6 месяцев
Re: Проблемы после переноса на другой хостинг
Спасибо, Татьяна5. Вы второй раз меня выручаете. С наступающим праздником 8-е Марта

