Ошибка 500 при установке

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
magos
phpBB 1.0.0
Сообщения: 2
Стаж: 12 лет 7 месяцев

Ошибка 500 при установке

Сообщение magos »

Здравствуйте, устанавливаю phpBB 3.0.12 на заключительном этапе выдает ошибку 500

Код: Выделить всё

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
При попытке обновить страницу выдает следующее сообщение.

Код: Выделить всё

General Error
SQL ERROR [ mysql4 ]

Duplicate entry 'adsbot [google]' for key 'username_clean' [1062]

SQL

INSERT INTO phpbb_users (username, username_clean, user_password, user_pass_convert, user_email, user_email_hash, group_id, user_type, user_permissions, user_timezone, user_dateformat, user_lang, user_style, user_actkey, user_ip, user_regdate, user_passchg, user_options, user_new, user_inactive_reason, user_inactive_time, user_lastmark, user_lastvisit, user_lastpost_time, user_lastpage, user_posts, user_dst, user_colour, user_occ, user_interests, user_avatar, user_avatar_type, user_avatar_width, user_avatar_height, user_new_privmsg, user_unread_privmsg, user_last_privmsg, user_message_rules, user_full_folder, user_emailtime, user_notify, user_notify_pm, user_notify_type, user_allow_pm, user_allow_viewonline, user_allow_viewemail, user_allow_massemail, user_sig, user_sig_bbcode_uid, user_sig_bbcode_bitfield, user_form_salt) VALUES ('AdsBot [Google]', 'adsbot [google]', '', 0, '', '00', 6, 2, '', 0, 'D M d, Y g:i a', 'en', 1, '', '', 1393281022, 1393281022, 230271, 0, 0, 0, 1393281022, 0, 0, '', 0, 0, '9E8DA7', '', '', '', 0, 0, 0, 0, 0, 0, 0, -3, 0, 0, 1, 0, 0, 1, 1, 0, '', '', '', 'c3564e162e7c586c')

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 754
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/includes/functions_user.php
LINE: 250
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/install/install_install.php
LINE: 1865
CALL: user_add()

FILE: [ROOT]/install/install_install.php
LINE: 108
CALL: install_install->add_bots()

FILE: [ROOT]/install/index.php
LINE: 326
CALL: install_install->main()

FILE: [ROOT]/install/index.php
LINE: 203
CALL: module->load()
Пробовал переустанавливать с другим дистрибутивом(с офф сайта) та же песня. Искал решение не нашел, подскажите что можно сделать. Заранее спасибо.
Последний раз редактировалось Sheer 25.02.2014 1:04, всего редактировалось 1 раз.
Причина: bb-код
Anvar
Former team member
Сообщения: 1964
Стаж: 16 лет 5 месяцев
Благодарил (а): 67 раз
Поблагодарили: 800 раз

Re: Ошибка 500 при установке

Сообщение Anvar »

Вспомнил. Была похожая проблема с другим движком и на другом хостинге, нашёл решение в php.ini, сейчас не вспомню точно. Кажется register_globals=On был, сейчас конечно это ветхий зовет.

Базу перед повторной установкой очищали? Файлу config права 666 выставили перед установкой? (он тоже должен быть пустой перед установкой)
magos
phpBB 1.0.0
Сообщения: 2
Стаж: 12 лет 7 месяцев

Re: Ошибка 500 при установке

Сообщение magos »

Базу перед повторной установкой очищали? Файлу config права 666 выставили перед установкой? (он тоже должен быть пустой перед установкой)
База пустая, права выставлены, то же самое.

Вернуться в «Поддержка phpBB 3.0.х»