http 503

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
PAW
phpBB 1.4.3
Сообщения: 93
Стаж: 16 лет 6 месяцев
Благодарил (а): 14 раз

http 503

Сообщение PAW »

Здравствуйте. После добавления страницы сайта (3.0.14 с установленным сео модом) в addurl Яндекса выдаётся:
"Для заданной страницы (или страницы, полученной после перенаправления) сервер возвращает код статуса http 503 (ожидался код 200)"
Подобная проблема возникла после смены прав доступа на некоторые форумы для ботов с "доступ для ботов" на "нет доступа" и "роль не назначена". Но добавляю в addurl я другие страницы, открытые для индексации. Думал проблемы на сервере. Хостеры (vps) ответили:
"Контент сайта отдаётся некорректно - возможно, проблема в настройках движка, неправильно прописывающего пути к файлам.
Проверьте сайт на наличие битых ссылок. Если у Вас подключены какие-либо плагины - их настройка может влиять на отдачу контента. Рекомендуем отключить все плагины."
Вернул все права обратно, изменений не произошло.
В логах много подобных записей:

Код: Выделить всё

"66.249.67.25 - - [29/Jun/2015:06:30:01 +0400] "GET /stomatologicheskoe-radio-ili-mp3-pleer-kotoriy-veshchaet-pryamo-izo-rta-video-foto-t4087.html HTTP/1.1" 503 1159 "-" "Mozilla/5.0 (iPhone; CPU iPhone OS 6_0 like Mac OS X) AppleWebKit/536.26 (KHTML, like Gecko) Version/6.0 Mobile/10A5376e Safari/8536.25 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)" "-"
Отправлено спустя 55 минут 50 секунд:
При копировании прав доступа Яндекс бота выдаётся следующее:

Код: Выделить всё

Общая ошибка
SQL ERROR [ mysql4 ]

Unknown column 't.forum_id' in 'where clause' [1054]

SQL

SELECT forum_id FROM phpbb_forums WHERE forum_type = 1 AND t.forum_id NOT IN('115') LIMIT 1

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 240
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/includes/db/dbal.php
LINE: 170
CALL: dbal_mysql->_sql_query_limit()

FILE: [ROOT]/includes/bb3topics.php
LINE: 48
CALL: dbal->sql_query_limit()

FILE: [ROOT]/viewtopic.php
LINE: 475
CALL: include('[ROOT]/includes/bb3topics.php')
Последний раз редактировалось Sheer 29.06.2015 19:49, всего редактировалось 1 раз.
Причина: bb-код
Аватара пользователя
владимир1983
phpBB 3.2.6
Сообщения: 5954
Стаж: 16 лет 4 месяца
Откуда: Сергиев Посад
Благодарил (а): 373 раза
Поблагодарили: 727 раз

Re: http 503

Сообщение владимир1983 »

PAW писал(а): Вернул все права обратно, изменений не произошло.
При чем тут права доступа? Ссылку покажи на страницу с которой проблемы. .htaccess содержимое покажи.
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
PAW
phpBB 1.4.3
Сообщения: 93
Стаж: 16 лет 6 месяцев
Благодарил (а): 14 раз

Re: http 503

Сообщение PAW »

При чем тут права доступа
Так с них всё и началось.
Отключил мод bb3topics боты стали видеть форум. Я знал, что мод кривой, но заменить мне его нечем.
В строке 48 в файле этого мода bb3topics.php:

Код: Выделить всё

$result = $db->sql_query_limit($sql, 1);
Ссылку покажи на страницу с которой проблемы
Боты не видят весь сайт из за этого мода.
.htaccess:

Код: Выделить всё

<Files ".htaccess">
deny from all
</Files>
# th23 start - error pages
ErrorDocument 400 http://**/error.php?e=400
ErrorDocument 401 http://***/error.php?e=401
ErrorDocument 403 http://***/error.php?e=403
ErrorDocument 404 http://***/error.php?e=404
ErrorDocument 500 http://***/error.php?e=500
# th23 end - error pages    

RewriteEngine   on
RewriteCond    %{HTTP_USER_AGENT}  (android|midp|j2me|symbian|series\ 60|symbos|windows\ mobile|windows\ ce|ppc|smartphone|blackberry|mtk|bada|windows\ phone)  [NC]
RewriteCond    %{HTTP_USER_AGENT}  !(accoona|ia_archiver|antabot|ask\ jeeves|baidu|dcpbot|eltaindexer|feedfetcher|gamespy|gigabot|googlebot|gsa-crawler|grub-client|gulper|slurp|mihalism|msnbot|worldindexer|ooyyo|pagebull|scooter|w3c_validator|jigsaw|webalta|yahoofeedseeker|yahoo!\ slurp|mmcrawler|yandexbot|yandeximages|yandexvideo|yandexmedia|yandexblogs|yandexaddurl|yandexfavicons|yandexdirect|yandexmetrika|yandexcatalog|yandexnews|yandeximageresizer)    [NC]
<ifmodule mod_expires.c>
<Filesmatch "\.(jpg|jpeg|png|gif|js|css|swf|ico|woff|mp3)$">
ExpiresActive on
ExpiresDefault "access plus 2 days"
</Filesmatch>
</ifmodule>

# Expires for main MIME types
#<IfModule mod_expires.c>
#ExpiresActive On
#ExpiresByType /styles/Coralis%20-%20Light%20Blue/template/overall_footer.html  "access plus 7 days"
#ExpiresByType /styles/Coralis%20-%20Light%20Blue/template/footer_blocks.html  "access plus 7 days"
#ExpiresByType /styles/Coralis%20-%20Light%20Blue/template/shet.html  "access plus 7 days"
#ExpiresByType image/png					"access plus 7 days"
#ExpiresByType image/JPG					"access plus 7 days"
#ExpiresByType image/jpg					"access plus 7 days"
#ExpiresByType image/gif					"access plus 7 days"
#ExpiresByType image/jpeg				"access plus 7 days"
#ExpiresByType audio/flac				"access plus 7 days"
#ExpiresByType audio/ogg					"access plus 7 days"
#ExpiresByType video/mp4					"access plus 7 days"
#ExpiresByType video/ogg					"access plus 7 days"
#ExpiresByType video/webm				"access plus 7 days"
#ExpiresByType text/css					"access plus 7 days"
#ExpiresByType font/ttf					"access plus 7 days"
#ExpiresByType font/woff					"access plus 7 days"
#ExpiresByType image/svg+xml				"access plus 7 days"
#ExpiresByType text/javascript 			"access plus 7 days"
#ExpiresByType application/javascript 	"access plus 7 days"
#ExpiresByType application/x-javascript 	"access plus 7 days"
#ExpiresByType application/x-shockwave-flash	"access plus 7 days"
#</IfModule>

# Gzip compression for Apache 2
#<IfModule mod_deflate.c>
#AddOutputFilterByType DEFLATE text/plain text/html text/xml text/css
#AddOutputFilterByType DEFLATE text/javascript application/javascript application/x-javascript application/json
#AddOutputFilterByType DEFLATE application/xml application/xhtml+xml application/rss+xml
#AddOutputFilterByType DEFLATE font/ttf font/otf image/svg+xml
#</IfModule>

# Gzip compression for Apache 1
#<IfModule mod_gzip.c>
#mod_gzip_on Yes
#mod_gzip_dechunk Yes
#mod_gzip_item_include file \.(html?|txt|css|js|php)$
#mod_gzip_item_include mime ^text/.*
#mod_gzip_item_exclude mime ^image/.*
#mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
#</IfModule>



# Lines That should already be in your .htacess
# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>


DirectoryIndex search.php?search_id=active_topics





# Lines That should already be in your .htacess
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>

# You may need to un-comment the following lines
# Options +FollowSymlinks
# To make sure that rewritten dir or file (/|.html) will not load dir.php in case it exist
# Options -MultiViews
# REMEBER YOU ONLY NEED TO STARD MOD REWRITE ONCE
RewriteEngine On
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
# RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
# REWRITE BASE
RewriteBase /
# HERE IS A GOOD PLACE TO FORCE CANONICAL DOMAIN
# RewriteCond %{HTTP_HOST} !^rai77\.ru$ [NC]
# RewriteRule ^(.*)$ http://rai77.ru/$1 [QSA,L,R=301]

# DO NOT GO FURTHER IF THE REQUESTED FILE / DIR DOES EXISTS
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule . - [L]
#####################################################
# PHPBB SEO REWRITE RULES ALL MODES
#####################################################
# AUTHOR : dcz www.phpbb-seo.com
# STARTED : 01/2006
#################################
# FORUMS PAGES
###############
# FORUM INDEX REWRITERULE WOULD STAND HERE IF USED. "forum" REQUIRES TO BE SET AS FORUM INDEX
# RewriteRule ^forum\.html$ /index.php [QSA,L,NC]
# FORUM ALL MODES
RewriteRule ^(forum|[a-z0-9_-]*-f)([0-9]+)(-([0-9]+))?\.html$ /viewforum.php?f=$2&start=$4 [QSA,L,NC]
# TOPIC WITH VIRTUAL FOLDER ALL MODES
RewriteRule ^(forum|[a-z0-9_-]*-f)([0-9]+)/(topic|[a-z0-9_-]*-t)([0-9]+)(-([0-9]+))?\.html$ /viewtopic.php?f=$2&t=$4&start=$6 [QSA,L,NC]
# TOPIC WITHOUT FORUM ID & DELIM ALL MODES
RewriteRule ^([a-z0-9_-]*)/?(topic|[a-z0-9_-]*-t)([0-9]+)(-([0-9]+))?\.html$ /viewtopic.php?forum_uri=$1&t=$3&start=$5 [QSA,L,NC]
# PHPBB FILES ALL MODES
RewriteRule ^resources/[a-z0-9_-]+/(thumb/)?([0-9]+)$ /download/file.php?id=$2&t=$1 [QSA,L,NC]
# PROFILES ALL MODES WITH ID
RewriteRule ^(member|[a-z0-9_-]*-u)([0-9]+)\.html$ /memberlist.php?mode=viewprofile&u=$2 [QSA,L,NC]
# USER MESSAGES ALL MODES WITH ID
RewriteRule ^(member|[a-z0-9_-]*-u)([0-9]+)-(topics|posts)(-([0-9]+))?\.html$ /search.php?author_id=$2&sr=$3&start=$5 [QSA,L,NC]
# GROUPS ALL MODES
RewriteRule ^(group|[a-z0-9_-]*-g)([0-9]+)(-([0-9]+))?\.html$ /memberlist.php?mode=group&g=$2&start=$4 [QSA,L,NC]
# POST
RewriteRule ^post([0-9]+)\.html$ /viewtopic.php?p=$1 [QSA,L,NC]
# ACTIVE TOPICS
RewriteRule ^active-topics(-([0-9]+))?\.html$ /search.php?search_id=active_topics&start=$2&sr=topics [QSA,L,NC]
# UNANSWERED TOPICS
RewriteRule ^unanswered(-([0-9]+))?\.html$ /search.php?search_id=unanswered&start=$2&sr=topics [QSA,L,NC]
# NEW POSTS
RewriteRule ^newposts(-([0-9]+))?\.html$ /search.php?search_id=newposts&start=$2&sr=topics [QSA,L,NC]
# UNREAD POSTS
RewriteRule ^unreadposts(-([0-9]+))?\.html$ /search.php?search_id=unreadposts&start=$2 [QSA,L,NC]
# THE TEAM
RewriteRule ^the-team\.html$ /memberlist.php?mode=leaders [QSA,L,NC]
# HERE IS A GOOD PLACE TO ADD OTHER PHPBB RELATED REWRITERULES

# FORUM WITHOUT ID & DELIM ALL MODES
# THESE FOUR LINES MUST BE LOCATED AT THE END OF YOUR HTACCESS TO WORK PROPERLY
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^([a-z0-9_-]+)(-([0-9]+))\.html$ /viewforum.php?forum_uri=$1&start=$3 [QSA,L,NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^([a-z0-9_-]+)\.html$ /viewforum.php?forum_uri=$1 [QSA,L,NC]
# FIX RELATIVE PATHS : FILES
RewriteRule ^.+/(style\.php|ucp\.php|mcp\.php|faq\.php|download/file.php)$ /$1 [QSA,L,NC,R=301]
# FIX RELATIVE PATHS : IMAGES
RewriteRule ^.+/(styles/.*|images/.*)/$ /$1 [QSA,L,NC,R=301]
# END PHPBB PAGES
    #####################################################


# Yandex IMAGES PATH
RewriteRule ^thumb/.*_(\d+)\.(gif|jpg|jpeg|bmp|png|tiff|tif|tga)$ download/file.php?id=$1&t=1 [NC]
RewriteRule ^pic/.*_(\d+)\.(gif|jpg|jpeg|bmp|png|tiff|tif|tga)$ download/file.php?id=$1&mode=view [NC]
RewriteRule ^small/.*_(\d+)\.(gif|jpg|jpeg|bmp|png|tiff|tif|tga)$ download/file.php?id=$1 [NC]
RewriteRule ^img/.*_(\d+)\.(gif|jpg|jpeg|bmp|png|tiff|tif|tga)$ download/file.php?id=$1 [NC]
PAW
phpBB 1.4.3
Сообщения: 93
Стаж: 16 лет 6 месяцев
Благодарил (а): 14 раз

Re: http 503

Сообщение PAW »

Удалил

Код: Выделить всё

$result = $db->sql_query_limit($sql, 1);
из мода, пока всё работает нормально. Извините за беспокойство.
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: http 503

Сообщение Sheer »

Но причина-то не в этой строке. А в том, что функция sql_query_limit пытается выполнить ошибочный SQL-запрос, определенный в переменной $sql, которая определена строкой (двумя-тремя) выше. И тут

Код: Выделить всё

Unknown column 't.forum_id' in 'where clause' [1054]
все предельно понятно. А кривой запрос, вот он

Код: Выделить всё

SELECT forum_id FROM phpbb_forums WHERE forum_type = 1 AND t.forum_id NOT IN('115') LIMIT 1
Должен быть какой-то такой

Код: Выделить всё

SELECT forum_id FROM phpbb_forums WHERE forum_type = 1 AND forum_id NOT IN('115') LIMIT 1
PS И научитесь пользоваться bb-кодами и создавать внятные заголовки тем.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.

Вернуться в «Поддержка phpBB 3.0.х»