Как принудительно убрать www?

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Юлия
phpBB 1.4.2
Сообщения: 69
Стаж: 17 лет 5 месяцев
Откуда: Астрахань
Благодарил (а): 10 раз

Re: Как принудительно убрать www?

Сообщение Юлия »

Нет, у вас тоже не работает, нажимаешь на "Список форумов" и www возвращаются обратно, добавляешь www и форум его не убирает, а вот пример того что я хочу в идеале получить http://phpbbex.com/ здесь всё чётко работает в домене, добавляешь перед адресом www и он автоматом убирается и за одно и index.php после адреса.
drugold
phpBB 1.4.2
Сообщения: 72
Стаж: 16 лет 2 месяца
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 8 раз

Re: Как принудительно убрать www?

Сообщение drugold »

Юлия
У меня реализовано так:

Код: Выделить всё

RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
http://forum.3doplanet.ru
VDS: OpenVZ [Intel(R) Xeon(R) CPU E5645 @ 2.40GHz 1596.000 Mhz X 4 / 4096 MB / 120 GB]
HTTPd: Apache/2.2.22 (Debian)
PHP: 5.4.4-14+deb7u12
MySQL(i): 5.5.33-0+wheezy1
---
Основной: phpBB 3.0.14
Тестовый: phpBB 3.1.8
Аватара пользователя
saturn-z
phpBB 2.0.0
Сообщения: 241
Стаж: 13 лет 10 месяцев
Откуда: РФ, Тюмень
Благодарил (а): 13 раз
Поблагодарили: 93 раза

Re: Как принудительно убрать www?

Сообщение saturn-z »

Юлия писал(а): нажимаешь на "Список форумов" и www возвращаются обратно
Админка => общие => конфигурация сервера => Настройки сервера => Настройки URL сервера => Имя домена: указать домен без www
Немало нужно знания, чтобы уметь скрыть перед другими свое незнание.
Аватара пользователя
Юлия
phpBB 1.4.2
Сообщения: 69
Стаж: 17 лет 5 месяцев
Откуда: Астрахань
Благодарил (а): 10 раз

Re: Как принудительно убрать www?

Сообщение Юлия »

drugold писал(а): У меня реализовано так:
у вас тоже всё работает на ура, у меня не хочет :cry: не пойму где загвоздка
saturn-z писал(а): Админка => общие => конфигурация сервера => Настройки сервера => Настройки URL сервера => Имя домена: указать домен без www
это настроено
Аватара пользователя
Likbezz
phpBB 1.4.3
Сообщения: 79
Стаж: 14 лет 4 месяца
Благодарил (а): 3 раза
Поблагодарили: 6 раз

Re: Как принудительно убрать www?

Сообщение Likbezz »

Юлия писал(а): не пойму где загвоздка
Полный код .htaccess под спойлер

Оба примера что вам дали абсолютно рабочие
Хрен, положенный на мнение окружающих, ведет к счастью и спокойствию..
Аватара пользователя
Юлия
phpBB 1.4.2
Сообщения: 69
Стаж: 17 лет 5 месяцев
Откуда: Астрахань
Благодарил (а): 10 раз

Re: Как принудительно убрать www?

Сообщение Юлия »

Likbezz писал(а): Оба примера что вам дали абсолютно рабочие
я абсолютно уверенна что они рабочие, это где то у меня косяк
.htaccess 
#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#<IfModule mod_rewrite.c>
#RewriteEngine On
#RewriteBase /
#RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
#RewriteRule ^(.*)$ http://%1/$1 [R=301,L]
#</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
<IfVersion < 2.4>
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>
</IfVersion>
<IfVersion >= 2.4>
<Files "config.php">
Require all denied
</Files>
<Files "common.php">
Require all denied
</Files>
</IfVersion>
</IfModule>
<IfModule !mod_version.c>
<IfModule !mod_authz_core.c>
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>
</IfModule>
<IfModule mod_authz_core.c>
<Files "config.php">
Require all denied
</Files>
<Files "common.php">
Require all denied
</Files>
</IfModule>
</IfModule>
Аватара пользователя
Likbezz
phpBB 1.4.3
Сообщения: 79
Стаж: 14 лет 4 месяца
Благодарил (а): 3 раза
Поблагодарили: 6 раз

Re: Как принудительно убрать www?

Сообщение Likbezz »

Вот:
Скрытый текст

Код: Выделить всё

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ http://%1%{REQUEST_URI} [R=301,QSA,NC,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>
Хрен, положенный на мнение окружающих, ведет к счастью и спокойствию..
Аватара пользователя
Юлия
phpBB 1.4.2
Сообщения: 69
Стаж: 17 лет 5 месяцев
Откуда: Астрахань
Благодарил (а): 10 раз

Re: Как принудительно убрать www?

Сообщение Юлия »

спасибо огромное, но почему то index.php не убирается после адреса
drugold
phpBB 1.4.2
Сообщения: 72
Стаж: 16 лет 2 месяца
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 8 раз

Re: Как принудительно убрать www?

Сообщение drugold »

Юлия писал(а): но почему то index.php не убирается после адреса
Это лучше сделать через хук.
VDS: OpenVZ [Intel(R) Xeon(R) CPU E5645 @ 2.40GHz 1596.000 Mhz X 4 / 4096 MB / 120 GB]
HTTPd: Apache/2.2.22 (Debian)
PHP: 5.4.4-14+deb7u12
MySQL(i): 5.5.33-0+wheezy1
---
Основной: phpBB 3.0.14
Тестовый: phpBB 3.1.8
Аватара пользователя
Юлия
phpBB 1.4.2
Сообщения: 69
Стаж: 17 лет 5 месяцев
Откуда: Астрахань
Благодарил (а): 10 раз

Re: Как принудительно убрать www?

Сообщение Юлия »

drugold писал(а): Это лучше сделать через хук.
А вот с этого места по подробнее :)
drugold
phpBB 1.4.2
Сообщения: 72
Стаж: 16 лет 2 месяца
Откуда: СССР
Благодарил (а): 6 раз
Поблагодарили: 8 раз

Re: Как принудительно убрать www?

Сообщение drugold »

Создать файл hook_kill_index.php с содержимым:

Код: Выделить всё

<?php

function kill_index(&$hook, $url, $params = false, $is_amp = true, $session_id = false)
{
	$url = str_replace('index.php', '', $url);
	return append_sid($url, $params, $is_amp, $session_id);
}

$phpbb_hook->register('append_sid', 'kill_index');

?>
Положить в имя_форума/includes/hooks
VDS: OpenVZ [Intel(R) Xeon(R) CPU E5645 @ 2.40GHz 1596.000 Mhz X 4 / 4096 MB / 120 GB]
HTTPd: Apache/2.2.22 (Debian)
PHP: 5.4.4-14+deb7u12
MySQL(i): 5.5.33-0+wheezy1
---
Основной: phpBB 3.0.14
Тестовый: phpBB 3.1.8
Аватара пользователя
Юлия
phpBB 1.4.2
Сообщения: 69
Стаж: 17 лет 5 месяцев
Откуда: Астрахань
Благодарил (а): 10 раз

Re: Как принудительно убрать www?

Сообщение Юлия »

видимо что то в коде, нажимаю там где у меня "Список форумов" и вылезает index.php
Аватара пользователя
Likbezz
phpBB 1.4.3
Сообщения: 79
Стаж: 14 лет 4 месяца
Благодарил (а): 3 раза
Поблагодарили: 6 раз

Re: Как принудительно убрать www?

Сообщение Likbezz »

Юлия писал(а): но почему то index.php не убирается после адреса
?
Вопрос стоял немножко иначе: “Как принудительно убрать www?” вам еще и индекс убрать надо?)
Тогда вот:

Код: Выделить всё

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteBase /

RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ http://%1%{REQUEST_URI} [R=301,QSA,NC,L]

RewriteCond %{THE_REQUEST} ^(GET|HEAD)\ /index.php
RewriteRule .* / [R=301,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>
Хрен, положенный на мнение окружающих, ведет к счастью и спокойствию..
Аватара пользователя
Юлия
phpBB 1.4.2
Сообщения: 69
Стаж: 17 лет 5 месяцев
Откуда: Астрахань
Благодарил (а): 10 раз

Re: Как принудительно убрать www?

Сообщение Юлия »

Likbezz писал(а): Вопрос стоял немножко иначе: “Как принудительно убрать www?” вам еще и индекс убрать надо?)
супер, всё работает отлично, спасибо огроменное за терпение и неоценимую помощь
Аватара пользователя
Likbezz
phpBB 1.4.3
Сообщения: 79
Стаж: 14 лет 4 месяца
Благодарил (а): 3 раза
Поблагодарили: 6 раз

Re: Как принудительно убрать www?

Сообщение Likbezz »

Юлия писал(а): спасибо огроменное за терпение и неоценимую помощь
Ну что вы, ..
всегда пожалуйста )
Хрен, положенный на мнение окружающих, ведет к счастью и спокойствию..

Вернуться в «Поддержка phpBB 3.0.х»