Доменная аутентификация (LDAP авторизация) - как?
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
cmit
- phpBB 1.0.0
- Сообщения: 3
- Стаж: 15 лет 5 месяцев
Re: Доменная аутентификация (LDAP авторизация) - как?
Alek$, в php есть возможность получить имя пользователя Windows. Теория: заменить использование кукисов на скрипт php определяющий имя пользователя прошедшего авторизацию в domain. На данный момент не знаю структуры авторизации в phpbb, что и с чем связано. Идею возможно реализовать? )
-
outofdate
- phpBB 1.0.0
- Сообщения: 1
- Стаж: 15 лет 2 месяца
Re: Доменная аутентификация (LDAP авторизация) - как?
Были тут вначале куски кода как сделать аутентификацию лдап, но чтобы отображался не sAMAccount... а полное имя пользователя, прописал всё везде где нужно, но полагаю у нас разные версии phpBB3 от того и возникают у меня проблемы такого рода
Вот такая конструкция была собрана по аналогии с тем кодом. Может ли мне кто нибудь в этом помочь, ибо сам ни пхп и в мускле не силен. Благодарю за внимание.
Данное событие по моим измышлениям происходят из-за того что ldap_search по каким то причинам не заглядывает куда на, а именноSQL ERROR [ mysql4 ]
Column 'user_from' cannot be null [1048]
Код: Выделить всё
$search = @ldap_search(
$ldap,
htmlspecialchars_decode($config['ldap_base_dn']),
ldap_user_filter($user->data['username']),
(empty($config['ldap_email'])) ?
array(htmlspecialchars_decode($config['ldap_uid'])) :
array(htmlspecialchars_decode($config['ldap_uid']), htmlspecialchars_decode($config['ldap_email']), 'displayName'),
0,
1
);
-
valve513
- phpBB 1.0.0
- Сообщения: 1
- Стаж: 14 лет 3 месяца
Re: Доменная аутентификация (LDAP авторизация) - как?
Привет GURU/
Пречитал форум, но запустить авторизацию LDAP так и не получилось.
Выдает ошибку
"не удалось найти идентификатор для входа в систему для login"
настройки:
1) Метод аутентификации: Ldap
2) Имя сервера Ldap: ip
3) Порт сервера Ldap: 389
4) Основное имя Ldap: dc=domain
5) Идентификационный номер: sAMAccountName
6) Фильтр имени пользователя Ldap: пусто
7) E-mail-атрибут Ldap: mail
8) Пользователь Ldap: login
9) Пароль: password
Подскажите развернутой мыслью, где что не совпадает или нехватает? Очеень нужно
Пречитал форум, но запустить авторизацию LDAP так и не получилось.
Выдает ошибку
"не удалось найти идентификатор для входа в систему для login"
настройки:
1) Метод аутентификации: Ldap
2) Имя сервера Ldap: ip
3) Порт сервера Ldap: 389
4) Основное имя Ldap: dc=domain
5) Идентификационный номер: sAMAccountName
6) Фильтр имени пользователя Ldap: пусто
7) E-mail-атрибут Ldap: mail
8) Пользователь Ldap: login
9) Пароль: password
Подскажите развернутой мыслью, где что не совпадает или нехватает? Очеень нужно
-
solbadguy
- phpBB 1.0.0
- Сообщения: 1
- Стаж: 10 лет
Re: Доменная аутентификация (LDAP авторизация) - как?
При попытке активации LDAP авторизации появляется сообщение:
"Could not find a login identity for %username%"
Оно же на русском: "не удалось найти идентификатор для входа в систему для %username%"
Решается это так:
1) Cозданием в Active Directory еще одного пользователя(например phpBBadmin), который будет выполнять роль админа для форума.
2) Указываем ему почтовый ящик и включаем неограниченный срок действия пароля.
3) Через Board index регистрируем с такими же именем и паролем(phpBBadmin) нового пользователя.
4) Логинимся под старым админом и даем новому пользователю права администратора или founder'а.
5) Логинимся под нашим новым админом(phpBBadmin), и уже без проблем включаем режим LDAP авторизации.
Для тех, кто заранее знает что ему нужна LDAP авторизация, при установке phpBB создавайте заранее в AD пользователя на роль админа.
"Could not find a login identity for %username%"
Оно же на русском: "не удалось найти идентификатор для входа в систему для %username%"
Решается это так:
1) Cозданием в Active Directory еще одного пользователя(например phpBBadmin), который будет выполнять роль админа для форума.
2) Указываем ему почтовый ящик и включаем неограниченный срок действия пароля.
3) Через Board index регистрируем с такими же именем и паролем(phpBBadmin) нового пользователя.
4) Логинимся под старым админом и даем новому пользователю права администратора или founder'а.
5) Логинимся под нашим новым админом(phpBBadmin), и уже без проблем включаем режим LDAP авторизации.
Для тех, кто заранее знает что ему нужна LDAP авторизация, при установке phpBB создавайте заранее в AD пользователя на роль админа.

