Ошибки в индексах базы данных

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибки в индексах базы данных

Сообщение Sheer »

Да я б не парился, а установил MySQLDumper на сервере, и снял бы дам им, причем выборочно - без поисковых индексов (нафиг они нужны!?)
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Booker
phpBB 2.0.7a
Сообщения: 627
Стаж: 15 лет 3 месяца
Благодарил (а): 165 раз
Поблагодарили: 21 раз

Re: Ошибки в индексах базы данных

Сообщение Booker »

А как снять без индексов?

При восстановлении выдаёт: Fatal error: Maximum execution time of 60 seconds exceeded in Z:\home\localhost\www\MySQLDumper\restore.php on line 131
Не пойму, где это ограничение выставлено, вроде все настройки перерыл.
Но тем не менее таблицы теперь хотя бы открываются.
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибки в индексах базы данных

Сообщение Sheer »

Booker писал(а):где это ограничение выставлено
В php.ini

Код: Выделить всё

; Maximum execution time of each script, in seconds
; http://php.net/max-execution-time
; Note: This directive is hardcoded to 0 for the CLI SAPI
max_execution_time = 60
Но что он ругается, это непонятно. Это как раз фича MySQLDumper, что ему пофиг эти ограничения:
A PHP script has a maximum execution time that is usually set to 30 seconds on most server installations. A script running longer than this limit will simply stop working. This behavior makes backing up large databases impossible. Maybe you already had this specific problem when using other tools.
Добавлено спустя 1 минуту 6 секунд:
Booker писал(а):А как снять без индексов?
При создании резервной копии можно выбирать таблицы, которые будут включены в дамп.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Booker
phpBB 2.0.7a
Сообщения: 627
Стаж: 15 лет 3 месяца
Благодарил (а): 165 раз
Поблагодарили: 21 раз

Re: Ошибки в индексах базы данных

Сообщение Booker »

А php.ini где лежит?
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибки в индексах базы данных

Сообщение Sheer »

Если на локалке, то например Y:\usr\local\php5\php.ini
Также можно поменять в .htaccess, например так

Код: Выделить всё

php_value max_execution_time 120
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Ошибки в индексах базы данных

Сообщение Татьяна5 »

Booker писал(а):А php.ini где лежит?
админка - Система - Общие задачи - Сведения о PHP - Loaded Configuration File (написан путь)
Это если на сервере
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: Ошибки в индексах базы данных

Сообщение MIT »

Booker писал(а):

Код: Выделить всё

/*!40103 SET @OLD_TIME_ZONE=@@TIME_ZONE */;
Просто для внесения ясности: это не совсем комментарий. Это условный комментарий MySQL, для обратной совместимости со старыми версиями. 40103 — минимальный номер версии Мускуля, который понимает конструкцию.
Booker
phpBB 2.0.7a
Сообщения: 627
Стаж: 15 лет 3 месяца
Благодарил (а): 165 раз
Поблагодарили: 21 раз

Re: Ошибки в индексах базы данных

Сообщение Booker »

В php.ini на денвере кодировка ANSI или UTF-8 без BOM?
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибки в индексах базы данных

Сообщение Sheer »

А какая разница? Ну вообще-то там все на английском (первая половина кодовой таблицы). Поэтому ANSI.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
Balamut
Former team member
Сообщения: 2214
Стаж: 21 год 6 месяцев
Откуда: {postrow.POSTER_FROM}
Поблагодарили: 146 раз

Re: Ошибки в индексах базы данных

Сообщение Balamut »

С учетом того, что пациент пользовался для создания бекапа, восстанавливать эту хрень должен тот же, кто наивно возомнил себя основоположником нового стандарта.

Где бекап делали, там и спрашивайте, как его восстанновить. Хотите нормальный бекап - пользуетесь sxd , mysqldumper'Ом phpmyadmin'ом, чем хотите.

К поддержке phpBB это не имеет ни какого отношения.

От меня: требуйте ssh и не любите наше серое вещество.
//
// That's all, Folks!
// -------------------------------------------------
Booker
phpBB 2.0.7a
Сообщения: 627
Стаж: 15 лет 3 месяца
Благодарил (а): 165 раз
Поблагодарили: 21 раз

Re: Ошибки в индексах базы данных

Сообщение Booker »

Да, да, спасибо за вразумление. Базы данных вообще к phpbb отношения не имеют, он сам по себе.

Вернуться в «Поддержка phpBB 3.0.х»