Fatal error: Allowed memory size

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
c61
phpBB 2.0.6
Сообщения: 506
Стаж: 13 лет 9 месяцев
Благодарил (а): 42 раза
Поблагодарили: 251 раз

Re: Fatal error: Allowed memory size

Сообщение c61 »

MIT писал(а):Хм, слушай, может это баг самого PHP или его модуля?...
Если неверно собран, или неверные параметры настройки под апача, такое запросто можно получить. К этому и веду - хостер напортачил) phpinfo надо бы глянуть, это точно !
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

MIT, c61, конечно! Вот: http://danfa.ru/phpinfo.php - так пойдет?
MIT писал(а):Ну не та же.
Я имею введу ошибки похоже с файлом startup.php... Кстати, что это за файл, для чего он?
Аватара пользователя
c61
phpBB 2.0.6
Сообщения: 506
Стаж: 13 лет 9 месяцев
Благодарил (а): 42 раза
Поблагодарили: 251 раз

Re: Fatal error: Allowed memory size

Сообщение c61 »

Raisin писал(а):Вот:...
Ага... startup.php - название говорит само за себя - можно обозвать "запускатель" или "пускач"))

Так вот, см. в чем странность. Строка 84 в startup.php находится в функции deregister_globals, а эта функция выполняется только если в настройках php register_globals включен (по phpinfo - отключен). Таким образом, на строку 84 мы никак не можем попадать))

Кстати, строка 19 в common.php цепляет этот самый startup.php - на этой строке в common.php тоже были вылеты по памяти.

Очевидная лажа хостера, которую он не желает признавать ! Может, у него диск давно рухнул и всё запуталось, или кэширование дурное, а может, у него шаловливые ручки маленько поправили какой-то код, да что угодно может быть, вплоть до вульгарного дефекта модуля памяти.
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

c61, у меня нет слов! Пошел писать хостеру о выключенных функциях...
Спасибо.

Добавлено спустя 3 минуты 33 секунды:
Файл phpinfo.php можно удалить?
Аватара пользователя
c61
phpBB 2.0.6
Сообщения: 506
Стаж: 13 лет 9 месяцев
Благодарил (а): 42 раза
Поблагодарили: 251 раз

Re: Fatal error: Allowed memory size

Сообщение c61 »

Raisin, по phpinfo видно, что используется mod_php. См., например, по ссылке отличия mod_php и php fastcgi. Этот mod_php при неумелой настройке может стать источником совершенно непонятных ошибок))

phpinfo можно удалять.
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

Хостер сказал добавить: php_value register_globals on в .htaccess, так и сделал... Посмотрим, как дальше обстоят дела.
Аватара пользователя
c61
phpBB 2.0.6
Сообщения: 506
Стаж: 13 лет 9 месяцев
Благодарил (а): 42 раза
Поблагодарили: 251 раз

Re: Fatal error: Allowed memory size

Сообщение c61 »

Raisin писал(а):php_value register_globals on
Необходимы полные бэкапы перед таким экспериментом. Вся эта ерунда может также быть из-за дырявости хостинга на предмет атак с использованием register_globals.
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

Ну, блин, опять:

Код: Выделить всё

[18-May-2013 17:30:58 Europe/Moscow] PHP Fatal error:  Allowed memory size of 201326592 bytes exhausted (tried to allocate 1853187651 bytes) in /home/bh49858/public_html/common.php on line 19
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Fatal error: Allowed memory size

Сообщение Пчелкин »

Да разводит тебя хостер подключая не твои запросы ...есть такое...на более мощные ресурсы разводит...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

Пчелкин, дружище! Вы знали?!
Вот и вышла ошибка на форуме моего друга:

Код: Выделить всё

[19-May-2013 17:37:02 Europe/Moscow] PHP Fatal error:  Allowed memory size of 201326592 bytes exhausted (tried to allocate 1853187649 bytes) in /home/bh49995/public_html/common.php on line 19
http://doctorvet.net/ - форум по прежнему пуст... Интересно, они даже цифры (требуемую память) не меняют, мои цифры - 201326592, форум друга - 201326592 :lol:

Добавлено спустя 3 минуты 37 секунд:
Кстати много запросов на странице FAQ из-за мода рекламы и меню, отключаю эти моды и запросов всего семь, это нормально?
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Fatal error: Allowed memory size

Сообщение Пчелкин »

Raisin писал(а):Пчелкин, дружище! Вы знали?!
Я это прошел уже...полтора года назад...щас другим с подобным помогаю тикать на нормальные хосты...Вроде малость научился перевозить форумы...вот и ваяю...
Одно угнетает - у меня трафики шибко медленные - дальевосточные...возни по времени много...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: Fatal error: Allowed memory size

Сообщение MIT »

Raisin писал(а):Интересно, они даже цифры (требуемую память) не меняют
Дружище, ты б ошибки-то хоть читал. Написано же: лимит в 201326592 байт (ровно 192 мегабайта) исчерпан при попытке зарезервировать 1767 мегабайт.
Raisin писал(а):это нормально?
Да
Пчелкин писал(а):возни по времени много...
Купи RDP сервер в Европе, подключайся и гоняй трафик через него.
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

MIT писал(а):Дружище, ты б ошибки-то хоть читал.
Я понял, что написано, я просто не так выразился...
Спасибо.
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Fatal error: Allowed memory size

Сообщение Slash »

Сменил хостера. Ошибка пока не появляется!
Стоя пью зелье от сглаза.

Вернуться в «Поддержка phpBB 3.0.х»