Проблема при переходе на nginx
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
orsi
- phpBB 1.4.1
- Сообщения: 49
- Стаж: 16 лет 11 месяцев
- Забанен: Бессрочно
Проблема при переходе на nginx
При переходе на nginx форум выдаёт ошибку 400:
---------------
400 Bad Request
nginx/0.7.63
-----------------------
Кто знает как решается эта проблема с phpbb?
Ошибка выдаётся в браузерах Опера и Мозилла. В IE и ГуглХром эта ошибка не появляется.
Проблема решается чисткой куки.
НО. На хосинге у меня ещё есть несколько сайтов с другими движками - там всё ОК.
И юзерам же не объяснишь что нужно почистить куки, они видят ошибку 400.
Вот такая проблема.
Что нужно сделать чтобы её решить?
---------------
400 Bad Request
nginx/0.7.63
-----------------------
Кто знает как решается эта проблема с phpbb?
Ошибка выдаётся в браузерах Опера и Мозилла. В IE и ГуглХром эта ошибка не появляется.
Проблема решается чисткой куки.
НО. На хосинге у меня ещё есть несколько сайтов с другими движками - там всё ОК.
И юзерам же не объяснишь что нужно почистить куки, они видят ошибку 400.
Вот такая проблема.
Что нужно сделать чтобы её решить?
-
nissin
- phpBB 3.0.4
- Сообщения: 2229
- Стаж: 18 лет 9 месяцев
- Откуда: Астана
- Благодарил (а): 7 раз
- Поблагодарили: 344 раза
Re: Проблема при переходе на nginx
Пошаманить в nginx.
http://www.ruby-forum.com/topic/173362
http://blog.andrewvc.com/big-cookies-and-nginx
http://nginx.org/pipermail/nginx/2009-D ... 17351.html
http://www.ruby-forum.com/topic/173362
И ещёMaxim Dounin писал(а):Anyway, the problem is that client sent too long Cookie header to nginx.
Quick fix is to enlarge large_client_header_buffers. And the next thing to tune is proxy_buffer_size, which in turn will require enlargement.
http://blog.andrewvc.com/big-cookies-and-nginx
http://nginx.org/pipermail/nginx/2009-D ... 17351.html
Andrew Cholakian писал(а):I recently ran into this where very large (4.7kib) cookies from IE were causing requests to my nginx server to fail with 400 Bad Request errors. The underlying problem--besides the erroneously large cookie--was a too small large_client_header_buffers value. According to the nginx docs (http://wiki.nginx.org/NginxHttpCoreModu ... er_buffers): "The request line can not be bigger than the size of one buffer, if the client send a bigger header nginx returns error "Request URI too large" (414). The longest header line of request also must be not more than the size of one buffer, otherwise the client get the error "Bad request" (400)."
-
orsi
- phpBB 1.4.1
- Сообщения: 49
- Стаж: 16 лет 11 месяцев
- Забанен: Бессрочно
Re: Проблема при переходе на nginx
nissin
А в самом phpbb нельзя ничего сделать?
Потому что другие движки не глючат так...
А в самом phpbb нельзя ничего сделать?
Потому что другие движки не глючат так...
-
nissin
- phpBB 3.0.4
- Сообщения: 2229
- Стаж: 18 лет 9 месяцев
- Откуда: Астана
- Благодарил (а): 7 раз
- Поблагодарили: 344 раза
Re: Проблема при переходе на nginx
Если указанное выше верно, то это не совсем зависит от движка.
Для проверки попробуйте после 400-й ошибки открыть например docs/README.html (это чистый HTML)
Вкратце если не поняли суть, браузер при каждом запросе передаёт веб-серверу список установленных для данного домена кук, если переданный размер превышает определённое значение nginx взбрыкивает и выдаёт 400 ошибку.
На всякий случай уточню, у Вас информация о прочитанных темах не в cookies хранится?
Для проверки попробуйте после 400-й ошибки открыть например docs/README.html (это чистый HTML)
Вкратце если не поняли суть, браузер при каждом запросе передаёт веб-серверу список установленных для данного домена кук, если переданный размер превышает определённое значение nginx взбрыкивает и выдаёт 400 ошибку.
На всякий случай уточню, у Вас информация о прочитанных темах не в cookies хранится?
Код: Выделить всё
Включить маркировку тем на сервере:
Сохранять информацию о статусе «прочитано/не прочитано» в базе данных, а не в cookies.-
orsi
- phpBB 1.4.1
- Сообщения: 49
- Стаж: 16 лет 11 месяцев
- Забанен: Бессрочно
Re: Проблема при переходе на nginx
Включить маркировку тем на сервере:
Сохранять информацию о статусе «прочитано/не прочитано» в базе данных, а не в cookies.
Здесь у меня стоит НЕТ
Добавлено спустя 1 минуту 46 секунд:
Т.е. лучше поставить ДА?
Сохранять информацию о статусе «прочитано/не прочитано» в базе данных, а не в cookies.
Здесь у меня стоит НЕТ
Добавлено спустя 1 минуту 46 секунд:
Т.е. лучше поставить ДА?
-
Rayden
- Former team member
- Сообщения: 3739
- Стаж: 21 год 2 месяца
- Поблагодарили: 44 раза
-
orsi
- phpBB 1.4.1
- Сообщения: 49
- Стаж: 16 лет 11 месяцев
- Забанен: Бессрочно
Re: Проблема при переходе на nginx
Хостер сам настраивает.Rayden писал(а):Лучше настроить nginx нормально
Я им сказал они установили.
Пошли глюки с куки.
На других форумных движках таких проблем не случилось.
-
Rayden
- Former team member
- Сообщения: 3739
- Стаж: 21 год 2 месяца
- Поблагодарили: 44 раза
Re: Проблема при переходе на nginx
Если сегодня не случилось, не значит что завтра не случится.
Ну сказано же, что по умолчанию у nginx слишком маленький буфер для кук, надо увеличить.
Ну сказано же, что по умолчанию у nginx слишком маленький буфер для кук, надо увеличить.
-
orsi
- phpBB 1.4.1
- Сообщения: 49
- Стаж: 16 лет 11 месяцев
- Забанен: Бессрочно
Re: Проблема при переходе на nginx
Вообще ни разу такого не было.Rayden писал(а):Если сегодня не случилось, не значит что завтра не случится.
-
nissin
- phpBB 3.0.4
- Сообщения: 2229
- Стаж: 18 лет 9 месяцев
- Откуда: Астана
- Благодарил (а): 7 раз
- Поблагодарили: 344 раза
Re: Проблема при переходе на nginx
Думаю что на будущее нужно поставить да, хранить информацию о прочитанных темах в cookies не комильфо (у клиента как-то раз на двойке из-за этого возникли проблемы, пришлось в коде phpbb обрезать их размер до одного килобайта).orsi писал(а):Т.е. лучше поставить ДА?
Ну и nginx тоже настроить не помешает.
-
orsi
- phpBB 1.4.1
- Сообщения: 49
- Стаж: 16 лет 11 месяцев
- Забанен: Бессрочно
Re: Проблема при переходе на nginx
Хостеру писал об этой проблеме. Сказал что всё пучком. А я лично в этом особо не шарю :)nissin писал(а):Ну и nginx тоже настроить не помешает.
Т.е. "Включить маркировку тем на сервере:nissin писал(а):Думаю что на будущее нужно поставить да, хранить информацию о прочитанных темах в cookies не комильфо
Сохранять информацию о статусе «прочитано/не прочитано» в базе данных, а не в cookies."
Отметить флажком "ДА"?
Если "ДА", то тогда будет храниться в базе данных. У меня сейчас стоит "НЕТ", т.е. хранить в куках....
У кого из нас лыжи не едут? :)
-
crash
- Former team member
- Сообщения: 6517
- Стаж: 22 года 2 месяца
- Откуда: Бердск
- Поблагодарили: 15 раз
Re: Проблема при переходе на nginx
вам и говорят что лучше в базе. Про какие лыжи речь?orsi писал(а):У кого из нас лыжи не едут?
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
-
orsi
- phpBB 1.4.1
- Сообщения: 49
- Стаж: 16 лет 11 месяцев
- Забанен: Бессрочно

