Восстановление БД из архива - Ошибка

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
cossack
phpBB 1.0.0
Сообщения: 4
Стаж: 14 лет 10 месяцев
Благодарил (а): 2 раза

Восстановление БД из архива - Ошибка

Сообщение cossack »

Здравствуйте.

При восстановлении БД для форума на phpBB, как обычно до этого, делал следующим образом:
- удалил старые, залил новые файлы сайта на хостинг
- удалил старую БД и пользователя, создал новую БД и пользователя, пароль остался такой же
- через PHPMyAdmin зашел в созданную новую базу и с помощью "Импорт" залил sql-файл архивной копии БД

Выдает следующее:

Код: Выделить всё

Ошибка
SQL-запрос:

INSERT INTO `phpbb_users` VALUES (1,2,1,'00000000003khra3nk\n\n\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000\ni1cjyo000000',0,'',1282027440,'Anonymous','anonymous','',0,0,'',0,'',0,0,0,'','ZZ93T0C4ZK',1321729907,0,0,0,0,0,1,'en','0.00',0,'d M Y H:i',33,0,'',0,0,0,0,-3,0,0,'t','d',0,'t','a',0,1,0,1,1,1,0,230271,'',0,0,0,'','','','','','','','','','','','','','','23a96bf76207006b',1,0,0),(2,3,5,'zik0zjzik0zjzik0xs\n\n\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000\nzik0zi000000',0,'91.211.212.2',1282027440,'Sam','sam','$H$9.jI/JzysuhLRmVddF3lEyOGg4.KsB.',[...]

Ответ MySQL: 

#1062 - Duplicate entry 'o?»?ra' for key 'username_clean'
Форум все-таки работает, но отображается только структура, когда заходишь в саму тему, выдает следующее:

Код: Выделить всё

Общая ошибка
SQL ERROR [ mysql4 ]

Table 'artmedia_forum.phpbb_zebra' doesn't exist [1146]

Произошла ошибка SQL при выборке на этой странице. Пожалуйста, сообщите администратору, если ошибка будет повторяться.
Пробовал из разных архивных копий, разницей в неделю - результат идентичен

Уважаемые, кто может помочь с такой катастрофической для меня проблемой? Спасибо.

Восстановил еще одну копию - доступен еще и такой вариант, вместо отображения форума в целом

Код: Выделить всё

Общая ошибка
SQL ERROR [ mysql4 ]

Table 'artmedia_forum.phpbb_words' doesn't exist [1146]

Произошла ошибка SQL при выборке на этой странице. Пожалуйста, сообщите администратору, если ошибка будет повторяться.
Последний раз редактировалось Sheer 11.12.2011 19:44, всего редактировалось 1 раз.
Причина: Красный цвет - модераторский. Не пугайте других участников форума. Есть bb-код [code][\code]
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Восстановление БД из архива - Ошибка

Сообщение Sheer »

Перевести?
Duplicate entry - дублирование значения.
Table 'artmedia_forum.phpbb_zebra' doesn't exist - таблица phpbb_zebra не существует.
Table 'artmedia_forum.phpbb_words' doesn't exist - таблица phpbb_words не существует.

Ну вот резервные копии у тебя такие... Или восстанавливаешь вот как-то так... через ж
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
cossack
phpBB 1.0.0
Сообщения: 4
Стаж: 14 лет 10 месяцев
Благодарил (а): 2 раза

Re: Восстановление БД из архива - Ошибка

Сообщение cossack »

Ну, прежде всего, извините за красный цвет

Хоть убейте, не пойму куда могли деться эти таблицы. А восстанавливаю, вроде как, стандартным способом (описанным выше), коим уже пользовался до этого без всяких проблем.
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Восстановление БД из архива - Ошибка

Сообщение Sheer »

cossack писал(а):стандартным способом
Каким "стандартным"? Как получали резервную копию? Как восстанавливаете? Средствами админки, PMA или еще как? Это все "стандартные"...
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
cossack
phpBB 1.0.0
Сообщения: 4
Стаж: 14 лет 10 месяцев
Благодарил (а): 2 раза

Re: Восстановление БД из архива - Ошибка

Сообщение cossack »

Архивную копию делал через панель хостинг провайдера (архив с sql файлом сливал по FTP), файловый архив так же. Импортировал базу через "Импорт" в PHPMyAdmin.

Изображение

PS. Спасибо, что откликнулись
Аватара пользователя
HAMMER663
Former team member
Сообщения: 2032
Стаж: 16 лет 5 месяцев
Откуда: Зеленоград
Благодарил (а): 77 раз
Поблагодарили: 249 раз

Re: Восстановление БД из архива - Ошибка

Сообщение HAMMER663 »

скорее всего не все таблицы вы экспортировали.. попробуйте повторить попытку бекапа бд
либо сделайте следующее

Код: Выделить всё

CREATE TABLE `artmedia_forum.phpbb_words` (
  `word_id` mediumint(8) unsigned NOT NULL auto_increment,
  `word` varchar(255) collate utf8_bin NOT NULL default '',
  `replacement` varchar(255) collate utf8_bin NOT NULL default '',
  PRIMARY KEY  (`word_id`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin AUTO_INCREMENT=1 ;

CREATE TABLE `artmedia_forum.phpbb_zebra` (
  `user_id` mediumint(8) unsigned NOT NULL default '0',
  `zebra_id` mediumint(8) unsigned NOT NULL default '0',
  `friend` tinyint(1) unsigned NOT NULL default '0',
  `foe` tinyint(1) unsigned NOT NULL default '0',
  PRIMARY KEY  (`user_id`,`zebra_id`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin;

Вернуться в «Поддержка phpBB 3.0.х»