Не вижу форум!

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
ajmal
phpBB 1.0.0
Сообщения: 9
Стаж: 21 год

Не вижу форум!

Сообщение ajmal »

Друзья, прошу прощения если повторюсь с кем-то, но буду благодарен если кто-то сталкивался с подобной проблемой. Пытаюсь зайти на форум... и как обычно по ссылке **..../forum/phpBB3/index.php выдает ошибку

500 Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@westbaptist.ru and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Подскажите пожалуйста что надо проверить чтобы определить причину падение форума. Я даже не знаю куда посмотреть потому что не могу зайти на него. Заранее спасибо!
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Не вижу форум!

Сообщение Татьяна5 »

ajmal писал(а):More information about this error may be available in the server error log
Что в error_log пишет?

И что делали перед падением? (Если совсем ничего - возможно проблема со стороны хостинга)
ajmal
phpBB 1.0.0
Сообщения: 9
Стаж: 21 год

Re: Не вижу форум!

Сообщение ajmal »

вообще ничего не делал, форум работал в штатном режиме. А где просмотреть error_log файлы? На сервере? Тогда я увидел следующее...

Код: Выделить всё

[Wed Feb 27 16:38:02 2013] [error] [client 95.54.119.140] File does not exist: /home/westbapt/public_html/500.shtml, referer: http://site.ru/
[Wed Feb 27 16:38:02 2013] [error] [client 95.54.119.140] SoftException in Application.cpp:313: File "/home/westbapt/public_html/forum/phpBB3/index.php" is writeable by group, referer: http://site.ru/
[Wed Feb 27 16:20:40 2013] [error] [client 31.128.83.193] File does not exist: /home/westbapt/public_html/forum/phpBB3/forum, referer: http://www.site.ru/forum/phpbb3/viewtopic.php?f=22&t=28
[Wed Feb 27 16:18:23 2013] [error] [client 188.138.149.40] File does not exist: /home/westbapt/public_html/forum/phpbb3, referer: http://site.ruforum/phpbb3/index.php
[Wed Feb 27 16:18:23 2013] [error] [client 188.138.149.40] File does not exist: /home/westbapt/public_html/500.shtml, referer: http://site.ru/forum/phpBB3/index.php
[Wed Feb 27 16:18:23 2013] [error] [client 188.138.149.40] SoftException in Application.cpp:313: File "/home/westbapt/public_html/forum/phpBB3/index.php" is writeable by group, referer: http://site.ru/forum/phpBB3/index.php
[Wed Feb 27 16:06:17 2013] [error] [client 95.54.119.140] File does not exist: /home/westbapt/public_html/500.shtml, referer: http://site.ru/
[Wed Feb 27 16:06:17 2013] [error] [client 95.54.119.140] SoftException in Application.cpp:313: File "/home/westbapt/public_html/forum/phpBB3/index.php" is writeable by group, referer: http://site.ru/
[Wed Feb 27 16:00:22 2013] [error] [client 199.21.99.88] File does not exist: /home/westbapt/public_html/403.shtml
[Wed Feb 27 16:00:22 2013] [error] [client 199.21.99.88] (13)Permission denied: file permissions deny server access: /home/westbapt/public_html/robots.txt
[Wed Feb 27 15:57:42 2013] [error] [client 95.54.119.140] File does not exist: /home/westbapt/public_html/500.shtml, referer: http://site.ru/
[Wed Feb 27 15:57:42 2013] [error] [client 95.54.119.140] SoftException in Application.cpp:313: File "/home/westbapt/public_html/forum/phpBB3/index.php" is writeable by group, referer: http://site.ru
[Wed Feb 27 15:57:13 2013] [error] [client 95.54.119.140] File does not exist: /home/westbapt/public_html/500.shtml
[Wed Feb 27 15:57:13 2013] [error] [client 95.54.119.140] SoftException in Application.cpp:313: File "/home/westbapt/public_html/forum/phpBB3/index.php" is writeable by group
[Wed Feb 27 15:51:57 2013] [error] [client 95.54.119.140] File does not exist: /home/westbapt/public_html/forum/phpBB3/login.php
[Wed Feb 27 15:20:33 2013] [error] [client 91.224.246.179] File does not exist: /home/westbapt/public_html/forum/phpBB3/forum, referer: http://site.ru/forum/phpbb3/index.php
Последний раз редактировалось Татьяна5 28.02.2013 0:18, всего редактировалось 1 раз.
Причина: [code]
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Не вижу форум!

Сообщение Татьяна5 »

ajmal писал(а):SoftException in Application.cpp:313: File ... is writeable by group
Permission denied
File does not exist
Неправильные права доступа
Доступ запрещен
Файл не найден

Узнавайте на техподдержке хостинга, что произошло. Права доступа сами по себе не должны слетать, и тем более исчезать файлы
ajmal
phpBB 1.0.0
Сообщения: 9
Стаж: 21 год

Re: Не вижу форум!

Сообщение ajmal »

Спасибо. Узнаю!
ajmal
phpBB 1.0.0
Сообщения: 9
Стаж: 21 год

Re: Не вижу форум!

Сообщение ajmal »

Пообщался с хостпровайдером. Ребята из техподдержки сказали что не видят ничего необычного, что проблема в самом форуме. Опять тупик...
Аватара пользователя
c61
phpBB 2.0.6
Сообщения: 506
Стаж: 13 лет 9 месяцев
Благодарил (а): 42 раза
Поблагодарили: 251 раз

Re: Не вижу форум!

Сообщение c61 »

Обратите внимание на пути:
ajmal писал(а):/home/westbapt/public_html/forum/phpbb3
ajmal писал(а):/home/westbapt/public_html/forum/phpBB3/
Вы установили phpbb от корня html в /forum/phpBB3 ? А какие пути ставили в админке (общие - настройки сервера) ? Вообще-то на второй уровень обычно не загоняют... Но это не беда, а вот это:
ajmal писал(а):is writeable by group
. Установите для /forum с вложенными подкаталогами и файлами права 755. Затем для вложенных cache, uploads, dowload, store - 777. Псомотрите, что будет... Ничего не изменится - для файлов ставьте 644.
Спросите у хостера: какие права нужны для файлов php, иногда хостеры искренне заблуждаются... А также могут быть реально мерзкие глюки, если пользуетесь встроенным в панель управления хостера ftp-клиентом ! Он может работать неизвестно от какого пользователя, и в результате права выставляются неверно. Попробуйте, например, через Far3 или иной ftp-клиент.

Вернуться в «Поддержка phpBB 3.0.х»