413 Request Entity Too Large при загрузке вложений

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
HAMMER663
Former team member
Сообщения: 2032
Стаж: 16 лет 5 месяцев
Откуда: Зеленоград
Благодарил (а): 77 раз
Поблагодарили: 249 раз

413 Request Entity Too Large при загрузке вложений

Сообщение HAMMER663 »

При загрузке вложений на форум любого размера появляется такая ошибка 413 Request Entity Too Large.
Я полез в файл конфигурации nginx и изменил значение директивы client_max_body_size с 4m до 100m
И радостный полез проверять вложения, а они все равно не загружаются - та же ошибка.
Версия форума 3.0.11.
Никаких действий со стороны хостинга и форума не производилось. Появилось недавно ни с того ни с сего.
Причем ошибка возникает не у всех. Как-то выборочно. Так как я без проблем загружаю любые файлы.
Может есть еще какие-то другие причины данной ошибки?
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: 413 Request Entity Too Large при загрузке вложений

Сообщение MIT »

Как настроен веб-сервер?
fpm->nginx? apache->nginx?

Куда прописывал эту директиву? В основной блок http {} или в персональный для хоста?
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: 413 Request Entity Too Large при загрузке вложений

Сообщение rxu »

HAMMER663 писал(а):полез в файл конфигурации nginx и изменил значение директивы client_max_body_size с 4m до 100m
И радостный полез проверять вложения
На всякий, спрошу: nginx перезапустил? :P
Изображение
Аватара пользователя
HAMMER663
Former team member
Сообщения: 2032
Стаж: 16 лет 5 месяцев
Откуда: Зеленоград
Благодарил (а): 77 раз
Поблагодарили: 249 раз

Re: 413 Request Entity Too Large при загрузке вложений

Сообщение HAMMER663 »

rxu перезапустил :D
МIT, тебе отвечу позже ;)
Алсидес
phpBB 1.4.4
Сообщения: 143
Стаж: 13 лет 11 месяцев
Благодарил (а): 57 раз
Поблагодарили: 9 раз

Re: 413 Request Entity Too Large при загрузке вложений

Сообщение Алсидес »

Точно такое было у меня, когда создал форум. Но после того как хостер всё исправил проблема исчезла. Но хотя это разные вещи Internal Server Error у меня был.
Последний раз редактировалось Алсидес 06.07.2013 5:49, всего редактировалось 1 раз.
php и HTML - учусь, а CSS и JavaScript пока 0%
Аватара пользователя
HAMMER663
Former team member
Сообщения: 2032
Стаж: 16 лет 5 месяцев
Откуда: Зеленоград
Благодарил (а): 77 раз
Поблагодарили: 249 раз

Re: 413 Request Entity Too Large при загрузке вложений

Сообщение HAMMER663 »

Алсидес совсем разные ошибки..
Аватара пользователя
HAMMER663
Former team member
Сообщения: 2032
Стаж: 16 лет 5 месяцев
Откуда: Зеленоград
Благодарил (а): 77 раз
Поблагодарили: 249 раз

Re: 413 Request Entity Too Large при загрузке вложений

Сообщение HAMMER663 »

MIT писал(а):fpm->nginx? apache->nginx?
Сейчас работает апач и nginx в качестве проксирующего сервера.
MIT писал(а):Куда прописывал эту директиву? В основной блок http {} или в персональный для хоста?
В блок http.
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: 413 Request Entity Too Large при загрузке вложений

Сообщение MIT »

HAMMER663 писал(а): работает апач и nginx
Каким сервером подписана 413-ая ошибка? Быть может, её отдаёт Апач?
Аватара пользователя
HAMMER663
Former team member
Сообщения: 2032
Стаж: 16 лет 5 месяцев
Откуда: Зеленоград
Благодарил (а): 77 раз
Поблагодарили: 249 раз

Re: 413 Request Entity Too Large при загрузке вложений

Сообщение HAMMER663 »

MIT не могу сказать. пользователи не читают такие буковки.. И у меня когда появлялась такая ошибка, то я тоже не обратил внимание.
А если ее отдает апач, то как быть?
Но, по-моему, там было написано nginx.
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: 413 Request Entity Too Large при загрузке вложений

Сообщение MIT »

HAMMER663 писал(а):А если ее отдает апач, то как быть?
У Апача есть аналогичный параметр — LimitRequestBody.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: 413 Request Entity Too Large при загрузке вложений

Сообщение rxu »

HAMMER663 писал(а):не могу сказать. пользователи не читают такие буковки
В логе ошибок сервера посмотри.
Изображение
Аватара пользователя
HAMMER663
Former team member
Сообщения: 2032
Стаж: 16 лет 5 месяцев
Откуда: Зеленоград
Благодарил (а): 77 раз
Поблагодарили: 249 раз

Re: 413 Request Entity Too Large при загрузке вложений

Сообщение HAMMER663 »

rxu писал(а):В логе ошибок сервера посмотри.
К сожалению за последние 10 дней ошибка не вылезала и в логах ничего нет.. Или все прошло? Пока тестирую
Аватара пользователя
HAMMER663
Former team member
Сообщения: 2032
Стаж: 16 лет 5 месяцев
Откуда: Зеленоград
Благодарил (а): 77 раз
Поблагодарили: 249 раз

Re: 413 Request Entity Too Large при загрузке вложений

Сообщение HAMMER663 »

LimitRequestBody в конфигурации apache сейчас не прописан, я так понял, что идет значение по умолчанию - 0( не ограничено)
Аватара пользователя
Perfecthus
phpBB 2.0.14
Сообщения: 958
Стаж: 15 лет 11 месяцев
Откуда: Оттуда
Благодарил (а): 68 раз
Поблагодарили: 112 раз

Re: 413 Request Entity Too Large при загрузке вложений

Сообщение Perfecthus »

HAMMER663 писал(а):При загрузке вложений на форум любого размера появляется такая ошибка 413 Request Entity Too Large
Была такая же ошибка, увеличил размер загружаемых на сервер файлов в nginx и всё прошло :)

Вернуться в «Поддержка phpBB 3.0.х»