Ошибка mysql при импорте базы (phpbb_posts)

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Eridani
phpBB 1.4.2
Сообщения: 56
Стаж: 13 лет
Благодарил (а): 17 раз

Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Eridani »

Всем наидобрейшего!
Постараюсь максимально доступно объяснить суть своей проблемы и, как я её вижу, но сразу скажу, что с sql общаюсь плохо, никак не доберусь до изучения.

Давным давно, в далекой галактике, у нас перестал работать импорт БД, то есть, случись что, если нас турнут с хостинга, то это будет серьезной проблемой. Он работает, но выдает ошибки в phpbb_posts.
Все вы знаете, что хостинг каждодневно делает автоматические бэкапы, как самой структуры сайта, так и БД. Если делать откат через это, то вылезут ошибки, и если загружать этот автоматический дамп через phpmyadmin (импорт) - то тоже ошибки...
А вот если зайти в phpmyadmin, экспортировать БД оттудава, и туда же потом импортировать - ошибок нет, и все встает нормально. Но я то знаю, что ошибка есть.
Вчера, пытаясь поставить БД на локальную машину, дабы тестить форум не лазая на хостинг, вновь вспомнил о проблеме и решил попросить помощи, т.к. сам я тут точно не справлюсь.

Вот и сама ошибка:

Код: Выделить всё

 Ошибка

Ответ MySQL: Документация
#1062 - Duplicate entry '?' for key 2


Это я загрузил автоматический дамп от хостинга/

А ниже - тот, который я сам экспортировать через phpmyadmin и обратно через него же залил, но уже не на хостинг, а на локальную машину, т.к. я уже выше говорил о том, что если бы я экспорт и импорт сделал через phpmyadmin в пределах хостинга, то проблем не возникает, а локальный сервер принимать ни один из этих бэкапов не хочет.

Код: Выделить всё

SQL-запрос:

INSERT INTO `phpbb_posts` (`post_id`, `topic_id`, `forum_id`, `poster_id`, `icon_id`, `poster_ip`, `post_time`, `post_created`, `post_approved`, `post_reported`, `enable_bbcode`, `enable_smilies`, `enable_magic_url`, `enable_sig`, `post_username`, `post_subject`, `post_text`, `post_checksum`, `post_attachment`, `bbcode_bitfield`, `bbcode_uid`, `post_postcount`, `post_edit_time`, `post_edit_reason`, `post_edit_user`, `post_edit_count`, `post_edit_locked`, `post_expire_time`) VALUES (9095, 5010, 350, 3524, 0, '46.147.87.217', 1322731597, 0, 1, 0, 1, 1, 1, 1, '', 'Фирмы Австрии', 0x3c212d2d2065202d2d3e3c6120687265663d226d61696c746f3a30302e353139333840696e6f64652e6174223e30302e353139333840696e6f64652e61743c2f613e3c212d2d2065202d2d3e0a3c212d2d2065202d2d3e3c6120687265663d226d61696c746f3a303233394061742e6174752e6575223e303233394061742e6174752e65753c2f613e3c212d2d2065202d2d3e0a3c212d2d2065202d2d3e3c6120687265663d226d61696c746f3a3036313035406c6c2e6f6f656c66762e6174223e3036313035406[...]

Ответ MySQL: Документация
#2006 - MySQL server has gone away 
Интуитивно я понял, что 9095 - post id, и по старой привычке "не работает - удали к фигам", нашел и потер этот пост из phpbb_posts. Попробовал опять импортировать, но уже без этого поста 9095. Ну, теперь он ругается на другой номер поста, это и 9096, это и 10340 и т.п. Сколько их там и сколько мне нужно сидеть, экспортируя и импортируя, дабы выявить все эти проблемные посты и перешмалять их - не знаю.

Возможно, что я вцелом ошибаюсь, и не надо ничего удалять, а можно как то поправить, но я "озвучил" это так, как думал сам, дабы была понятнее цепочка моих движений и чем руководствовался.

Помогите, пожалуйста, справится с проблемой :(
Аватара пользователя
Pazh
Former team member
Сообщения: 2317
Стаж: 16 лет 10 месяцев
Благодарил (а): 42 раза
Поблагодарили: 506 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Pazh »

Eridani писал(а):Duplicate entry
означает попытку создать индекс, который уже есть. Выложи полный текст ошибки или выясняй что за индекс на phpb_post у тебя стоит и в каой ячейке вставляемой записи поста стоит "?"
Помощь в ЛС/email только за WM или ЮMoney
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Sheer »

Надо не интуитивно понимать, а читать сообщения об ошибках, и изучать документацию.

Код: Выделить всё

Ответ MySQL: Документация
#2006 - MySQL server has gone away
Что означает, что твой MySQL "упал", то есть не справился с возложенной задачей в рамках отведенных ресурсов для выполнения этой задачи.

Добавлено спустя 6 минут 56 секунд:
Чтоб не падал MySQLDumper
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
Eridani
phpBB 1.4.2
Сообщения: 56
Стаж: 13 лет
Благодарил (а): 17 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Eridani »

Pazh, а это и был полный текст ошибки. Я, если бы знал, где там ковыряться, но мне было бы куда проще, я само строение базы не знаю, где там ячейки, записи и т.п. могу только интуитивно лазать как старый пользователь ПК.
Вот я сейчас загрузил на хостинг автоматический дамп, он мне выдал опять 1062, а при попытке войти на форум, браузер пишет

Код: Выделить всё

SQL ERROR [ mysqli ]

Table 'rogue_fish.phpbb_users' doesn't exist [1146]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
Залез в базу, посмотрел, увидел, что таблиц после phpbb_search_wordlist больше нет, а там должны быть ещё порядка 20-ти штук

Код: Выделить всё

        phpbb_search_wordmatch
	phpbb_sessions
	phpbb_sessions_keys
	phpbb_sitelist
	phpbb_smilies
	phpbb_smilies_categories
	phpbb_styles
	phpbb_styles_imageset
	phpbb_styles_imageset_data 
	phpbb_styles_template 
	phpbb_styles_template_data
	phpbb_styles_theme
	phpbb_thanks 
 	phpbb_topics 
	phpbb_topics_posted 
	phpbb_topics_track
	phpbb_topics_watch
	phpbb_users
	phpbb_user_group
	phpbb_warnings
	phpbb_words
	phpbb_wpm
	phpbb_wwh
	phpbb_zebra
Эти вот отсутствуют

Добавлено спустя 3 минуты 35 секунд:
Sheer писал(а):Надо не интуитивно понимать, а читать сообщения об ошибках, и изучать документацию.

Код: Выделить всё

Ответ MySQL: Документация
#2006 - MySQL server has gone away
Что означает, что твой MySQL "упал", то есть не справился с возложенной задачей в рамках отведенных ресурсов для выполнения этой задачи.

Добавлено спустя 6 минут 56 секунд:
Чтоб не падал MySQLDumper
Спасибы, посмотрю.
А мог ли упасть из-за того, что сам mysql на локальной машине не так настроен?
Вот этот автоматический дамп я залил на хостинг, выдает 1062, а загружаю его же на локальный, то как вы говорите - "упал"
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Sheer »

Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
Eridani
phpBB 1.4.2
Сообщения: 56
Стаж: 13 лет
Благодарил (а): 17 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Eridani »

Sheer, спасибо, БД экспортированная через phpmyadmin встала на локальный сервер, а автоматический дамп выдает при импорте ошибку

Код: Выделить всё

#1062 - Duplicate entry '?' for key 'wrd_txt' 
А где именно искать эти повторы, в word text?
Прошу простить, впервые сталкиваюсь с этим.
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Татьяна5 »

Eridani писал(а):wrd_txt
Именно так или word_text?

Что возвращает

Код: Выделить всё

SELECT * FROM `phpbb_search_wordlist` WHERE word_text = '?'
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Sheer »

Eridani писал(а):а автоматический дамп
Забей на него. Установи на сервере MySQLDumper и используй его, в том числе и для автоматического создания резервных копий.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
Eridani
phpBB 1.4.2
Сообщения: 56
Стаж: 13 лет
Благодарил (а): 17 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Eridani »

Татьяна5 писал(а):
Eridani писал(а):wrd_txt
Именно так или word_text?
Именно wrd_txt.
Что возвращает

Код: Выделить всё

SELECT * FROM `phpbb_search_wordlist` WHERE word_text = '?'
Честно? Ничего не понял, что куда возвращает? :) Мне эта строчка ни о чем не говорит) Я не так силен в этом

Добавлено спустя 1 минуту 1 секунду:
Sheer писал(а):
Eridani писал(а):а автоматический дамп
Забей на него. Установи на сервере MySQLDumper и используй его, в том числе и для автоматического создания резервных копий.
Поставил, но пока не разбирался, что к чему. А этот автоматически делает или тоже вручную надо?
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Sheer »

Выполни в PMA это запрос

Код: Выделить всё

SELECT * FROM `phpbb_search_wordlist` WHERE word_text = '?'
и отпиши о результате.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
Eridani
phpBB 1.4.2
Сообщения: 56
Стаж: 13 лет
Благодарил (а): 17 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Eridani »

Sheer,MySQL вернула пустой результат (т.е. ноль строк). ( Запрос занял 0.0003 сек. )
Booker
phpBB 2.0.7a
Сообщения: 627
Стаж: 15 лет 3 месяца
Благодарил (а): 165 раз
Поблагодарили: 21 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Booker »

Sheer писал(а):
Eridani писал(а):а автоматический дамп
Забей на него. Установи на сервере MySQLDumper и используй его, в том числе и для автоматического создания резервных копий.
Мне с похожими проблемами и MySQLDumper не помог, так что не панацея он. Просто не докачивал до конца, да и всё, точно так же выбивало ошибку.
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Sheer »

Booker писал(а):не панацея он
Вы просто не умеете его готовить.Eridani, Таблица search_wordlist для экспериментов не важна. Просто создай пустую таблицу. Так же не нужно содержимое forums_track, forums_watch, search_results, search_wordmatch
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
Eridani
phpBB 1.4.2
Сообщения: 56
Стаж: 13 лет
Благодарил (а): 17 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Eridani »

Sheer, согласен, не важна, и без неё все работает. Но, к чему я эту тему завел изначально - автоматический дамп, что бы каждодневно вручную его самому не делать, а таймвебовская автоматика, она импортируется с ошибкой и всё, что ниже этой ошибки, тупо не заливается и форум, естественно, не работает. Просто, хотел снять с себя груз, что бы ручной дамп не делать, ибо однажды и такое было, что у таймвеба что-то полетело, они восстановили базу, а т.к. она с ошибками была, я половину учетных записей, постов недосчитался, они даже не умудрились сообщить об этом изначально, пришлось потерроризировать их, и тут вскрылось, что они вручную её собрали.
Вот такая вот история )

P.S. Если дампер может сам их делать, без моего вмешательства, и импортируется после этого без пыли, то тогда и вопрос снимается)
Последний раз редактировалось Eridani 29.01.2014 15:56, всего редактировалось 1 раз.
Booker
phpBB 2.0.7a
Сообщения: 627
Стаж: 15 лет 3 месяца
Благодарил (а): 165 раз
Поблагодарили: 21 раз

Re: Ошибка mysql при импорте базы (phpbb_posts)

Сообщение Booker »

Sheer, возможно. Но мне в своё время так и не помогли, поудивлявшись, что с MySQLDumper такого не может быть. А оно было всё равно: Ошибки в индексах базы данных
В результате закончилось тем, что сделать ничего нельзя, надо идти понятно куда. Но MySQLDumper рулит, да.

Вернуться в «Поддержка phpBB 3.0.х»