Nginx 400 Bad Request

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
olegvmk
phpBB 1.2.0
Сообщения: 19
Стаж: 12 лет 2 месяца
Откуда: Зеленоград
Благодарил (а): 2 раза

Nginx 400 Bad Request

Сообщение olegvmk »

Привет, вчера устанавливал на форум мод - Prime Links, все исправно работало. Сегодня при попытке зайти на сайт получаю ошибку -

Код: Выделить всё

400 Bad Request
Request Header Or Cookie Too Large
nginx/1.2.4
Прочитал что ошибка связана с параметрами -

Код: Выделить всё

client_header_buffer_size
    large_client_header_buffers  

Вопросы у меня вот какие:
1. Может ли данная ошибка быть связаной с установкой мода Prime Links, (там в общем то ставить то и нечего, и если бы что-то было не так, ошибка 400 сразу бы вылезла а не на следующий день).
2. Может ли мне помочь ссылка - Удалить cookies конференции? (Только как мне теперь туда попасть?)
3. Есть бэкап, но все-таки хочется разобраться из за чего это, ошибка в коде или дело чисто в работе веб-сервера.
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Nginx 400 Bad Request

Сообщение Татьяна5 »

Куки в браузере чистить пробовали?
Аватара пользователя
olegvmk
phpBB 1.2.0
Сообщения: 19
Стаж: 12 лет 2 месяца
Откуда: Зеленоград
Благодарил (а): 2 раза

Re: Nginx 400 Bad Request

Сообщение olegvmk »

Татьяна5 Да конечно, разные браузеры пробовал.
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Nginx 400 Bad Request

Сообщение Татьяна5 »

Что в логе ошибок на сервере?
Аватара пользователя
olegvmk
phpBB 1.2.0
Сообщения: 19
Стаж: 12 лет 2 месяца
Откуда: Зеленоград
Благодарил (а): 2 раза

Re: Nginx 400 Bad Request

Сообщение olegvmk »

Татьяна5 Ничего, всмысле, либо файл логов не создается у хостера, либо у меня доступа к нему нет что скорее всего.
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Nginx 400 Bad Request

Сообщение Татьяна5 »

Поставьте копию форума на локалке. Ошибка там повторится? Если нет - обращайтесь к хостеру
Аватара пользователя
olegvmk
phpBB 1.2.0
Сообщения: 19
Стаж: 12 лет 2 месяца
Откуда: Зеленоград
Благодарил (а): 2 раза

Re: Nginx 400 Bad Request

Сообщение olegvmk »

Татьяна5 Копия есть и работает, в локалке. Я все моды и прочее ставлю сначала локально и только потом сливаю на хостинг. Плюс ко всему, вчерашний бэкап root директории доманипуляций тоже не работает, который 100% работал. Хостеру написал. Спасибо буду дальше разбираться.

Добавлено спустя 1 час 42 минуты 30 секунд:
Проблема была у провайдера. Спасибо еще раз. :D

Вернуться в «Поддержка phpBB 3.0.х»