Уважаемые пользователи phpBB Guru!

Напоминаем, что уже с 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
В связи с этим, с 1 января 2017 года форумы локализации, стилей и модификации phpBB 3.0, а также часть соответствующих тем FAQ (phpBB 3.0.x) на нашей конференции станут доступны только для чтения.
Полностью поддержка phpBB 3.0 будет прекращена на полгода позже, чем на официальном сайте - 1 июля 2017 года.

С учетом этого, рекомендуем использовать оставшиеся несколько месяцев до окончания поддержки версии 3.0 для перехода на более новые - phpBB 3.1 или 3.2 (когда финальный релиз последней станет доступен для скачивания).

Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Проблемы с установкой или работой phpBB 3.2.x? Получите помощь здесь!
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB3.1.x | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 12664
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 265 раз
Поблагодарили: 1135 раз
Контактная информация:

Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение rxu » 09.03.2015 13:42

Процедура обновления до phpBB 3.2 аналогична таковой для phpBB 3.1: Как сконвертировать phpBB 3.0.х в phpBB 3.1.х, за исключением: для обновления базы данных необходимо запустить в браузере /install/app.php, затем следовать инструкциям.

Работоспособность расширений от phpBB 3.1 не гарантирована. Более того, часть расширений (например, использующих систему уведомлений) гарантированно несовместима.

Минимальные системные требования для версии PHP повышены - не ниже PHP 5.4.0 (для phpBB 3.1 - 5.3.3).
Последний раз редактировалось владимир1983 15.10.2016 0:09, всего редактировалось 3 раза.
Изображение

Аватара пользователя
xisp
phpBB 3.0.0
Сообщения: 1895
Зарегистрирован: 19.05.2012 19:00
Откуда: http://www.phpbbguru.net/яссылко
Благодарил (а): 156 раз
Поблагодарили: 220 раз
Забанен: Бессрочно

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение xisp » 09.03.2015 16:08

rxu писал(а):Минимальные системные требования для версии PHP повышены - не ниже PHP 5.3.9


Давно 5.4 нужно ставить.
phpBBex

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 12664
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 265 раз
Поблагодарили: 1135 раз
Контактная информация:

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение rxu » 09.03.2015 16:10

xisp писал(а):Давно 5.4 нужно ставить.

Поддержка которого заканчивается 14.09.2015 г. ;)
Изображение

Sergiocharm
phpBB 2.0.7
Сообщения: 591
Зарегистрирован: 18.09.2010 16:03
Благодарил (а): 55 раз
Поблагодарили: 5 раз
Контактная информация:

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение Sergiocharm » 09.03.2015 16:24

rxu писал(а):phpBB 3.2

а где ознакомиться с новшествами в 3.2?

Аватара пользователя
xisp
phpBB 3.0.0
Сообщения: 1895
Зарегистрирован: 19.05.2012 19:00
Откуда: http://www.phpbbguru.net/яссылко
Благодарил (а): 156 раз
Поблагодарили: 220 раз
Забанен: Бессрочно

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение xisp » 09.03.2015 16:26

rxu писал(а):Поддержка которого заканчивается 14.09.2015 г.


Тем более. 5.3 с прошлого года не поддерживается разработчиками PHP, а разрабы phpBB всё ещё его поддерживают.
Моя бы воля- сразу бы 5.5 поставил в минимальные.
phpBBex

Аватара пользователя
Борис Бердичевский
phpBB 2.0.23
Сообщения: 1447
Зарегистрирован: 31.12.2007 1:52
Откуда: Израиль, Беэр-Шева
Благодарил (а): 44 раза
Поблагодарили: 78 раз
Контактная информация:

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение Борис Бердичевский » 09.03.2015 21:39

Плохо, если 5.4 не будет поддерживаться. 5.5 и выше требуют Апачи 2.4, которые у меня упорно не хотят работать нормально.
После нескольких лет общения здесь и техсопровождения форумов я наконец понял, что ничего не понимаю в phpBB!

Аватара пользователя
xisp
phpBB 3.0.0
Сообщения: 1895
Зарегистрирован: 19.05.2012 19:00
Откуда: http://www.phpbbguru.net/яссылко
Благодарил (а): 156 раз
Поблагодарили: 220 раз
Забанен: Бессрочно

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение xisp » 09.03.2015 21:51

Плохо, что у вас апач и венда.
phpBBex

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 12664
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 265 раз
Поблагодарили: 1135 раз
Контактная информация:

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение rxu » 28.09.2015 18:56

Минимальное требование к версии PHP для phpBB 3.2 установлено - PHP 5.4 и выше.
Изображение

Аватара пользователя
Борис Бердичевский
phpBB 2.0.23
Сообщения: 1447
Зарегистрирован: 31.12.2007 1:52
Откуда: Израиль, Беэр-Шева
Благодарил (а): 44 раза
Поблагодарили: 78 раз
Контактная информация:

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение Борис Бердичевский » 28.09.2015 19:55

Это значит, что поддержку SQLite 2.x можно наконец из кода выкинуть!
Кстати, довольно громоздкая операция -- выкидывание этого кода.
После нескольких лет общения здесь и техсопровождения форумов я наконец понял, что ничего не понимаю в phpBB!

Аватара пользователя
владимир1983
Former team member
Сообщения: 6103
Зарегистрирован: 27.04.2010 2:17
Откуда: Сергиев Посад
Благодарил (а): 409 раз
Поблагодарили: 737 раз
Контактная информация:

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение владимир1983 » 28.09.2015 19:57

rxu, Ничего не слышно будет ли поддержка php7?
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 12664
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 265 раз
Поблагодарили: 1135 раз
Контактная информация:

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение rxu » 28.09.2015 19:58

3.2 работает на PHP 7.

Отправлено спустя 2 минуты 21 секунду:
Русский перевод 3.2: https://github.com/rxu/Olympusrupack/tree/rhearupack
Изображение

Аватара пользователя
владимир1983
Former team member
Сообщения: 6103
Зарегистрирован: 27.04.2010 2:17
Откуда: Сергиев Посад
Благодарил (а): 409 раз
Поблагодарили: 737 раз
Контактная информация:

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение владимир1983 » 29.09.2015 0:20

Занимательно http://talks.php.net/oz15#/bbbench
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)

Audioman
phpBB 1.0.0
Сообщения: 1
Зарегистрирован: 23.04.2007 22:35

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение Audioman » 24.11.2015 16:40

Я пользовался PHPBB много лет, но, в связи с такими драконовскими апдейтами, буду вынужден прекратить его использование.
1. PHP версия - нереально требовать от хостера обновления версии в связи с выходом каждой новой версии форума.
2. Переход с 3.0.** на 3.1** полностью снес все наработки и модификации по дизайну, плагинам и т.д.

Аватара пользователя
Sumanai
phpBB 2.0.23
Сообщения: 1406
Зарегистрирован: 02.11.2014 13:57
Благодарил (а): 244 раза
Поблагодарили: 188 раз
Контактная информация:

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение Sumanai » 24.11.2015 16:42

Audioman писал(а):Источник цитаты PHP версия - нереально требовать от хостера обновления версии в связи с выходом каждой новой версии форума.

PHP версии 5.4 уже не поддерживается, 5.3 не поддерживается очень давно. Кто виноват, что ваш хостинг использует столь древний софт?
Audioman писал(а):Источник цитаты Переход с 3.0.** на 3.1** полностью снес все наработки и модификации по дизайну, плагинам и т.д.

Для этого и нужна была система расширений, чтобы ничего не терять.
Вам разве кто- то говорил, что на 3.2 не будут работать расширения от 3.1?

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 12664
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 265 раз
Поблагодарили: 1135 раз
Контактная информация:

Re: Как сконвертировать phpBB 3.0/3.1 в phpBB 3.2

Сообщение rxu » 24.11.2015 16:46

Sumanai писал(а):Источник цитаты разве кто- то говорил, что на 3.2 не будут работать расширения от 3.1?

Некоторые без доработок не будут работать. Как минимум те, которые имеют собственные уведомления. Но это лишь вопрос адаптации к новой версии, контент не потеряется.
Изображение


Вернуться в «Поддержка phpBB 3.2.x»

Кто сейчас на конференции

Сейчас этот форум просматривают: Omgili [Bot] и 2 гостя