[Решено] Проблема с XCache после установки мода

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Crelby
phpBB 1.4.2
Сообщения: 74
Стаж: 18 лет 8 месяцев
Благодарил (а): 3 раза
Поблагодарили: 5 раз

[Решено] Проблема с XCache после установки мода

Сообщение Crelby »

Привет.

Версия борды 3.0.13-PL1.
После установки мода Ban List появилась ошибка в админке.
Появляется она (как минимум) в 2 случаях: при попытке очистить кэш шаблонов и при попытке забанить по емейл.
Текст ошибки:
Fatal error: xcache_count(): xcache.admin.user and/or xcache.admin.pass settings is not configured. Make sure you've modified the correct php ini file for your php used in webserver. in /var/www/admin/www/airgun.org.ru/forum/includes/acm/acm_xcache.php on line 60
Строка 60 в файле, на который ссылается ошибка, выглядит так:

Код: Выделить всё

		// If the admin authentication is enabled but not set up, this will cause a nasty error.
		// Not much we can do about it though.
		$n = xcache_count(XC_TYPE_VAR);
XCache включен как на VPS, так и в конфиге. До установки мода этой проблемы не было. Других действий с форумом и VPS не производилось.
Последний раз редактировалось Crelby 12.03.2015 12:48, всего редактировалось 1 раз.
Crelby
phpBB 1.4.2
Сообщения: 74
Стаж: 18 лет 8 месяцев
Благодарил (а): 3 раза
Поблагодарили: 5 раз

Re: Проблема с XCache после установки мода

Сообщение Crelby »

Дополнение.
Действие, которое предшествует ошибке, форум выполняет. Ошибка, судя по всему, происходит, когда форум пытается сообщить о том, что действие выполнено успешно.
Crelby
phpBB 1.4.2
Сообщения: 74
Стаж: 18 лет 8 месяцев
Благодарил (а): 3 раза
Поблагодарили: 5 раз

Re: [Решено] Проблема с XCache после установки мода

Сообщение Crelby »

В общем, как мне подсказали добрые самаритяне, дело было не в моде, а в том, что я в связи с установкой мода обновил кэш.
И это обновление кэша случилось впервые после установки XCache. Что привело к указанным в первом сообщении последствиям.
Настроил авторизацию в XCache, и проблема устранилась.

Вернуться в «Поддержка phpBB 3.0.х»