Проблема со стилем

Есть любые вопросы, связанные со стилями/темами для phpBB 2.0.x? Ишите ответы здесь!
Аватара пользователя
lautes
phpBB 1.4.4
Сообщения: 150
Зарегистрирован: 22.12.2006 17:10
Откуда: Одесса
Благодарил (а): 3 раза
Контактная информация:

Проблема со стилем

Сообщение lautes » 28.03.2007 14:43

Появилась проблема со стилем, а именно SoftBlue. Вообщем недавно заметил что стиль немного поплыл на право, а footer'a просто нет. И это всё происходит только на главной стрвнице форума во всех разделах темах стиль выглядит так как оно должно быть. Где нужно копать?

Аватара пользователя
lautes
phpBB 1.4.4
Сообщения: 150
Зарегистрирован: 22.12.2006 17:10
Откуда: Одесса
Благодарил (а): 3 раза
Контактная информация:

Сообщение lautes » 29.03.2007 14:47

Ну подскажить пожалуйста фаил который впринципе отвечает за главную страницу форума, а именно его стиль. У меня ещё установлен стандартный subSilver но в нём всё в порядке!

Аватара пользователя
MXM
phpBB 2.0.7
Сообщения: 555
Зарегистрирован: 17.08.2004 13:45
Откуда: Санкт-Петербург
Благодарил (а): 1 раз
Контактная информация:

Сообщение MXM » 29.03.2007 15:09

Если ссылка: форум/index.php, то смотри:
overall_header.tpl - верх
index_body.tpl - середина
overall_footer.tpl - низ

А вообще дай ссылку на форум, гляну, что там у тебя.

Аватара пользователя
lautes
phpBB 1.4.4
Сообщения: 150
Зарегистрирован: 22.12.2006 17:10
Откуда: Одесса
Благодарил (а): 3 раза
Контактная информация:

Сообщение lautes » 29.03.2007 18:24

MXM
Но вот например footer у index'a вообще нет это и зачего сожет быть?

Аватара пользователя
RedNaxi
Former team member
Сообщения: 916
Зарегистрирован: 21.02.2007 2:05
Откуда: BeBoss.ru
Поблагодарили: 4 раза

Сообщение RedNaxi » 29.03.2007 19:34

если совсем футера нет то возможно ставил какой-то мод и остался незакрытый тег <tr> <td> или <table> где то в index_body.tpl вот и ушел футер. Может действительно дашь ссылку на форум посмотрим

Аватара пользователя
lautes
phpBB 1.4.4
Сообщения: 150
Зарегистрирован: 22.12.2006 17:10
Откуда: Одесса
Благодарил (а): 3 раза
Контактная информация:

Сообщение lautes » 29.03.2007 20:06


Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14341
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 343 раза
Поблагодарили: 1494 раза
Контактная информация:

Сообщение rxu » 29.03.2007 20:15

Код: Выделить всё

include($phpbb_root_path . 'includes/page_tail.'.$phpEx);
Присутствует внизу в файле index.php?
Изображение

Аватара пользователя
MXM
phpBB 2.0.7
Сообщения: 555
Зарегистрирован: 17.08.2004 13:45
Откуда: Санкт-Петербург
Благодарил (а): 1 раз
Контактная информация:

Сообщение MXM » 29.03.2007 20:16

lautes, выложи:
overall_header.tpl
index_body.tpl
overall_footer.tpl

Аватара пользователя
lautes
phpBB 1.4.4
Сообщения: 150
Зарегистрирован: 22.12.2006 17:10
Откуда: Одесса
Благодарил (а): 3 раза
Контактная информация:

Сообщение lautes » 29.03.2007 22:47

Пожалуйста.
Вложения
overall_footer.txt
(1.65 КБ) 457 скачиваний
overall_header.txt
(4.96 КБ) 438 скачиваний
index_body.txt
(4.95 КБ) 458 скачиваний

Аватара пользователя
TheHawk
phpBB 1.4.4
Сообщения: 130
Зарегистрирован: 21.02.2007 18:04
Откуда: Беларусь, Гомель

Сообщение TheHawk » 29.03.2007 22:49

У меня была похожая проблема после установки мода democraсy в стиле solaris: окна выстраивались каскадом.
Просто не пойму зачем авторы стилей, кроме стандартного изменения цветов, шрифтов и перестановки окон, так до неузнаваемости перебивают стандартный стиль subSilver, что порой трудно и даже невозможно найти нужную строку.
lautes Посмотри внимательно на строки которые добавлял в стиль, возможно где-то придётся подумать и даже разбить их на 2 части, а где-то добавить в другое место.
Изображение

Аватара пользователя
MXM
phpBB 2.0.7
Сообщения: 555
Зарегистрирован: 17.08.2004 13:45
Откуда: Санкт-Петербург
Благодарил (а): 1 раз
Контактная информация:

Сообщение MXM » 29.03.2007 23:21

lautes, с тэпээлками у тебя все гуд, кроме этого (но это не влияет на смещение футера), но всё равно поправь
овералл_хидер.тпл
Непонятно мне вот это:
<th height="25" nowrap="nowrap" align="left"><a href="http://www.smallworld.com.ua/index.php" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" border="0" hspace="3" >Вернуться на главную страницу сайта</здесь пропустил закрывающий тэг - a><a href="{U_FAQ}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_faq.gif" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a></span><span class="mainmenu">&nbsp; &nbsp;<a href="{U_SEARCH}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_search.gif" border="0" alt="{L_SEARCH}" hspace="3" />{L_SEARCH}</a>&nbsp; &nbsp;<a href="{U_MEMBERLIST}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_members.gif" border="0" alt="{L_MEMBERLIST}" hspace="3" />{L_MEMBERLIST}</a>&nbsp; &nbsp;<a href="{U_GROUP_CP}" class="mainmenu"><img src="templates/SoftBlue/images/icon_mini_groups.gif" border="0" alt="{L_USERGROUPS}" hspace="3" />{L_USERGROUPS}</a>&nbsp; &nbsp;<a href="{U_STAFF}" class="mainmenu"><img src="templates/subSilver/images/staff.gif" width="12" height="13" border="0" alt="{L_STAFF}" hspace="3" />{L_STAFF}</a>&nbsp;</th>
Значит, где-то в другом месте бяка. Говори, что делал ...
Вообщем смотри index.php или includes/page_tail.php наверное там.

Аватара пользователя
RedNaxi
Former team member
Сообщения: 916
Зарегистрирован: 21.02.2007 2:05
Откуда: BeBoss.ru
Поблагодарили: 4 раза

Сообщение RedNaxi » 30.03.2007 0:36

TheHawk писал(а):так до неузнаваемости перебивают стандартный стиль subSilver
извиняюсь за оффтоп но это совсем не так:) нужную строку очень просто найти по переменным {U_*} или {L_*}

Добавлено спустя 4 минуты 32 секунды:

Код: Выделить всё

	<td width="20" align="center"><img src="templates/SoftBlue/images/folder_new_big.gif" alt="Новые сообщения"/></td>
	<td><span class="gensmall">Новые сообщения</span></td>
	<td>&nbsp;&nbsp;</td>
	<td width="20" align="center"><img src="templates/SoftBlue/images/folder_big.gif" alt="Нет новых сообщений" /></td>
	<td><span class="gensmall">Нет новых сообщений</span></td>
	<td>&nbsp;&nbsp;</td>

	<td width="20" align="center"><img src="templates/SoftBlue/images/folder_locked_big.gif" alt="Форум закрыт" /></td>
	<td><span class="gensmall">Форум закрыт</span></td>
  </tr>
</table>
</td>
</tr>
</table>
</div>
<br clear="all" />


взято с твоего форума. судя по коду т.к. нет </body> и </htm> значит какой-то мод неправильно установил инклуд куда то делся. проверь все открывающие изакрывающие скобки в index.php может поможет.. не знаешь после установки какого мода такое произошло?

Аватара пользователя
lautes
phpBB 1.4.4
Сообщения: 150
Зарегистрирован: 22.12.2006 17:10
Откуда: Одесса
Благодарил (а): 3 раза
Контактная информация:

Сообщение lautes » 30.03.2007 2:09

MXM
Это я добавил ссылку для выхода на главную страницу сайта.
RedNaxi
Вроде я практически уверен на 100% это произошло после установки мода staffsite.

Аватара пользователя
RedNaxi
Former team member
Сообщения: 916
Зарегистрирован: 21.02.2007 2:05
Откуда: BeBoss.ru
Поблагодарили: 4 раза

Сообщение RedNaxi » 30.03.2007 3:38

lautes писал(а):установки мода staffsite.
честно говоря себе его не ставил - не счел необходимым:) поэтому наверное ничем не могу помочь... сейчас гляну как этот мод изменяет index php авось найду что нмбудь...

Добавлено спустя 7 минут 21 секунду:

посмотрел я staff site он ничего не меняет из того, что могло вызвать такую ошибку:( может есть полный список установленных модов?

Добавлено спустя 2 минуты 38 секунд:

ИМХО в каком то моде не в том месте бвла поставлена закрвающая скобка ( "}" ) изз-за этого все и произошло...
MXM у вас другое мнение?

Аватара пользователя
lautes
phpBB 1.4.4
Сообщения: 150
Зарегистрирован: 22.12.2006 17:10
Откуда: Одесса
Благодарил (а): 3 раза
Контактная информация:

Сообщение lautes » 30.03.2007 14:48

Что ж вот все моды которые у меня:
quick reply 3.0.5
global announcement 1.5.0
birthday 1.5.9em
birthday add on zodiac 1.0.5em
post is sending 1.1.2
on off hid v2.2.8em
topic search 1.1.0
gender 1.2.8em
attach mod 2.4.5
topics sorted by type 1.1.0
Reputation Mod v.100
admin users list v110
album v2054
log actions mod
anti-bot-question v.1.0.3 (не доставленный)
staffsite 2.2.3

Вот и всё.

Добавлено спустя 1 минуту 35 секунд:

Перед этим я ещё обновлял quick reply до версии 3.0.5...

Закрыто

Вернуться в «Стили для phpBB 2.0.x»