Мои смайлики плющит :)

Есть любые вопросы, связанные со стилями/темами для phpBB 2.0.x? Ишите ответы здесь!
Аватара пользователя
Vetal
phpBB 1.4.0
Сообщения: 39
Зарегистрирован: 10.10.2005 3:09
Откуда: Sevastopol city

Мои смайлики плющит :)

Сообщение Vetal » 13.12.2005 23:20

Вобщем у меня есть стиль fiblack3dblue ,в нём всё нормально,кроме одного, когда я жму "Дополнительные смайлики" ,во всплывающем окне отображаются и те смайлы которые были ,и те что я добавил сам (они по размеру немного больше стандартных).
Но форум почему-то хочет мне в окне все смайлы уровнять ,так, что те ,которые больше он сплющивает делая их одного размера со стандартными (но если честно выглядит это очень некрасиво :x )

Был бы рад ,если бы сказал мне кто-нить где мне в коде предстоит покавыряться.
Спасибо за внимание.
Всем у кого форум в локальной сети и глючит E-mail сюда : http://spsmtp.net.ru/

Stas!

Сообщение Stas! » 14.12.2005 1:38

Можно тут почитать.

Joss

Сообщение Joss » 14.12.2005 15:26

Vetal
Там жестко прописаны размеры смайлов. Если их убрать, то все будет нормально, только немножко медленнее форматирование строки со смайликами отображаться будет.

Аватара пользователя
Vetal
phpBB 1.4.0
Сообщения: 39
Зарегистрирован: 10.10.2005 3:09
Откуда: Sevastopol city

Сообщение Vetal » 14.12.2005 20:35

Спасибо, помогло...
Всем у кого форум в локальной сети и глючит E-mail сюда : http://spsmtp.net.ru/

Extremator
phpBB 1.4.3
Сообщения: 81
Зарегистрирован: 14.01.2006 17:18
Контактная информация:

Сообщение Extremator » 14.01.2006 17:36

У меня тоже плющит смайлы, я заменил основные смайлы на новые, но так как у них размер больше они все кривые, а при вставке в сообщение нормальные, что надо сделать. В posting_smilies.tpl ширину и длину удалил, все-рано криво.

Joss

Сообщение Joss » 14.01.2006 18:19

Кэш почистили?

Extremator
phpBB 1.4.3
Сообщения: 81
Зарегистрирован: 14.01.2006 17:18
Контактная информация:

Сообщение Extremator » 14.01.2006 18:19

Да.

Аватара пользователя
ursus
phpBB 1.4.2
Сообщения: 55
Зарегистрирован: 26.02.2006 4:13
Откуда: Украина, Луганская обл.
Контактная информация:

Сообщение ursus » 25.04.2006 1:57

Народ!
Такой неприятный момент: я портировал смайлы с IPB 2.1.4 в свой phpBB 2.0.19 . Они стали нормально, но при вставке первого же кода смайла в тело сообщения анимированные смайлы (в поле слева) замерзают до перезагрузки страницы или нажатия на кнопку Предварительный просмотр.
Стоит отметить, что данный трабл проявляется только при использовании Internet Explorer.
В чем проблема: в броузере или кривых руках?
Я нормальный, небуйный подонок, каких миллионы (с) А. Мухин "Горбушка"

Аватара пользователя
Vetal
phpBB 1.4.0
Сообщения: 39
Зарегистрирован: 10.10.2005 3:09
Откуда: Sevastopol city

Сообщение Vetal » 25.04.2006 3:02

ursus вот решение:

----------------------------------------------------------
Найти в posting_body.tpl (quick_reply.tpl)

Код:
<td><a href="javascript:emoticon('{smilies_row.smilies_col.SMILEY_CODE}')"><img src="{smilies_row.smilies_col.SMILEY_IMG}" border="0" alt="{smilies_row.smilies_col.SMILEY_DESC}" title="{smilies_row.smilies_col.SMILEY_DESC}" /></a></td>

заменить на -

Код:
<td><img src="{smilies_row.smilies_col.SMILEY_IMG}" border="0" onmouseover="this.style.cursor='hand';" onclick="emoticon('{smilies_row.smilies_col.SMILEY_CODE}');" alt="{smilies_row.smilies_col.SMILEY_DESC}" title="{smilies_row.smilies_col.SMILEY_DESC}" /></td>

И аналогично в posting_smilies.tpl -

Код:
<td><a href="javascript:emoticon('{smilies_row.smilies_col.SMILEY_CODE}')"><img src="{smilies_row.smilies_col.SMILEY_IMG}" border="0" alt="{smilies_row.smilies_col.SMILEY_DESC}" title="{smilies_row.smilies_col.SMILEY_DESC}" /></a></td>

заменить на -

Код:
<td><img src="{smilies_row.smilies_col.SMILEY_IMG}" border="0" onmouseover="this.style.cursor='hand';" onclick="emoticon('{smilies_row.smilies_col.SMILEY_CODE}');" alt="{smilies_row.smilies_col.SMILEY_DESC}" title="{smilies_row.smilies_col.SMILEY_DESC}" /></td>
Всем у кого форум в локальной сети и глючит E-mail сюда : http://spsmtp.net.ru/

Аватара пользователя
ursus
phpBB 1.4.2
Сообщения: 55
Зарегистрирован: 26.02.2006 4:13
Откуда: Украина, Луганская обл.
Контактная информация:

Сообщение ursus » 25.04.2006 3:11

Vetal
слушай, а ведь сработало!!! :)
буду должен :)
Я нормальный, небуйный подонок, каких миллионы (с) А. Мухин "Горбушка"

Аватара пользователя
Kuban
phpBB 1.4.2
Сообщения: 56
Зарегистрирован: 04.01.2006 19:22
Откуда: Комсомольск-на-Амуре
Благодарил (а): 8 раз
Поблагодарили: 1 раз
Контактная информация:

Сообщение Kuban » 25.04.2006 18:12

Vetal
Найти в posting_body.tpl (quick_reply.tpl)

Код:

Код: Выделить всё

<td><a href="javascript:emoticon('{smilies_row.smilies_col.SMILEY_CODE}')"><img src="{smilies_row.smilies_col.SMILEY_IMG}" border="0" alt="{smilies_row.smilies_col.SMILEY_DESC}" title="{smilies_row.smilies_col.SMILEY_DESC}" /></a></td> 
Я у себя в quick_reply.tpl не нашел такой строки! Как решить именно эту проблему?!

Аватара пользователя
Vetal
phpBB 1.4.0
Сообщения: 39
Зарегистрирован: 10.10.2005 3:09
Откуда: Sevastopol city

Сообщение Vetal » 25.04.2006 19:44

Ну не знаю , я себе мод быстрого ответа не ставил поэтому файла quick_reply.tpl у меня нет ,но наверняка там должна быть похожая строчка, поищи.
Всем у кого форум в локальной сети и глючит E-mail сюда : http://spsmtp.net.ru/

Аватара пользователя
antos
phpBB 1.4.1
Сообщения: 44
Зарегистрирован: 18.04.2006 23:34
Откуда: Peterburg
Контактная информация:

Сообщение antos » 26.04.2006 21:57

Подскажие плиз -- у меня в каждом сообщении есть белая такая часть (нижняя ) и где она прописывается никак не найти ---помогите плиз сделать её такой же как фон самого сообщения . Форум тут http://www.svinka.spb.ru/forum . Уже 2 дня мудохаюсь
С уважением Антон

Аватара пользователя
Kuban
phpBB 1.4.2
Сообщения: 56
Зарегистрирован: 04.01.2006 19:22
Откуда: Комсомольск-на-Амуре
Благодарил (а): 8 раз
Поблагодарили: 1 раз
Контактная информация:

Сообщение Kuban » 27.04.2006 4:18

Vetal
Vetal писал(а):Ну не знаю , я себе мод быстрого ответа не ставил поэтому файла quick_reply.tpl у меня нет ,но наверняка там должна быть похожая строчка, поищи.
Вот строчка из quick_reply.tpl

Код: Выделить всё

<td><a href="javascript:emoticon('{quick_reply.smilies_row.smilies_col.CODE}')"><img src="{quick_reply.smilies_row.smilies_col.URL}" border="0" alt="{quick_reply.smilies_row.smilies_col.DESC}" title="{quick_reply.smilies_row.smilies_col.DESC}" /></a></td>
меняю на

Код: Выделить всё

<td><img src="{smilies_row.smilies_col.SMILEY_IMG}" border="0" onmouseover="this.style.cursor='hand';" onclick="emoticon('{smilies_row.smilies_col.SMILEY_CODE}');" alt="{smilies_row.smilies_col.SMILEY_DESC}" title="{smilies_row.smilies_col.SMILEY_DESC}" /></td>
не работает...
пробовал убирать quick_reply. - кресты красные появляются......

Аватара пользователя
Kuban
phpBB 1.4.2
Сообщения: 56
Зарегистрирован: 04.01.2006 19:22
Откуда: Комсомольск-на-Амуре
Благодарил (а): 8 раз
Поблагодарили: 1 раз
Контактная информация:

Сообщение Kuban » 29.04.2006 3:32

По идее Xpert мог бы помочь в решении этой проблемы... но он молчит пока... Я думаю, что у многих стоит мод быстрого ответа!

Закрыто

Вернуться в «Стили для phpBB 2.0.x»