Внимание!
Не все расширения для phpBB 3.2 совместимы с phpBB 3.3, главным образом из-за неверного синтаксиса в определениях сервисов (отсутствия обрамляющих кавычек - '...').
Перед обновлением необходимо убедиться в совместимости всех расширений.
Рекомендуется предварительно тестировать обновление на копии конференции (локально или на сервере).

[INFO] phpBB 2.0.x и php 5.1.х

Проблемы с установкой или работой phpBB 2.0.x? Ищите ответы здесь!
Аватара пользователя
Vladson
Former team member
Сообщения: 816
Стаж: 16 лет 1 месяц
Откуда: Estonia, Tallinn

[INFO] phpBB 2.0.x и php 5.1.х

Сообщение Vladson »

В виду множества изменений в РНР 5.1.х по сравнению с более ранними версиями, работа phpBB 2.0.х на нём крайне не стабильна...

Теоретически запуск возможен, изменения в настройках РНР схожи с версией РНР 5.0.х и практически достаточно включить директиву register_long_arrays так-же подключить библиотеку php_mysql.dll, однако добиться стабильной работы невозможно в виду некоторых новинок представленных в РНР 5.1.х

Внимание:
Небольшое добавление, с момента этого "анонса" до этого момента в РНР было исправлено много багов по этому можно надеяться на стабильную работу с версиями РНР-5.1.4 и выше, однако я бы рекомендовал быть всеже острожнее...
Серый цвет - светлый (светлее чёрного), но он и тёмный (темнее белого), он же промежуточный (между чёрным и белым). Теорию относительности никто не отменял. Истина в целом - понятие виртуально-ситуативное.

Вернуться в «Поддержка phpBB 2.0.x»