Advanced Posts Merging

Все моды, созданные нашим сообществом для phpBB 2.0.x, анонсированы тут.
Аватара пользователя
crash
Former team member
Сообщения: 6517
Зарегистрирован: 07.07.2004 17:12
Откуда: Бердск
Поблагодарили: 15 раз
Контактная информация:

Сообщение crash » 03.10.2007 10:40

dav2005 писал(а):правил все верно
dav2005 писал(а):вместо афтер одд сделал реплейс
так верно или нет, вот в чем вопрос
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса

dav2005
phpBB 1.2.1
Сообщения: 26
Зарегистрирован: 27.06.2007 23:10

Сообщение dav2005 » 04.10.2007 11:36

ну, в принципе, "верно" можно взять в кавычки :wink:

Lokust
phpBB 1.4.4
Сообщения: 119
Зарегистрирован: 24.05.2006 21:46

Сообщение Lokust » 21.10.2007 12:12

Помогите понять плиз. Два раза переставил мод. Второй раз очень внимательно! После того как включаю мод в админке и отсылаю подряд два сообщения, после отсылки второго вместо сообщения с предложением вернуться в тему или в форум, выскакивает абсолютно пустое и на этом все замирает. В каком именно файле может быть ошибка? Форум 2.0.22

vitty
phpBB 1.4.4
Сообщения: 193
Зарегистрирован: 20.06.2006 11:06
Благодарил (а): 9 раз
Контактная информация:

Сообщение vitty » 22.10.2007 17:54

Проблема в следующем. Установил данный мод, все работает прерасно, но иногда в некоторых постах, когда добавляешь второй, то все склеивает без проблем, но пишет "Добавленно спустя:" и не указывает времени, через которое был добавлен пост. В некоторых темах .все работает без проблем, а в некоторых такой баг. С чем может быть сие связанно и как это можно решить?

Добавлено спустя 18 секунд:

У вас, я вижу все работает четко.

Tang
phpBB 1.2.0
Сообщения: 10
Зарегистрирован: 12.06.2006 3:59

Сообщение Tang » 07.12.2007 20:07

Форум стоит на localhost
При запуске advanced_posts_merging_db_ins.php выдает:
Advanced Posts Merging DB Update
Installation failed: Duplicate entry 'time_to_merge' for key 1

Подскажите пожалуйста, что делать?

Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Зарегистрирован: 24.05.2006 23:20
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 453 раза
Контактная информация:

Сообщение Палыч » 08.12.2007 1:29

Tang писал(а):Подскажите пожалуйста, что делать?
Ничего. Зачем вы его дважды запускаете?
Tang писал(а): Duplicate entry 'time_to_merge'
Повторная вставка поля 'time_to_merge'
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.

Valiks
phpBB 1.4.1
Сообщения: 46
Зарегистрирован: 10.07.2006 20:07

Сообщение Valiks » 23.12.2007 8:05

Установил модуль, все вроде бы работает корректно, спасибо создателям

Но есть вопрос - как склеивать сообщения гостей?

У меня на форуме гостям разрешено писать, а вот как сделать, чтобы сообщения гостя склеивалось,- не знаю. Понимаю, что тут есть проблема, гость может написать себе десять разных имен и поставить десять сообщений подряд. В общем, вопрос состоит в том, по чему проверять гостя, так?

Есть какие-нибудь решения этого вопроса или нет? Устроило бы даже не очень строгая проверка
Val

Элен
phpBB 1.4.2
Сообщения: 55
Зарегистрирован: 02.08.2007 1:34
Благодарил (а): 1 раз

Сообщение Элен » 12.01.2008 21:13

Мод работает - СПАСИБО! Все склеивается.
Но после его установки, все посты написанные раньше датируются Чт Янв 01, 1970 3:00 am . Из-за чего такое? И никак нельзя вернуть все даты на место?
Я не волшебник, я только учусь.

Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Зарегистрирован: 24.05.2006 23:20
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 453 раза
Контактная информация:

Сообщение Палыч » 12.01.2008 21:28

Элен
А вот это сделали?

Код: Выделить всё

UPDATE phpbb_posts SET post_created = post_time;
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.

Элен
phpBB 1.4.2
Сообщения: 55
Зарегистрирован: 02.08.2007 1:34
Благодарил (а): 1 раз

Сообщение Элен » 13.01.2008 0:13

Палыч
Я это в самом начале делала?

Код: Выделить всё

-----[ SQL ]------------------------------------------ 
# 
INSERT INTO phpbb_config (config_name, config_value) VALUES('time_to_merge', 0); 
INSERT INTO phpbb_config (config_name, config_value) VALUES('merge_flood_interval', 0); 
ALTER TABLE phpbb_posts ADD post_created INT(11) DEFAULT '0' NOT NULL AFTER post_time; 
UPDATE phpbb_posts SET post_created = post_time;
Или это не то?
Я не волшебник, я только учусь.

Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Зарегистрирован: 24.05.2006 23:20
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 453 раза
Контактная информация:

Сообщение Палыч » 13.01.2008 0:44

То, только судя по вашему посту, у вас там пусто...
Вот строка из viewtopic.php (после установки МОДа)

Код: Выделить всё

	$post_date = create_date($board_config['default_dateformat'], $postrow[$i]['post_created'], $board_config['board_timezone']);
которая присваивает значение переменной $post_date из функции create_date в формате, заданном в конфигурации, путём корректировки времени создания поста на установленную таймзону.
Таймзона у вас, суда по всему, GMT+3. А поле post_created, вероятно пустое. То есть к "0" (время начала UNIX - 00.00.00 01.01.1970 год) прибавляется 3 часа.
Посмотрите в базе данных значения, которые стоят в поле post_created (после выполнения запроса, они должны быть такие же как в поле post_time). Возможно, просто запрос не выполнялся?
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.

Элен
phpBB 1.4.2
Сообщения: 55
Зарегистрирован: 02.08.2007 1:34
Благодарил (а): 1 раз

Сообщение Элен » 13.01.2008 1:28

Палыч писал(а):Посмотрите в базе данных значения, которые стоят в поле post_created (после выполнения запроса, они должны быть такие же как в поле post_time). Возможно, просто запрос не выполнялся?
не поняла я где смотреть ( если имеется в виду phpbb posts ) то там значения для post_created и post_time одинаковые
Я не волшебник, я только учусь.

Darkness*666
phpBB 1.0.0
Сообщения: 2
Зарегистрирован: 13.01.2008 1:34

Сообщение Darkness*666 » 13.01.2008 1:39

Здравствуйте , уважаемые участники
Столкнулся с такой проблемой :
Всё вроде работает , но когда при отправке сообщения после первого переходит для просмотра поста вновь , то никаикх изменений нет
Если нажать F5 - то всё видно становится
В чём проблема может быть ?

Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Зарегистрирован: 24.05.2006 23:20
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 453 раза
Контактная информация:

Сообщение Палыч » 13.01.2008 2:13

Darkness*666
Глюк браузера (вероятно Опера)

Добавлено спустя 29 минут 50 секунд:
Элен писал(а): если имеется в виду phpbb posts
да
Элен писал(а):одинаковые
других предположений у меня нет :?
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.

Элен
phpBB 1.4.2
Сообщения: 55
Зарегистрирован: 02.08.2007 1:34
Благодарил (а): 1 раз

Сообщение Элен » 13.01.2008 2:29

Тоесть поменять теперь нельзя? Так и будут посты 70 годом? прикольно конечно... еще и компов то не у было, а у нас сообщения..мда
А в форумах и темах( в нрафе последнее сообщение) даты остались нормальные, только в постах все 70 датированы
Я не волшебник, я только учусь.

Закрыто

Вернуться в «Анонсы и поддержка модов для phpBB 2.0.x»