Уважаемые пользователи!
Напоминаем, что с 7 ноября 2020 года phpBB Group прекращает поддержку phpBB версии 3.2.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.2 до 31 декабря 2020 года.
С учетом этого, а также того, что версия 3.2.x больше не будет получать обновлений, за исключением связанных с проблемами безопасности
(только при их наличии и только до 7 ноября 2020 года), рекомендуется обновить конференции до версии 3.3.x.

Награды для пользователей [Medal System]

Ответы на вопросы, связанные с модами для phpBB 2.0.x, кроме относящихся к форуму Для авторов (phpBB 2.0.x).
vitty
phpBB 1.4.4
Сообщения: 193
Стаж: 15 лет 1 месяц
Благодарил (а): 9 раз

Сообщение vitty »

Хорошо если так проще, как решается данная проблема в phpbb2? Я по аналогии решу ее тут.
Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Стаж: 15 лет 1 месяц
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 454 раза

Сообщение Палыч »

vitty писал(а): как решается данная проблема в phpbb2?
Ну я бы проверил, что файл содержит в начале конструкцию типа:

Код: Выделить всё

define('IN_PHPBB', 1);

if( !empty($setmodules) )
{
	$file = basename(__FILE__);
	$module['Medals']['Manage'] = "$file";
	return;
}
и что имееться также файл admin_medal_cfg.php
Остальное - проверка установки МОДа.
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
vitty
phpBB 1.4.4
Сообщения: 193
Стаж: 15 лет 1 месяц
Благодарил (а): 9 раз

Сообщение vitty »

В локале мод работал нормально, а данный скрипт я смотрел, тут все в порядке.

Добавлено спустя 5 минут 53 секунды:

Файл - admin_medal_cfg.php есть. Благодаря ему в админке есть раздел, для конфигурации наград. Файл admin_medals.php отвечает за присвоение наград, импорт наград в базу, чтобы их можно было присваивать. Соответсвенно т.к. я этот файл убрал, то в настройке наград только один пункт, второго нет ,т.к. когда я этот файл заливаю админка перестает работать. В локале все работает на ура.

Добавлено спустя 5 часов 43 минуты 39 секунд:

Скопировал все файлы форума и залил их на Денвер. Все работает и админка нормально загружается. На форуме не хочет. Что делать?
vitty
phpBB 1.4.4
Сообщения: 193
Стаж: 15 лет 1 месяц
Благодарил (а): 9 раз

Сообщение vitty »

И всетаки, как можно решить мою проблему? Общался с Хостингом, сказали, что это проблемы мода. Но в локале при иденчичных файлах и базе все работает четко.
Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Стаж: 15 лет 1 месяц
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 454 раза

Сообщение Палыч »

vitty писал(а):Общался с Хостингом, сказали, что это проблемы мода.
vitty писал(а):Скопировал все файлы форума и залил их на Денвер. Все работает и админка нормально загружается.
Противоречия не находите?
Вопрос интересный. Если найдёте решение, отпишитесь.
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
vitty
phpBB 1.4.4
Сообщения: 193
Стаж: 15 лет 1 месяц
Благодарил (а): 9 раз

Сообщение vitty »

Нет не нахожу. В локале все работает, на хостинге нет. А что за противоречие?
Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Стаж: 15 лет 1 месяц
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 454 раза

Сообщение Палыч »

vitty писал(а):А что за противоречие?
Противоречие между словами вашего хостера и тем, что в других условиях всё работает. Значит дело не в МОДе, не правда ли? :wink:
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
vitty
phpBB 1.4.4
Сообщения: 193
Стаж: 15 лет 1 месяц
Благодарил (а): 9 раз

Сообщение vitty »

Да вот я им тоже самое пытаюсь доказать.
Incident
phpBB 1.0.0
Сообщения: 2
Стаж: 13 лет 9 месяцев

Сообщение Incident »

У меня аналогичная проблема. Форум локальный, пользуюсь АппСерв. С файлом admin_medal.php админ панель не работает, без него только ссылка на отображение медалей. Все скопировано и установлено прямыми руками с подключенным моском (дрова на моск свежие). Ктулху? :shock:

...

Прошу прощения за беспокойство. По вышеизложенному совету поменял свои файлы admin_medal.php и admin_medal_cfg.php на новые из версии 0,4,6 от 2006 года (старые файлы от 2004 года). Все работает. Ктулху решил не будить зря.

Добавлено спустя 3 часа 47 минут 36 секунд:

Смешно. За единственное слово "моск" злобный модератор готов банить :D Смешно и по-детски. А может я неграмотен? Может я не знаю, что слово МОЗГ пишется через ЗГ? В любом случае, моя речь не несет перегруженности сленгом и понятна любому пользователю.
Забанить? да баньте ради бога! Только вместе со мной забаньте пожалуйста и пару пользователей с этой темы (хотя бы с этой темы, я даже другие не стану проверять), использующих сленг. Пальцем показать? Или сами найдете? :twisted:

З.Ы. Сделал скрин и копию постов с предупреждением. Так, чисто для себя, поржать :D Пост можете удалять, чтобы не травмировать психику рядовых пользователей и собственный имидж :twisted:
Аватара пользователя
Rayden
Former team member
Сообщения: 3739
Стаж: 16 лет
Поблагодарили: 44 раза

Сообщение Rayden »

Сделай еще скин страницы с правилами. Вместе с Ктулху почитаете. Вслух.
phpBB2 FAQ
phpBB3 FAQ
Incident
phpBB 1.0.0
Сообщения: 2
Стаж: 13 лет 9 месяцев

Сообщение Incident »

Суть проблемы: Не появляются созданные медали, то есть ни в админке, ни в разделе "Medals" после создания нет ни изображений наград, ни названий - ничего. Категории также не создаются - пишет, что имя задано неверно. Пробовал кидать каталог с рисунками медалек по разным местам - все по-прежнему. Мод ставил с помощью EasyMod. Скажите, возможно ли решить проблему без ручной установки?

2Rayden: Не скин, а скрин. Во-вторых, на брудершафт мы с вами не пили.
Аватара пользователя
RSV
phpBB 1.2.0
Сообщения: 12
Стаж: 16 лет 1 месяц
Откуда: Кисловодск

Сообщение RSV »

Посоветуйте, плиз, ставлю мод при помощи EasyMOD, он мне пишет следующее:

Critical Error

IN-LINE FIND FAILED: In file [templates/subSilver/overall_header.tpl] could not find:

{L_USERGROUPS}</a>&nbsp;

MOD script line #961 :: FAQ :: Report

Что мне с этим делать? Просто в php я мало что понимаю.
Заранее благодарен.

Добавлено спустя 31 минуту 17 секунд:

Может мне стоит вручную модифицировать файл templates/subSilver/overall_header.tpl изменив строку как это записано в тексте модификации, а потом повторить попытку установки мода?
Аватара пользователя
Siava
Поддержка
Поддержка
Сообщения: 4710
Стаж: 16 лет 6 месяцев
Откуда: Питер
Благодарил (а): 142 раза
Поблагодарили: 600 раз

Сообщение Siava »

RSV
Следовало изначально руками всё устанавливать.
Еще одно нарушение правил и будете забанены. © Mr. Anderson
https://siava.ru/forum/ (phpbb 2.0.x, 3.1.x 3.5.x)
Аватара пользователя
RSV
phpBB 1.2.0
Сообщения: 12
Стаж: 16 лет 1 месяц
Откуда: Кисловодск

Сообщение RSV »

Дело состоит в недостаточности знаний по php, поэтому приходится пользоваться утилитами для облегчения процесса инсталляции модов. В форумом ничего не случилось, потому что ума хватило не начинать процесс установки не решив всех появивишихся проблем.

Отсюда вопрос такой: если я вручную найду строку, которую мод должен изменить и изменю файл вручную, потом залью его в измененном виде и после этого попробую установить мод при помощи EasyMOD, то не приведет ли такая самодеятельность к нехорошим последствиям?

Добавлено спустя 3 минуты 7 секунд:

Или же стоит все-же приложить титанические усилия и сделать все ручками?
vitty
phpBB 1.4.4
Сообщения: 193
Стаж: 15 лет 1 месяц
Благодарил (а): 9 раз

Сообщение vitty »

Incident писал(а):Прошу прощения за беспокойство. По вышеизложенному совету поменял свои файлы admin_medal.php и admin_medal_cfg.php на новые из версии 0,4,6 от 2006 года (старые файлы от 2004 года). Все работает. Ктулху решил не будить зря.
Ссылку дай. где новые файлы брал?

Вернуться в «Поддержка модов для phpBB 2.0.x»