Photo Profile Mod

Ответы на вопросы, связанные с модами для phpBB 2.0.x, кроме относящихся к форуму Для авторов (phpBB 2.0.x).
Аватара пользователя
Cheetah
phpBB 1.2.0
Сообщения: 17
Зарегистрирован: 23.09.2006 15:11
Откуда: Великий Новгород
Контактная информация:

Сообщение Cheetah » 30.09.2006 19:50

WalkMan писал(а):Лично я сделал так - при заполнении формы регистрации юзеры не могут загружать фотки и аватары. А активация акаунтов производится админом форума.
А можно поподробнее...
Я тоже хочу убрать панель загрузки фото при регистрации.

Аватара пользователя
lautes
phpBB 1.4.4
Сообщения: 150
Зарегистрирован: 22.12.2006 17:10
Откуда: Одесса
Благодарил (а): 3 раза
Контактная информация:

Сообщение lautes » 26.12.2006 20:26

У меня проблема юзеры которые уже были зарегестрированны могут загружать фото с компьютера жа и вообще откуда угодна, а вот те которые пытаются сейчас регестрироватся и в регестрации указывают свою фотку то получают следуещее сообщение:

Код: Выделить всё

Couldn't insert data into users table

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3

UPDATE phpbb_users SET user_photo = 'd582061745915b0da5816.gif', user_photo_type = 1 WHERE user_id =

Line : 503
File : profilephoto_mod.php

Аватара пользователя
Siava
Поддержка
Поддержка
Сообщения: 4077
Зарегистрирован: 11.01.2005 14:29
Откуда: Питер
Благодарил (а): 103 раза
Поблагодарили: 419 раз
Контактная информация:

Сообщение Siava » 26.12.2006 21:54

lautes
Значит надо чтоб при регистрации блок загрузки фото был недоступен.
Спинным мозгом чую, что ошибка где-то в коде.. ведь при регистрации user_id ещё не известен, а мод его пытается использовать.
Еще одно нарушение правил и будете забанены. © Mr. Anderson
https://siava.ru/forum/ (phpbb 2.0.x, 3.1.x 3.2.x)

Аватара пользователя
lautes
phpBB 1.4.4
Сообщения: 150
Зарегистрирован: 22.12.2006 17:10
Откуда: Одесса
Благодарил (а): 3 раза
Контактная информация:

Сообщение lautes » 27.12.2006 12:15

Siava не подскажите тогда как убрать этот блок при регестрации?

Аватара пользователя
Siava
Поддержка
Поддержка
Сообщения: 4077
Зарегистрирован: 11.01.2005 14:29
Откуда: Питер
Благодарил (а): 103 раза
Поблагодарили: 419 раз
Контактная информация:

Сообщение Siava » 27.12.2006 15:16

lautes
Редактировать файл profile_add_body.tpl. Блок с фото обнести вокруг строками:

Код: Выделить всё

<!-- BEGIN switch_user_logged_in -->
<!-- END switch_user_logged_in -->
Еще одно нарушение правил и будете забанены. © Mr. Anderson
https://siava.ru/forum/ (phpbb 2.0.x, 3.1.x 3.2.x)

Аватара пользователя
lautes
phpBB 1.4.4
Сообщения: 150
Зарегистрирован: 22.12.2006 17:10
Откуда: Одесса
Благодарил (а): 3 раза
Контактная информация:

Сообщение lautes » 27.12.2006 16:38

Siava
Спасибо!!!!

Аватара пользователя
lautes
phpBB 1.4.4
Сообщения: 150
Зарегистрирован: 22.12.2006 17:10
Откуда: Одесса
Благодарил (а): 3 раза
Контактная информация:

Сообщение lautes » 28.12.2006 22:27

Убрал этот блок, но люди когда регестрируются даже не вставляя свою фотку при регестрации...Но всё равно возникает эта ошибка!:(

Код: Выделить всё

Couldn't insert data into users table

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3

UPDATE phpbb_users SET user_photo = '', user_photo_type = 0 WHERE user_id =

Line : 503
File : profilephoto_mod.php

Gisher
phpBB 2.0.12
Сообщения: 857
Зарегистрирован: 04.10.2006 7:50
Благодарил (а): 11 раз
Поблагодарили: 13 раз

Сообщение Gisher » 09.03.2007 21:31

а как можно удалить с базы этот мод?
вот инсталл файл
Вложения
mod_table_inst.rar
(886 байт) 465 скачиваний

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14270
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 339 раз
Поблагодарили: 1476 раз
Контактная информация:

Сообщение rxu » 09.03.2007 21:37

Gisher
В таблице phpbb_config удалить имена/значения allow_photo_remote, allow_photo_upload, photo_filesize, photo_max_height, photo_max_width, photo_path.

В таблице phpbb_users удалить поля user_photo, user_photo_type.

Префикс использовать Ваш. Вроде бы всё.
Изображение

Gisher
phpBB 2.0.12
Сообщения: 857
Зарегистрирован: 04.10.2006 7:50
Благодарил (а): 11 раз
Поблагодарили: 13 раз

Сообщение Gisher » 09.03.2007 22:18

rxu
спасибо, удалил,
просто не было смысла оставлять с фотоальбомом

glad
phpBB 1.0.0
Сообщения: 3
Зарегистрирован: 30.03.2007 16:29

Сообщение glad » 12.04.2007 15:43

такая вот проблемка...в админском разделе не видно ни чего...пустые строки...10 раз пересмотрел все файлы в которых нужно было что-то изменять(всё так же) как и в инстале мода.где может быть ошибка?почитал посты,у некоторых таже проблема,но не описано решение...

кстати,если это важно(а думаю, что так и есть).форум скопирован с работающего(в работающем всё видно),т.е. я скопировал базу данных (просто переименовав префиксы таблиц) и скопировал папку форума в новую,в настройках указал новую папку и в конфиге исправил префикс таблиц...но теперь в основном форуме(с которого копировал) всё работает,а в этом не видны в админке поля этого мода(и ещё поля мода ДР и жёлтых карточек)

glad
phpBB 1.0.0
Сообщения: 3
Зарегистрирован: 30.03.2007 16:29

Сообщение glad » 13.04.2007 10:13

подскажите плиз....4-й день бьюсь над этим и не могу ничего понять=(

вот ппц...щас работает...хотя я ничего не делал=)как так?

Аватара пользователя
Night
phpBB 1.2.0
Сообщения: 19
Зарегистрирован: 01.05.2007 16:49

Сообщение Night » 01.05.2007 21:01

Код: Выделить всё

one
create user variable 'user_photo'...
Couldn't alter users table
1060: Duplicate column name 'user_photo'

ALTER TABLE phpbb_users ADD user_photo VARCHAR(100)

done
create user variable 'user_photo_type'...
Couldn't alter users table
1060: Duplicate column name 'user_photo_type'

ALTER TABLE phpbb_users ADD user_photo_type TINYINT(4) DEFAULT '0' NOT NULL

done

sucessfully added new config variables.
В админке появилось поле. А в профайле ничего кроме авок нет(

ЗЫ: Настроила. Но теперь другая проблема после заливки она просто - напросто не отображается... :(

ЗЫ2: Забыла поставить разрешение на авы.

Аватара пользователя
Ivanek
phpBB 1.4.1
Сообщения: 49
Зарегистрирован: 08.03.2006 5:57
Поблагодарили: 1 раз
Контактная информация:

Сообщение Ivanek » 05.08.2007 20:30

Код: Выделить всё

Couldn't insert data into users table

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3

UPDATE phpbb_users SET user_photo = '', user_photo_type = 0 WHERE user_id = 

Line : 503
File : profilephoto_mod.php
Такая ошибка появляется при регистрации на форуме.
При регистрации пользователям отключена возможность закачивать фото. (сделал как советовали тут ж на форуме)

Ответ как неприсваивать фото только регистрирующемуся юзверу не нашел.

ICQ 166717875

Добавлено спустя 50 минут 54 секунды:

проанализировав ситуацию я продвинулся в решении праблемы.

При регистрации нового пользователя у меня блока с фоткой нет, после одобрения регистрации пользовтель заходит в свой профиль и можит закачать фото.
Тут все ОК!

Осталась праблема. Когда заходиш через админ панель и входиш в раздел редактирования профиля пользователя то блока с фоткой НЕТУ!!!

Видимо решаться должно так: тот код который добавлялся в раздел профиля надо добавить в тот код который вызывается когда админ редактирует профиль другого пользователя.

Только какие коды нужно вставить?

видимо $profilephoto_mod->execute_mod();
нужно вставить в тот файл который запускается когда админ редактирует профиль.

ПОМОГИТЕ добить мод.
И я выложу окончательные пояснения как мн это удалось и праблема будит решена

JHBTYN
phpBB 1.4.0
Сообщения: 38
Зарегистрирован: 18.09.2007 12:20
Контактная информация:

Сообщение JHBTYN » 16.10.2007 18:29

Никак не могу понять, в топике фото должно отображаться или нет? Все вроде работает как надо, в профиле фотка есть, в админке все настраивается, а в топике ее нет :roll:

Добавлено спустя 44 секунды:

Ставил два раза, и нифига...

Закрыто

Вернуться в «Поддержка модов для phpBB 2.0.x»