Общая ошибка Could not get style data
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
staiki
- phpBB 2.0.2
- Сообщения: 318
- Стаж: 14 лет 3 месяца
- Откуда: Киев Украина
- Благодарил (а): 76 раз
- Поблагодарили: 9 раз
- Забанен: Бессрочно
Re: Общая ошибка Could not get style data
Извините за дубль.
http://staiki.net/index.php Форум Компьютерная Помощь
-
clipart
- phpBB 1.0.0
- Сообщения: 1
- Стаж: 13 лет 1 месяц
Re: Общая ошибка Could not get style data
Столкнулся с такой же проблемой. После установки форума Could not get style data. Пробовал все что угодно, менял версию PHP и тип базы, ничего не помогло. Хостер серьезный и дорогой. Написал в техподдержку, получил следующий ответ:
1. Установил форум на другой хостинг (можно на локальный компьютер на Денвер)
2. сделал бэкап базы через phpMyAdmin
3. скопировал файлы форума на новый хостинг и сделал импорт базы.
4. Прописал параметры новой базы в файле config.php
В результате форум заработал на новом фостинге. Следующее что обязательно нужно сделать - исправить настройки куки в админке, там остается прописан старый адрес сайта. Все работает.
Решил проблему следующим образом:Атрибут AUTO_INCREMENT обычно используется для генерации уникального
идентификатора для новых строк. На наших серверах AUTO_INCREMENT - 10. Изменить
его значение мы не можем. Такой авто-инкремент связан с кластеризацией сервера
базы данных в целях повышения производительности и надежности его работы.
В связи с настройкой данного параметра установка phpBB 3.0.11, сразу на хостинг аккаунт, затруднительна.
В рамках решения данного вопроса Вы можете осуществимость установку, локально, после чего создать дам БД
и развернуть его на на хостинг аккаунт.
1. Установил форум на другой хостинг (можно на локальный компьютер на Денвер)
2. сделал бэкап базы через phpMyAdmin
3. скопировал файлы форума на новый хостинг и сделал импорт базы.
4. Прописал параметры новой базы в файле config.php
В результате форум заработал на новом фостинге. Следующее что обязательно нужно сделать - исправить настройки куки в админке, там остается прописан старый адрес сайта. Все работает.
-
x999am26rus
- phpBB 1.0.0
- Сообщения: 1
- Стаж: 13 лет
Re: Общая ошибка Could not get style data
Удалил стиль, появилась ошибка:
может и не из-за того что удалил стиль, без понятия, помогите исправить, спасибо!
Код: Выделить всё
Общая ошибка
Template path could not be found: styles/quasar/template
BACKTRACE
FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()
FILE: [ROOT]/includes/template.php
LINE: 81
CALL: trigger_error()
FILE: [ROOT]/includes/session.php
LINE: 1735
CALL: template->set_template()
FILE: [ROOT]/index.php
LINE: 26
CALL: user->setup()
-
rxu
- phpBB Guru

- Сообщения: 17272
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Общая ошибка Could not get style data
Нельзя удалять стиль путем простого удаления папки на сервере. Это делается через админраздел.
Скопируйте файлы обоатно и удалите как положено, средствами форума.
Скопируйте файлы обоатно и удалите как положено, средствами форума.
-
Jackssson
- phpBB 1.2.0
- Сообщения: 17
- Стаж: 12 лет 9 месяцев
- Благодарил (а): 4 раза
Re: Общая ошибка Could not get style data
Добрый день. Описание моей ситуации:
Началось все с того, что форум перестал пускать в админку. Также выяснилось что превышена квота на ftp. В соответствующей теме воспользовался советом и почистил папку cache(удалил все кроме index.htm и .htaccess). Затем в phpmyadmin почистил таблицу phpbb_log(220тыс записей и 420мб объема). Теперь при переходе в раздел форума выдает эту общую ошибку. Подскажите пожалуйста, в чем может быть дело?
ЗЫ: Сайт не мой, в phpBB ковыряюсь впервые. Версия форума вроде 3.0.9.
Началось все с того, что форум перестал пускать в админку. Также выяснилось что превышена квота на ftp. В соответствующей теме воспользовался советом и почистил папку cache(удалил все кроме index.htm и .htaccess). Затем в phpmyadmin почистил таблицу phpbb_log(220тыс записей и 420мб объема). Теперь при переходе в раздел форума выдает эту общую ошибку. Подскажите пожалуйста, в чем может быть дело?
ЗЫ: Сайт не мой, в phpBB ковыряюсь впервые. Версия форума вроде 3.0.9.
-
Sheer
- Former team member
- Сообщения: 12113
- Стаж: 19 лет 7 месяцев
- Откуда: Калининград не Кенигсберг
- Благодарил (а): 54 раза
- Поблагодарили: 2756 раз
Re: Общая ошибка Could not get style data
Jackssson
Читать, начиная с этого места Общая ошибка Could not get style data
Читать, начиная с этого места Общая ошибка Could not get style data
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
-
Jackssson
- phpBB 1.2.0
- Сообщения: 17
- Стаж: 12 лет 9 месяцев
- Благодарил (а): 4 раза
Re: Общая ошибка Could not get style data
Sheer
Зайти в админку форума по ссылке не удалось. В таблице, в поле default_styile вообще стояло значение "7". Поменял на "1", затем снова на "7" и вроде заработало.
Как бы странно это ни звучало, но работает нестабильно. Примерно раз в пару часов снова приходится чистить кэш, ибо ошибка повторяется.
Зайти в админку форума по ссылке не удалось. В таблице, в поле default_styile вообще стояло значение "7". Поменял на "1", затем снова на "7" и вроде заработало.
Как бы странно это ни звучало, но работает нестабильно. Примерно раз в пару часов снова приходится чистить кэш, ибо ошибка повторяется.
-
Sheer
- Former team member
- Сообщения: 12113
- Стаж: 19 лет 7 месяцев
- Откуда: Калининград не Кенигсберг
- Благодарил (а): 54 раза
- Поблагодарили: 2756 раз
Re: Общая ошибка Could not get style data
Вот зачем? Вы отдаете себе отчет в том, что такое в данном случае 1, а что такое 7?Jackssson писал(а):Поменял на "1", затем снова на "7"
Какой стиль вы используете?
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
-
Jackssson
- phpBB 1.2.0
- Сообщения: 17
- Стаж: 12 лет 9 месяцев
- Благодарил (а): 4 раза
Re: Общая ошибка Could not get style data
Вроде дефолтный для 3.0.X, где то в админке видел.Sheer писал(а):Вот зачем? Вы отдаете себе отчет в том, что такое в данном случае 1, а что такое 7?
Какой стиль вы используете?
В общем ошибка повторилась в очередной раз, и как говорится надолго. Я пробовал чистить форум через Центр Модератора и экспериментировал с количеством тем на странице(начал с 5000 и пошел в сторону нуля, т.к. грохнуть тему целиком нельзя, а в районе 100тыс тем надо удалить). Пару раз вылетала какая-то ошибка sql, какой-то там select, точно не скажу - не записал. Потом я снова почистил кэш и все. Новый кэш больше не появляется, перезапись default_style ничего не дает.
ЗЫ:Не удивлюсь, если люди знающие сейчас ржут над моими выходками, но как говорится: "Пгошу понять и пгостить!"(с).
-
Sheer
- Former team member
- Сообщения: 12113
- Стаж: 19 лет 7 месяцев
- Откуда: Калининград не Кенигсберг
- Благодарил (а): 54 раза
- Поблагодарили: 2756 раз
Re: Общая ошибка Could not get style data
Jackssson
Ok, я уже просил доступ к ftp. Предложение в силе. Только теперь еще доступ к PMA и логин и пароль администратора.
"Аборт по телефону не сделаешь" (c)
Ok, я уже просил доступ к ftp. Предложение в силе. Только теперь еще доступ к PMA и логин и пароль администратора.
"Аборт по телефону не сделаешь" (c)
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
-
Pazh
- Former team member
- Сообщения: 2317
- Стаж: 16 лет 10 месяцев
- Благодарил (а): 42 раза
- Поблагодарили: 506 раз
Re: Общая ошибка Could not get style data
Jackssson все ваши ошибки от этого:
1. увеличивать размер места на жестком диске на хостинге (скорее всего сменой тарифного план)
2. удалить старые вложения
3. очистить таблицы phpbb_log, переключиться с FULL_NATIVE на FULL_MYSQL поиск - но не факт что это поможет, т.к. БД может храниться не в вашем выделенном жестком диске
вариантов решения несколько:Jackssson писал(а):превышена квота на ftp
1. увеличивать размер места на жестком диске на хостинге (скорее всего сменой тарифного план)
2. удалить старые вложения
3. очистить таблицы phpbb_log, переключиться с FULL_NATIVE на FULL_MYSQL поиск - но не факт что это поможет, т.к. БД может храниться не в вашем выделенном жестком диске
Помощь в ЛС/email только за WM или ЮMoney
-
Jackssson
- phpBB 1.2.0
- Сообщения: 17
- Стаж: 12 лет 9 месяцев
- Благодарил (а): 4 раза
Re: Общая ошибка Could not get style data
Sheer
Я прекрасно понимаю, что владея определенными знаниями иногда все проще починить самому, но форум не мой, а его хозяйка слезно просила доступ больше никому не давать, я уж хз почему она так боится. Как вариант, могу провести демонстрацию через TeamViewer или если вы из Москвы попробовать созвониться и уж дальше как-то это порешать. Да и мне было бы интересно изучить этот вопрос, мало ли где пригодится. Собственно только из-за интереса я и взялся за эту проблему.
Pazh
Я прекрасно понимаю, что владея определенными знаниями иногда все проще починить самому, но форум не мой, а его хозяйка слезно просила доступ больше никому не давать, я уж хз почему она так боится. Как вариант, могу провести демонстрацию через TeamViewer или если вы из Москвы попробовать созвониться и уж дальше как-то это порешать. Да и мне было бы интересно изучить этот вопрос, мало ли где пригодится. Собственно только из-за интереса я и взялся за эту проблему.
Pazh
Pazh писал(а):1. увеличивать размер места на жестком диске на хостинге (скорее всего сменой тарифного план)
логи я уже чистил, освободилось 420 метров. Этого же должно хватить на какое-то время? Увеличивать квоту хозяйка форума не хочет, тк это доп. расходы.Pazh писал(а):очистить таблицы phpbb_log
Если дадите ссылку на тему с описанием, как это сделать, буду очень благодарен.Pazh писал(а):переключиться с FULL_NATIVE на FULL_MYSQL поиск
-
Пчелкин
- phpBB 3.3.0
- Сообщения: 11361
- Стаж: 16 лет 8 месяцев
- Благодарил (а): 1832 раза
- Поблагодарили: 1358 раз
Re: Общая ошибка Could not get style data
Это поисковый механизм...переключается в админке во вкладке ПОИСК...Jackssson писал(а):Если дадите ссылку на тему с описанием
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
-
Pazh
- Former team member
- Сообщения: 2317
- Стаж: 16 лет 10 месяцев
- Благодарил (а): 42 раза
- Поблагодарили: 506 раз
Re: Общая ошибка Could not get style data
если 420 метров занимали логи - возможно у вас большие проблемы на форуме с ошибками. В config.php расскомменируйте debug строки и посмотрите что будет на страницах форума.Jackssson писал(а):420 метров. Этого же должно хватить на какое-то время?
Админка - Обсуживание - Поисковый индексы - нажать кнопку "Создать индексы" в таболице Fulltext mysql - это уменьшит размер БД, но увеличит нагрузку на MySQL - если будет большая нагрузка, то переключитесь обратноJackssson писал(а): Pazh писал(а):переключиться с FULL_NATIVE на FULL_MYSQL поиск
Если дадите ссылку на тему с описанием, как это сделать, буду очень благодарен.
Да, и в админка -Поиск поменять поисковый механизм
Помощь в ЛС/email только за WM или ЮMoney


