Ошибка при восстановлении из бэкапа

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
crash
Former team member
Сообщения: 6517
Стаж: 22 года 2 месяца
Откуда: Бердск
Поблагодарили: 15 раз

Re: Ошибка при восстановлении из бэкапа

Сообщение crash »

***Blaze***
интересно, как имя домена влияет на ограничение в 30 секунд.
nissin
ну он вроде как частями делает, но сам не пробовал :)
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
dmmmm
phpBB 1.0.0
Сообщения: 5
Стаж: 18 лет 2 месяца

Re: Ошибка при восстановлении из бэкапа

Сообщение dmmmm »

мне помогло обращение к хостеру с просьбой о восстановлении
Базу он восстановил, после чего увеличил время ожидания, наверное

Чтобы так не встрять с небольшой БД, проще всего сохранять бэкап средствами форума, до этого нужно переключить в настройках форума поиск с Fulltext native на Fulltext mysql. Размер бэкапа после этого уменьшается в 10 раз (3,28Мб с Fulltext native и 214 Кб с Fulltext mysql)
Аватара пользователя
crash
Former team member
Сообщения: 6517
Стаж: 22 года 2 месяца
Откуда: Бердск
Поблагодарили: 15 раз

Re: Ошибка при восстановлении из бэкапа

Сообщение crash »

dmmmm писал(а):Чтобы так не встрять с небольшой БД, проще всего сохранять бэкап средствами форума
спорный вопрос лучше средствами форума или другими средствами
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
shvager
phpBB 1.4.4
Сообщения: 159
Стаж: 18 лет 5 месяцев
Благодарил (а): 104 раза
Поблагодарили: 8 раз

Re: Ошибка при восстановлении из бэкапа

Сообщение shvager »

У меня вопрос немножко не в тему(не хотел еще одну создавать).
Короче - никак не могу создать бэкап. Сначала все было хорошо. Но когда база стала уже больше 70мб при попытке создать архив выскакивает сообщение об ошибке:
"Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request...."
В настройка php ini время ожидания выставил на 900 сек. Всеравно не могу создать архив. Что только не перебробывал. В чем тут причина?


Спасибо.
Аватара пользователя
Alek$
Former team member
Сообщения: 2616
Стаж: 21 год 1 месяц
Откуда: Новосибирск
Поблагодарили: 37 раз

Re: Ошибка при восстановлении из бэкапа

Сообщение Alek$ »

shvager
1) Используйте панель управления хостера - там, как правило, проблем с большими базами не возникает.
2) Используйте альтернативные дамперы
3) Что в логах сервера?
Самая страшная ошибка, это ошибка без видимых причин и конкретных последствий.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
Аватара пользователя
Rayden
Former team member
Сообщения: 3739
Стаж: 21 год 2 месяца
Поблагодарили: 44 раза

Re: Ошибка при восстановлении из бэкапа

Сообщение Rayden »

shvager писал(а):Короче - никак не могу создать бэкап. Сначала все было хорошо.
Блеск! :)
Вообще-то тема о проблемах при восстановлении.
phpBB2 FAQ
phpBB3 FAQ
ilya300
phpBB 1.4.1
Сообщения: 49
Стаж: 19 лет 9 месяцев

Re: Ошибка при восстановлении из бэкапа

Сообщение ilya300 »

Вопрос такой. При создании бекапа на сервер сохраняется только 21 мб базы, а сама база весит 180 мб. Как решить проблему ?
ЗЫ за это должно отвечать время ожидания? как называется параметр в php.ini ?
Аватара пользователя
Rayden
Former team member
Сообщения: 3739
Стаж: 21 год 2 месяца
Поблагодарили: 44 раза

Re: Ошибка при восстановлении из бэкапа

Сообщение Rayden »

бекапить нормальными средствами.
phpBB2 FAQ
phpBB3 FAQ
ilya300
phpBB 1.4.1
Сообщения: 49
Стаж: 19 лет 9 месяцев

Re: Ошибка при восстановлении из бэкапа

Сообщение ilya300 »

а если через phpMyAdmin скачивается не вся база то тогда разбивать по таблицам? А если таблица постов не скачивается тогда что? можно же как то сохранить базу через ssh в концоле mysql ?
Аватара пользователя
Rayden
Former team member
Сообщения: 3739
Стаж: 21 год 2 месяца
Поблагодарили: 44 раза

Re: Ошибка при восстановлении из бэкапа

Сообщение Rayden »

можно. И даже не надо в консоль мускула заходить. Есть утилита mysqldump.exe - это наиболее лучшее и быстрое решение для создания дампа.
phpBB2 FAQ
phpBB3 FAQ
Аватара пользователя
crash
Former team member
Сообщения: 6517
Стаж: 22 года 2 месяца
Откуда: Бердск
Поблагодарили: 15 раз

Re: Ошибка при восстановлении из бэкапа

Сообщение crash »

ilya300
прочтите раздел FAQ по 2 версии, там есть как сделать бэкап/восстановить по ssh
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
uznaipravdu
phpBB 1.4.3
Сообщения: 81
Стаж: 20 лет 4 месяца
Благодарил (а): 1 раз

Re: Ошибка при восстановлении из бэкапа

Сообщение uznaipravdu »

При резервировании базы через phpbb3 файл обрывался, не сформировавшись до конца.
оказалось , что в
.../includes/acp/acp_database.php стоит time limit = 1200,
я так понял , что это 1200 секунд, у меня за это время база не успевала сформироваться и отбивалось по таймауту. увеличьте его до 3200 и будет резервироваться нормально до конца. с этим все получилось .

Код: Выделить всё

if ($type == 'full' || $type == 'structure')

{

$structure = true;

}

if ($type == 'full' || $type == 'data')

{

$schema_data = true;

}

@set_time_limit(3200);

$time = time();

$filename = 'backup_' . $time . '_' . unique_id();

switch ($db->sql_layer)
---------------------------------------------------------
теперь надо восстановить
восстановление длинного файла отбивается через 30 секунд

Код: Выделить всё

Fatal error: Maximum execution time of 30 seconds exceeded in z:\home\localhost\www\new\includes\acp\acp_database.php on line 2225
это не на хосте, а на локальнеой машине.
вот кусок этого файла, кто знает что можно сделать?

Код: Выделить всё

// modified from PHP.net

function fgetd(&$fp, $delim, $read, $seek, $eof, $buffer = 8192)

{

$record = '';

$delim_len = strlen($delim);


while (!$eof($fp))   [color=#FF0000] вот она 2225 строчка[/color]

{

$pos = strpos($record, $delim);

if ($pos === false)

{

$record .= $read($fp, $buffer);

if ($eof($fp) && ($pos = strpos($record, $delim)) !== false)

{

$seek($fp, $pos + $delim_len - strlen($record), SEEK_CUR);

return substr($record, 0, $pos);

}

}

else

{

$seek($fp, $pos + $delim_len - strlen($record), SEEK_CUR);

return substr($record, 0, $pos);

}

}

return false;

}

function fgetd_seekless(&$fp, $delim, $read, $seek, $eof, $buffer = 8192)

{

static $array = array();

static $record = '';

if (!sizeof($array))

{

while (!$eof($fp))

{

if (strpos($record, $delim) !== false)

{

$array = explode($delim, $record);

$record = array_pop($array);

break;

}

else

{

$record .= $read($fp, $buffer);

}

}

if ($eof($fp) && strpos($record, $delim) !== false)

{

$array = explode($delim, $record);

$record = array_pop($array);

}

}

if (sizeof($array))

{

return array_shift($array);

}

return false;

}

?>
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Ошибка при восстановлении из бэкапа

Сообщение nissin »

Параметр max_execution_time в php.ini
Либо опять же воткнуть где нибудь:

Код: Выделить всё

@set_time_limit(3200);
uznaipravdu
phpBB 1.4.3
Сообщения: 81
Стаж: 20 лет 4 месяца
Благодарил (а): 1 раз

Re: Ошибка при восстановлении из бэкапа

Сообщение uznaipravdu »

а где находится php.ini?

и куда именно можно воткнуть
@set_time_limit(3200);
Аватара пользователя
Fray98rus
Former team member
Сообщения: 442
Стаж: 18 лет 11 месяцев
Откуда: Санкт-Петербург
Благодарил (а): 3 раза
Поблагодарили: 2 раза

Re: Ошибка при восстановлении из бэкапа

Сообщение Fray98rus »

uznaipravdu писал(а):где находится php.ini?
У хостера просить надо увеличить память на выполнение скрипта.

Хотя можно его попросить восстановить бэкап.

Вернуться в «Поддержка phpBB 3.0.х»