phpbb 3.0.3 [обсуждаем]

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
zolti
phpBB 1.4.0
Сообщения: 38
Стаж: 18 лет
Забанен: Бессрочно

Re: phpbb 3.0.3 [обсуждаем]

Сообщение zolti »

Русский прошёл валидацию. Спасибо авторам :)
Stern
phpBB 2.0.3
Сообщения: 368
Стаж: 21 год 5 месяцев

Re: phpbb 3.0.3 [обсуждаем]

Сообщение Stern »

Там показывается только последние 300 строк с ошибками... Вот только уже поздно смотреть его - я затер папку cache и теперь придется опять ждать два часа, пока форум снова остановится...
Хотя... вроде бы там была одна ошибка у всех: [error] [client 94.51.144.86] File does not exist:
Вот и сейчас даже при работающем форуме пишет ошибки:
File does not exist: /home/vitagil/public_html/ermak/404.shtml
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: phpbb 3.0.3 [обсуждаем]

Сообщение rxu »

Тогда ждите.
А пока подумайте: может, у вас место свободное заканчивается на хосте под ваш сайт?
Изображение
Stern
phpBB 2.0.3
Сообщения: 368
Стаж: 21 год 5 месяцев

Re: phpbb 3.0.3 [обсуждаем]

Сообщение Stern »

В этот раз пришлось ждать меньше часа.
Вот что выдает error.log

[Mon Nov 17 20:12:10 2008] [error] [client 87.118.70.222] File does not exist: /home/vitagil/public_html/404.shtml
[Mon Nov 17 20:12:10 2008] [error] [client 87.118.70.222] File does not exist: /home/vitagil/public_html/ermak/forum/indeforum.php

Ошибка и время ее не меняется, сколько бы я не обновлял страницу форума...

Добавлено спустя 6 минут 32 секунды:
Под сайт занято ровно половина отведенного дискового пространства...

Добавлено спустя 2 минуты 27 секунд:
Вот еще новые ошибки появились:
[error] [client 81.19.66.85] File does not exist: /home/vitagil/public_html/404.shtml
[error] [client 81.19.66.85] File does not exist: /home/vitagil/public_html/ermak/forum/template.include-once
[error] [client 81.19.66.85] File does not exist: /home/vitagil/public_html/404.shtml
[error] [client 81.19.66.85] File does not exist: /home/vitagil/public_html/ermak/forum/function.include
Stern
phpBB 2.0.3
Сообщения: 368
Стаж: 21 год 5 месяцев

Re: phpbb 3.0.3 [обсуждаем]

Сообщение Stern »

Спасибо всем! Проблема вроде бы решилась.
Вот что сообщил хостер: "форум создает файлы кэша не с системной umask. на сервере запускается скрипт, который исправляет права у плоьзователей в соответствии с этой umask, а в итоге получалось, что менялся владелец с nobody на юзера, группа при этом не изменялась, но форум не назначал никакого доступа группе nobody, поэтому скрипт и не мог прочитать эти файлы".
Аватара пользователя
Oleg NT
Former team member
Сообщения: 450
Стаж: 20 лет 8 месяцев
Откуда: Нижний Тагил
Поблагодарили: 11 раз

Re: phpbb 3.0.3 [обсуждаем]

Сообщение Oleg NT »

Применил автоматический «обновлятор», в двух файлах нашел три конфликтных места, в одном я сказал «объединить + взять из текущего файла», в другом — «объединить + взять из нового файла». После этого закачал предложенный архив.

При проверке файлов ему не понравился memberlist. Он сказал, что файл уже модифицирован, но конфликтов не найдено, давай его обновим. Причем список изменений был приличным (как будто бы memberlist.php так и остался старым). Я его сохранил (т.е. уже пропатченный, но по мнению второй прокерки еще не пропатченный). Применил еще раз патч. В итоге у меня — я посмотрел для примера блок «добавляемые строки» (зеленый) — он у меня получился два раза. Ну ладно, сделал как он хочет, потом просто заменил на сохраненный промежуточный файл.

Вроде все работает :)

Добавлено спустя 28 минут 16 секунд:
Все-таки правильно я не доверял автоматике. Патч неправильно «объединил» viewtopic.php, в итоге затер одну строчку от мода репутации. Репутация в темах пропала. Восстановил эту строчку.

Добавлено спустя 12 минут:
Ага, и еще затер «Last Post Topic on Index» (а точнее имя автора в шаблоне).
Что-то я еще больше не доверяю патчу. Как бы потом не аукнулось где-нибудь.
Аватара пользователя
FladeX
Former team member
Сообщения: 1935
Стаж: 19 лет 3 месяца
Откуда: Саранск
Благодарил (а): 7 раз
Поблагодарили: 59 раз

Re: phpbb 3.0.3 [обсуждаем]

Сообщение FladeX »

Oleg NT, вручную - самый надежный способ. А вообще лучше залить файлы от phpBB 3.0.3, а уже на них поставить все моды. Хотя об этом уже писали, простите за повтор.
//
// Okay, let's do the loop, yeah come on baby let's do the loop
// and it goes like this ...
| phpBB Adept ] | Каталог форумов | генератор sitemap для форумов | форум про форумы
Stern
phpBB 2.0.3
Сообщения: 368
Стаж: 21 год 5 месяцев

Re: phpbb 3.0.3 [обсуждаем]

Сообщение Stern »

А где брать пакет для ручного обновление? На оф.сайте code changes какой-то урезаный... Отличается от того, который указал Gisher - http://www.marshalrusty.com/phpBB/code_changes/
Аватара пользователя
crash
Former team member
Сообщения: 6517
Стаж: 22 года 2 месяца
Откуда: Бердск
Поблагодарили: 15 раз

Re: phpbb 3.0.3 [обсуждаем]

Сообщение crash »

почитайте на офсайте, там написано что они выложили изменения языковые и стилей
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
dengol
phpBB 1.2.0
Сообщения: 12
Стаж: 18 лет 4 месяца

Re: phpbb 3.0.3 [обсуждаем]

Сообщение dengol »

FladeX писал(а):А вообще лучше залить файлы от phpBB 3.0.3, а уже на них поставить все моды. Хотя об этом уже писали, простите за повтор.
Залить файлы, от 3.0.3 это понятно, а база ведь тоже обновляетя, как с базой быть?
Аватара пользователя
FladeX
Former team member
Сообщения: 1935
Стаж: 19 лет 3 месяца
Откуда: Саранск
Благодарил (а): 7 раз
Поблагодарили: 59 раз

Re: phpbb 3.0.3 [обсуждаем]

Сообщение FladeX »

dengol, базу нужно обновить запуском файла-апдейтера. Что-то вроде db_update.php должно быть (лень смотреть как на самом деле называется).
//
// Okay, let's do the loop, yeah come on baby let's do the loop
// and it goes like this ...
| phpBB Adept ] | Каталог форумов | генератор sitemap для форумов | форум про форумы
dengol
phpBB 1.2.0
Сообщения: 12
Стаж: 18 лет 4 месяца

Re: phpbb 3.0.3 [обсуждаем]

Сообщение dengol »

Да, database_update.php , но ведь его просто так не запустишь!
Если прописать просто путь к нему, то эффекта никакого не будет....
Аватара пользователя
FladeX
Former team member
Сообщения: 1935
Стаж: 19 лет 3 месяца
Откуда: Саранск
Благодарил (а): 7 раз
Поблагодарили: 59 раз

Re: phpbb 3.0.3 [обсуждаем]

Сообщение FladeX »

dengol
1. не тот файл используете
2. не так файл используете
:)
//
// Okay, let's do the loop, yeah come on baby let's do the loop
// and it goes like this ...
| phpBB Adept ] | Каталог форумов | генератор sitemap для форумов | форум про форумы
dengol
phpBB 1.2.0
Сообщения: 12
Стаж: 18 лет 4 месяца

Re: phpbb 3.0.3 [обсуждаем]

Сообщение dengol »

FladeX писал(а):dengol
1. не тот файл используете
2. не так файл используете
:)
Уважаемый FladeX, а не могли бы Вы поподробнее описать! Если конечно не затруднит. :)
1) какой файл использовать?
2) как использовать?
был бы простой .sql можно былобы просто запрос выполнить, а вот как использовать database_update.php я к сожалению не могу понять.

Спасибо, вопрос решил самостоятельно.
1) Создаём директорию install в корне форума
2) Копируем туда файл database_update.php
3) Прописываем путь в адресной строке браузера http://путь к папке с форумом/install/database_update.php
Аватара пользователя
crash
Former team member
Сообщения: 6517
Стаж: 22 года 2 месяца
Откуда: Бердск
Поблагодарили: 15 раз

Re: phpbb 3.0.3 [обсуждаем]

Сообщение crash »

dengol писал(а):Если прописать просто путь к нему, то эффекта никакого не будет....
прописывайте не просто так.
dengol писал(а):3) Прописываем путь в адресной строке браузера http://путь к папке с форумом/install/database_update.php
путь к папке,а домен?
dengol писал(а):то эффекта никакого не будет....
а вы какой эффект ожидаете?
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса

Вернуться в «Поддержка phpBB 3.0.х»