Ошибка почты
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
Izya
- Former team member
- Сообщения: 408
- Стаж: 18 лет
- Откуда: Абакан, Сибирь
- Благодарил (а): 1 раз
- Поблагодарили: 28 раз
Re: Проблема с почтой
Invulnerabilis
А у Вас в полях "Контактный email-адрес" и "Обратный email-адрес" указан точно тот адрес, который зарегистрирован в Рамблере?
А у Вас в полях "Контактный email-адрес" и "Обратный email-адрес" указан точно тот адрес, который зарегистрирован в Рамблере?
-
Invulnerabilis
- phpBB 1.0.0
- Сообщения: 4
- Стаж: 17 лет 8 месяцев
Re: Проблема с почтой
Большое спасибо за помощь )Izya Сегодня 11:00
Invulnerabilis
А у Вас в полях "Контактный email-адрес" и "Обратный email-адрес" указан точно тот адрес, который зарегистрирован в Рамблере?
Контактный email-адрес и Обратный email-адрес была ошибка в адресе исправил и все заработало )
-
Sulpher
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 17 лет 3 месяца
- Откуда: Краснодар
Не получается настроить почтовую функцию
Добрый день форумчанам.
У меня с phpBB3 возникла проблема... Не могу настроить почтовую функцию на форуме - там по умолчанию указан mail (обращение к функции PHP), но почему-то письма не ходят...
Средства связи > настройки почты > Имя функции e-mail: указано mail по умолчанию. Пробую изменить на sendmail, но почему-то при обновлении страницы откатывает назад на mail. В чем может быть проблема?
На хостинге функция mail работает.
Прошу помочь разобраться в проблеме.
У меня с phpBB3 возникла проблема... Не могу настроить почтовую функцию на форуме - там по умолчанию указан mail (обращение к функции PHP), но почему-то письма не ходят...
Средства связи > настройки почты > Имя функции e-mail: указано mail по умолчанию. Пробую изменить на sendmail, но почему-то при обновлении страницы откатывает назад на mail. В чем может быть проблема?
На хостинге функция mail работает.
Прошу помочь разобраться в проблеме.
Платформа: FreeBSD s10.leaderhost.ru 6.1-RELEASE-p19 FreeBSD 6.1-RELEASE-p19 #0: Tue Sep 25 17:58:01 MSD 2007 root@s10.leaderhost.ru:/usr/obj/usr/src/sys/S10KERNEL i386
Версия MySQL: 5.1.26-rc-percona-log
Сравнение БД: utf8_general_ci
Версия PHP: 5.2.6
Веб-сервер: Apache/1.3.41 (Unix) mod_tsunami/3.0 PHP/5.2.6 mod_throttle/3.1.2 mod_psoft_traffic/0.2 mod_ssl/2.8.31 OpenSSL/0.9.7e-p1
Интерфейс веб-сервер -> PHP: apache
sendmail_from no value no value
sendmail_path /usr/sbin/sendmail -t -i -fphp-sender-dev.vernikov.ru@web1.leaderhost.ru /usr/sbin/sendmail -t -i
serialize_precision 100 100
short_open_tag On On
SMTP localhost localhost
smtp_port 25 25
-
rxu
- phpBB Guru

- Сообщения: 17272
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Не получается настроить почтовую функцию
Не уходят или не приходят?Sulpher писал(а):указан mail (обращение к функции PHP), но почему-то письма не ходят...
-
Sulpher
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 17 лет 3 месяца
- Откуда: Краснодар
Re: Не получается настроить почтовую функцию
Хмм... не приходят. То есть, регистрирую пользователя нового на сайте, получаю сообщение о том, что активационное письмо было отправлено пользователю на ящик. Но в почте пусто. Пробовал разные ящики - inbox.ru, gmail.com, так что тут вряд ли дело в спам фильтрах.
Меня ещё смущает тот факт, что если в настройках пытаюсь изменить название функции отправки с mail на, напрмимер, sendmail, то получаю сообщение, что изменения приняты, а при повторном заходе на страничку настроек почты вижу там снова mail.
Добавлено спустя 55 секунд:
rxu, могу отправить Вам данные доступа на сайт, сможете посмотреть, если не затруднит?
Меня ещё смущает тот факт, что если в настройках пытаюсь изменить название функции отправки с mail на, напрмимер, sendmail, то получаю сообщение, что изменения приняты, а при повторном заходе на страничку настроек почты вижу там снова mail.
Добавлено спустя 55 секунд:
rxu, могу отправить Вам данные доступа на сайт, сможете посмотреть, если не затруднит?
-
rxu
- phpBB Guru

- Сообщения: 17272
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Не получается настроить почтовую функцию
В логе ошибок в админразделе (закладка Обслуживание) есть что-то, связанное с рассылкой сообщений?
-
Sulpher
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 17 лет 3 месяца
- Откуда: Краснодар
Re: Не получается настроить почтовую функцию
Вы правы! Ошибка следующая:
Сейчас ещё потестирую.
Но Вам спасибо за оперативный ответ!
У меня был указан способ отправки smtp и невозможность законнектиться с сервером... Помню, сделал это в качестве экспериментов, т.к. отправка через mail не работала. А теперь работает, чудеса... Остаётся только грешить либо на хостеров, либо что-то не так делал изначально.Ошибка почты
» EMAIL/SMTP
./forum/ucp.php
Не удалось соединиться с SMTP-сервером: 13 : Permission denied
<b>[phpBB Debug] PHP Notice</b>: in file <b>/includes/functions_messenger.php</b> on line <b>846</b>: <b>fsockopen(): unable to connect to smtp.inbox.ru:25 (Permission denied)</b><br />
Сейчас ещё потестирую.
Но Вам спасибо за оперативный ответ!
-
Sulpher
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 17 лет 3 месяца
- Откуда: Краснодар
Re: Ошибка почты
rxu, извините, еще такой вопрос: у меня при регистрации нового пользователя, ему приходит уведомление на e-mail с активационным письмом, но... если пользователем подписаться на тему и другими пользователями оставить сообщения, то такого уведомления на e-mail не приходит, а, по идее, должно. Можете дать наводку, где рыть?
-
Sulpher
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 17 лет 3 месяца
- Откуда: Краснодар
-
мотоциклист
- phpBB 1.4.2
- Сообщения: 52
- Стаж: 17 лет 7 месяцев
Re:
А где эти логи посмотреть? Через админку Форума, или у хостера? И если у хостера, то по какому файлу смотреть логи нужно?***Blaze*** писал(а):Вот такая ошибка в логах:Код: Выделить всё
Ошибка почты » EMAIL/PHP/mail() /forum/adm/index.php
Добавлено спустя 8 минут 9 секунд:
Re: Ошибка почты
Захожу Админка/Система/Массовая расылка почты, после попытки отправки выдаёт красный прямоугольник с надписью:
Информация
Произошли ошибки во время отправки сообщения. Посмотрите лог ошибок для получения более подробных сведений об ошибках.
« Вернуться на предыдущую страницу
где этот лог ошибок можно увидеть?
-
Alek$
- Former team member
- Сообщения: 2616
- Стаж: 21 год 1 месяц
- Откуда: Новосибирск
- Поблагодарили: 37 раз
Re: Ошибка почты
мотоциклист
в админке есть соответствующий раздел.
в админке есть соответствующий раздел.
Самая страшная ошибка, это ошибка без видимых причин и конкретных последствий.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
-
Виталий Тараканов
- phpBB 1.0.0
- Сообщения: 1
- Стаж: 17 лет 2 месяца
Re: Ошибка почты
У меня была проблема с массовой рассылкой почты, поделюсь решением.
Шлю, через некоторое время в логах вижу, что SpamAsassin отвергает письма.
Ни одному тестовому пользователю письма не дошли.
Рассылка проводилась с использованием SMTP-сервера провайдера и использованием того-же домена, на котором стоит форум.
Если вместо SMTP-сервера провайдера использовался SMTP-сервер бесплатной службы http://pochta.ru, то первые 2 пачки писем уходили нормально, некоторые тестовые пользователи получали рассылку, затем в логах снова ошибка - Почта.Ру дальнейшие пачки отвергает за то, что превышен лимит отправляемых сообщений.
Ситуация разрешилась после обращения к хостеру - они вручную занесли домен, на котором стоит форум, в белые списки и теперь пользуюсь SMTP-сервером провайдера и использую тот-же домен, на котором стоит форум.
Видно, кто-то из получателей на своём почтовом ящике пометил как спам, поэтому домен и попал в списки SpamAsassin'а.
С уважением, Виталий Викторович Тараканов
Шлю, через некоторое время в логах вижу, что SpamAsassin отвергает письма.
Ни одному тестовому пользователю письма не дошли.
Рассылка проводилась с использованием SMTP-сервера провайдера и использованием того-же домена, на котором стоит форум.
Если вместо SMTP-сервера провайдера использовался SMTP-сервер бесплатной службы http://pochta.ru, то первые 2 пачки писем уходили нормально, некоторые тестовые пользователи получали рассылку, затем в логах снова ошибка - Почта.Ру дальнейшие пачки отвергает за то, что превышен лимит отправляемых сообщений.
Ситуация разрешилась после обращения к хостеру - они вручную занесли домен, на котором стоит форум, в белые списки и теперь пользуюсь SMTP-сервером провайдера и использую тот-же домен, на котором стоит форум.
Видно, кто-то из получателей на своём почтовом ящике пометил как спам, поэтому домен и попал в списки SpamAsassin'а.
С уважением, Виталий Викторович Тараканов
-
Dmytro_ua
- phpBB 1.0.0
- Сообщения: 2
- Стаж: 17 лет 2 месяца
Почта для админа
Уважаемые форумчане!
Не могу настроить получение почты админом (на подписки, новые темы, новые юзеры и т.д.)
Другие пользователи получают массовую рассылку, подтверждение регистрации, подписку на темы, а админ нет.
Размер почтового пакета: пробовал делать 0 (не помогло).
Хостер говорит, что должно все работать. Настройки SMTP включать не нужно.
Контактный и обратный email-адрес одинаковые. Пробовал разные и gmail.com, и ukr.net.
Ставлю мыло для юзера ***@ukr.net - приходит. Ставлю этот же адрес админу - ничего.
Отправляю массовую рассылку нескольким пользователям, включая админа, все сразу получают, админ - нет.
В логе ошибок - пусто!
Помогите плз.
п.с. Версия 3.0.5
Не могу настроить получение почты админом (на подписки, новые темы, новые юзеры и т.д.)
Другие пользователи получают массовую рассылку, подтверждение регистрации, подписку на темы, а админ нет.
Размер почтового пакета: пробовал делать 0 (не помогло).
Хостер говорит, что должно все работать. Настройки SMTP включать не нужно.
Контактный и обратный email-адрес одинаковые. Пробовал разные и gmail.com, и ukr.net.
Ставлю мыло для юзера ***@ukr.net - приходит. Ставлю этот же адрес админу - ничего.
Отправляю массовую рассылку нескольким пользователям, включая админа, все сразу получают, админ - нет.
В логе ошибок - пусто!
Помогите плз.
п.с. Версия 3.0.5
-
Dmytro_ua
- phpBB 1.0.0
- Сообщения: 2
- Стаж: 17 лет 2 месяца
Re: Почта для админа
На всякий случай перелил файлы форума (кром config) - ничего не изменилось.
Дополнительных модов не устанавливал.
В чем может быть проблема? Очень нужна ваша помощь..
Дополнительных модов не устанавливал.
В чем может быть проблема? Очень нужна ваша помощь..
-
rxu
- phpBB Guru

- Сообщения: 17272
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Ошибка почты
Если все получают, а админ - нет, проблема не в коде. У вас хоть в настройках установлена опция уведомления по емайл (Личный раздел, Личные настройки, кажется - Получать email-рассылки администрации)?

