Благодарю, буду обновляться. Завтра все установлю. А для обновления в русском языке достаточно поставить приведенный мод на первой странице и обновится ли английский без доп. вмешательств, т.к. у меня форум мультиязычный и мне это тоже важно?***Blaze*** писал(а):vitty на русском изменения
Вышел phpBB 3.0.5 [обсуждаем]
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
vitty
- phpBB 1.4.4
- Сообщения: 193
- Стаж: 20 лет 3 месяца
- Благодарил (а): 9 раз
Re: Вышел phpBB 3.0.5 [обсуждаем]
-
Grenuy
- phpBB 1.0.0
- Сообщения: 4
- Стаж: 17 лет 5 месяцев
Re: Вышел phpBB 3.0.5 [обсуждаем]
Есть вот такая проблема, у меня версия 3.0.RC5 при попытки обновления вечно какие-то бока вылазят, пытался обновить двома АПгрейдами
1. phpBB-3.0.5-RC1_to_3.0.5
2. phpBB-3.0.4_to_3.0.5
первое в обох случиях при обновления базы следуемые ошибки:
дальше разное
при обновлени файлом phpBB-3.0.5-RC1_to_3.0.5 при нажатии кнопки, после обновления базы, "продолжить процес обновления " следуещая ошибка
При обновлении пакетом phpBB-3.0.4_to_3.0.5 проходит проверка... вот только Файлов обновляет тьма тьмущу, и конфликтов в файлов очень много... И после обновления полюбом какойто заругается... пытался заменить некотырые файли кое че подправить ну и т.д. т.п. все безуспешно, всеравно вылазит то с одной стороны ошибка то с другой, была идея просто поставить с нуля phpbb 3 и на него чепануть базу, но тоже безрезультатно... ((
посоветуйте как быть и что делать что бы всетка заработало
1. phpBB-3.0.5-RC1_to_3.0.5
2. phpBB-3.0.4_to_3.0.5
первое в обох случиях при обновления базы следуемые ошибки:
Код: Выделить всё
Updating database schema
Progress :: . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done
Result :: Some queries failed, the statements and errors are listing below.
* Error :: Column 'post_subject' cannot be part of FULLTEXT index
SQL :: ALTER TABLE `phpbb_posts` CHANGE `post_subject` `post_subject` blob NOT NULL
This is probably nothing to worry about, update will continue. Should this fail to complete you may need to seek help at our support forums. See README for details on how to obtain advice.
Updating data
Progress :: . .
Notice: Undefined index: id in Z:\home\localhost\subdomain\install\database_update.php on line 768
[ убрать подсказку | никогда больше не показывать ]
Это предупреждение, вероятнее всего, возникает вследствие высокого уровня контроля ошибок в PHP, по умолчанию установленного в Денвере (E_ALL). Такой режим вывода ошибок является рекомендуемым и сильно помогает при отладке скриптов. Однако множество готовых скриптов требуют более низкого уровня ошибок.
Вы можете установить более слабый контроль ошибок одним из следующих способов:
* Впишите в скрипты строчку:
Error_Reporting(E_ALL & ~E_NOTICE);
Этот способ особенно удобен, если в скрипте есть один файл (конфигурационный), который подключается всеми остальными.
* Рекомендуемый способ. Создайте в директории со скриптом файл .htaccess следующего содержания:
php_value error_reporting 7
* Исправьте в /usr/local/php/php.ini значение error_reporting на E_ALL & ~E_NOTICE. Этот способ не является рекомендуемым и может привести к серьезным неудобствам при отладке!
[Денвер: показать возможную причину ошибки]
Notice: Undefined index: id in Z:\home\localhost\subdomain\install\database_update.php on line 769
. . . . . . . . . . . . . . . . . . Done
Result :: Some queries failed, the statements and errors are listing below.
* Error :: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3
SQL :: SELECT * FROM phpbb_acl_groups WHERE auth_option_id =
* Error :: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3
SQL :: SELECT * FROM phpbb_acl_roles_data WHERE auth_option_id =
* Error :: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3
SQL :: SELECT * FROM phpbb_acl_users WHERE auth_option_id =
при обновлени файлом phpBB-3.0.5-RC1_to_3.0.5 при нажатии кнопки, после обновления базы, "продолжить процес обновления " следуещая ошибка
Код: Выделить всё
Fatal error: Call to undefined method diff3::get_num_conflicts() in Z:\home\localhost\subdomain\install\install_update.php on line 1456посоветуйте как быть и что делать что бы всетка заработало
-
crash
- Former team member
- Сообщения: 6517
- Стаж: 22 года 2 месяца
- Откуда: Бердск
- Поблагодарили: 15 раз
Re: Вышел phpBB 3.0.5 [обсуждаем]
у вас 3.0RC5, а вы берете обновления с 3.0.5RC1 или с 3.0.4. Вам не кажется это странным? Или возьмите обновление для своей версии или попробуйте заменить все файлы последней версией форума, кроме config.php и обновить базу.
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
-
VLADARIK
- phpBB 1.0.0
- Сообщения: 1
- Стаж: 17 лет 3 месяца
Re: Вышел phpBB 3.0.5 [обсуждаем]
Здравствуйте ВСЕМ. есть 2 вопроса....
1й можно ли русифицировать админпанель в версии 3,0,5?
2й скопировал рус пакет (но система его не видит) то есть в админ панели и при регистрации не видно русского. Нашёл выход папку ru переименовал в en-us и при выборе указываю соответсвенно обединённые королевства, и при выборе en-us и отображается всё в рус кроме админпанели. как вообще бы правильно всё сделать?
3й где можно под форум скачать игровые скины, в часности интересует стиль под l2 (Lineage2 для версии 3,0,5)? ссылки*
Всем неравнодушнім заранее пасиб, даже биг спс.
1й можно ли русифицировать админпанель в версии 3,0,5?
2й скопировал рус пакет (но система его не видит) то есть в админ панели и при регистрации не видно русского. Нашёл выход папку ru переименовал в en-us и при выборе указываю соответсвенно обединённые королевства, и при выборе en-us и отображается всё в рус кроме админпанели. как вообще бы правильно всё сделать?
3й где можно под форум скачать игровые скины, в часности интересует стиль под l2 (Lineage2 для версии 3,0,5)? ссылки*
Всем неравнодушнім заранее пасиб, даже биг спс.
-
Борис Бердичевский
- phpBB 3.0.0 RC1
- Сообщения: 1457
- Стаж: 18 лет 8 месяцев
- Откуда: Израиль, Беэр-Шева
- Благодарил (а): 45 раз
- Поблагодарили: 81 раз
Re: Вышел phpBB 3.0.5 [обсуждаем]
Перешёл. Использовал автоматический переход, при этом оно затёрло мне все вызовы мода Prime Anti-bot. Благо я скопировал Форум (есть у меня такая возможность, сервер дома!), и затем, используя Araxis, восстановил из прежнего. Кстати, языковый пакет можно только Араксисом вставить. Иначе затрёт все модификации, потом фиг восстановишь...
Добавлено спустя 3 минуты 34 секунды:
Араксис -- это очень удобная утилита сравнения текстов, программ, кодов. На работе юзаем ее вовсю.
Добавлено спустя 3 минуты 34 секунды:
Араксис -- это очень удобная утилита сравнения текстов, программ, кодов. На работе юзаем ее вовсю.
После нескольких лет общения здесь и техсопровождения форумов я наконец понял, что ничего не понимаю в phpBB!
-
crash
- Former team member
- Сообщения: 6517
- Стаж: 22 года 2 месяца
- Откуда: Бердск
- Поблагодарили: 15 раз
Re: Вышел phpBB 3.0.5 [обсуждаем]
она и так русифицирована.VLADARIK писал(а):1й можно ли русифицировать админпанель в версии 3,0,5?
вообще русский пакет надо сначала установитьVLADARIK писал(а):как вообще бы правильно всё сделать?
например phpbb.comVLADARIK писал(а):3й где можно под форум скачать игровые скины, в часности интересует стиль под l2 (Lineage2 для версии 3,0,5)?
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
-
dmitrij2009
- phpBB 1.2.0
- Сообщения: 12
- Стаж: 17 лет 5 месяцев
Re: Вышел phpBB 3.0.5 [обсуждаем]
Поставил последние обновления без проблем, использовал автоматический режим (рекомендованный).
Стояли моды + был изменен стиль форума, всё осталось как было)) моды не слетели, обновил кеш и о чудо! всё в порядке)) я даже удивлен! думал придется всё переписывать по новой. Хотя мне кажется что форум стал на пару сек немного медленней))) посмотрим...
Стояли моды + был изменен стиль форума, всё осталось как было)) моды не слетели, обновил кеш и о чудо! всё в порядке)) я даже удивлен! думал придется всё переписывать по новой. Хотя мне кажется что форум стал на пару сек немного медленней))) посмотрим...
-
Izya
- Former team member
- Сообщения: 408
- Стаж: 18 лет
- Откуда: Абакан, Сибирь
- Благодарил (а): 1 раз
- Поблагодарили: 28 раз
Re: Вышел phpBB 3.0.5 [обсуждаем]
Я вчера обновлял форум с парой десятков модов автоапдейтером. В числе модов - Prime AntiBot. Ни одной строчки мода задето не было, и функционирует он как и прежде (равно как и остальные моды). Ей-богу, Вы как нагоните мути...Борис Бердичевский писал(а):Использовал автоматический переход, при этом оно затёрло мне все вызовы мода Prime Anti-bot
А что касается обновления языкового пакета, надо использовать codechanges, а не тупо копировать новый ленгпак поверх старого на модифицированной конференции.
-
Stern
- phpBB 2.0.3
- Сообщения: 368
- Стаж: 21 год 5 месяцев
Re: Вышел phpBB 3.0.5 [обсуждаем]
Тоже обновился без проблем. Моды не задеты - ни БО, ни Prime Anti-bot...
Отдельное спасибо за обновление русского в виде мода.
Отдельное спасибо за обновление русского в виде мода.
-
Борис Бердичевский
- phpBB 3.0.0 RC1
- Сообщения: 1457
- Стаж: 18 лет 8 месяцев
- Откуда: Израиль, Беэр-Шева
- Благодарил (а): 45 раз
- Поблагодарили: 81 раз
Re: Вышел phpBB 3.0.5 [обсуждаем]
Перепроверил.
Странно очень, но при повторном объединении файлов файл includes/ucp/ucp_register.php объединился совсем по-другому...
Добавлено спустя 5 минут 9 секунд:
При этом повторно объединённый файл вообще оказался дефектным, не работает...
Добавлено спустя 43 минуты 45 секунд:
Pir1
насчёт
•[Fix] IE8 textarea issues (Bug #43305)
Просто включен принудительно (через мета) режим Compatibility View, т.е. добавлена строка
(Не обратил внимания, что об этом уже говорилось выше.)
Странно очень, но при повторном объединении файлов файл includes/ucp/ucp_register.php объединился совсем по-другому...
Добавлено спустя 5 минут 9 секунд:
При этом повторно объединённый файл вообще оказался дефектным, не работает...
Добавлено спустя 43 минуты 45 секунд:
Pir1
насчёт
•[Fix] IE8 textarea issues (Bug #43305)
Просто включен принудительно (через мета) режим Compatibility View, т.е. добавлена строка
Код: Выделить всё
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />После нескольких лет общения здесь и техсопровождения форумов я наконец понял, что ничего не понимаю в phpBB!
-
Владислав
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 17 лет 3 месяца
Re: Вышел phpBB 3.0.5 [обсуждаем]
У меня проблемы с кодировкой.
В русском языковом пакете, например, в файле FAQ написано:
'Рнформация Рѕ phpBB 3'
Перевод: 'Информация о phpBB 3'
Но буква "И" не отображается вообще!
Т.е. вот этот символ - Р не работает.
В русском языковом пакете, например, в файле FAQ написано:
'Рнформация Рѕ phpBB 3'
Перевод: 'Информация о phpBB 3'
Но буква "И" не отображается вообще!
Т.е. вот этот символ - Р не работает.
-
crash
- Former team member
- Сообщения: 6517
- Стаж: 22 года 2 месяца
- Откуда: Бердск
- Поблагодарили: 15 раз
Re: Вышел phpBB 3.0.5 [обсуждаем]
ну так укажите чтобы вебсервер в utf-8 отдавал
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
-
Владислав
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 17 лет 3 месяца
Re: Вышел phpBB 3.0.5 [обсуждаем]
Либо я не понял где именно настраивать, либо ошибка где-то в другом месте.
MySQL-кодировка: UTF-8 Unicode (utf8)
Вы про это?
MySQL-кодировка: UTF-8 Unicode (utf8)
Вы про это?
-
Chianuk
- phpBB 1.4.1
- Сообщения: 46
- Стаж: 18 лет 3 месяца
Re: Вышел phpBB 3.0.5 [обсуждаем]
Странно. У меня phpbb 3 чувствует себя уютно как в базе 1251 так и в UTF-8.
crash, ну так скажите куда ему это прописать.
crash, ну так скажите куда ему это прописать.
-
Ksarien
- phpBB 1.4.0
- Сообщения: 30
- Стаж: 18 лет
Re: Вышел phpBB 3.0.5 [обсуждаем]
у меня форум версии 3.0.4, моды: thanks, QuickReply
решил обновиться.
я поставил с нуля 3.0.5, удалил базу, "скормил" дамп форума версии 3.0.4 и запустил database_update.php
Но вывело что база текущая 3.0.5 и обновления не требуется.
Так и должно быть?
я так понял что структура бд немного изменена по сравнению с версией 3.0.4.
не будет ли потом косяков?!
попробовал запустить - работает (но естественно без модов, т.к. пока их еще не ставил).
зы: а в админке в лог добавились строчки:
Anonymous 127.0.0.1 Сегодня, 21:17 Обновлена база данных с версии 3.0.5 до версии 3.0.5
Anonymous 127.0.0.1 Сегодня, 21:17 Обновлена база данных с версии 3.0.4 до версии 3.0.5
------
повторил все заново - при запуске database_update.php в этот раз все вывело правильно.
наверное в 1ый раз обновил страницу - что и лог показывает.
в общем насколько я понимаю.
осталось доустановить моды(без sql-запросов) и все должно быть ОК?!
решил обновиться.
я поставил с нуля 3.0.5, удалил базу, "скормил" дамп форума версии 3.0.4 и запустил database_update.php
Но вывело что база текущая 3.0.5 и обновления не требуется.
Так и должно быть?
я так понял что структура бд немного изменена по сравнению с версией 3.0.4.
не будет ли потом косяков?!
попробовал запустить - работает (но естественно без модов, т.к. пока их еще не ставил).
зы: а в админке в лог добавились строчки:
Anonymous 127.0.0.1 Сегодня, 21:17 Обновлена база данных с версии 3.0.5 до версии 3.0.5
Anonymous 127.0.0.1 Сегодня, 21:17 Обновлена база данных с версии 3.0.4 до версии 3.0.5
------
повторил все заново - при запуске database_update.php в этот раз все вывело правильно.
наверное в 1ый раз обновил страницу - что и лог показывает.
в общем насколько я понимаю.
осталось доустановить моды(без sql-запросов) и все должно быть ОК?!
Последний раз редактировалось Ksarien 06.06.2009 21:05, всего редактировалось 1 раз.

