Сообщаем об ошибках phpBB 3.0.x разработчикам

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
TolicH
phpBB 1.0.0
Сообщения: 6
Стаж: 17 лет 2 месяца
Поблагодарили: 2 раза

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение TolicH »

http://www.phpbb.com/bugs/phpbb3/ticket ... t_id=48345

UP: Похоже, дядьки считают такое поведение корретным. Или я опять прокололся со своим английским.
Последний раз редактировалось TolicH 22.07.2009 14:59, всего редактировалось 1 раз.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17273
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение rxu »

Про звание написали, а про аватар забыли? :)

Добавлено спустя 3 минуты 29 секунд:
Хотя... думаю, ответ будет аналогичным.

Добавлено спустя 42 секунды:
TolicH писал(а):Похоже, дядьки считают такое поведение корретным.
Именно. "Пустые" звание и аватара не заменяют "непустые".
Изображение
TolicH
phpBB 1.0.0
Сообщения: 6
Стаж: 17 лет 2 месяца
Поблагодарили: 2 раза

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение TolicH »

Гм, ну пусть тогда хотя бы сделают поведение одинаковым из обоих интерфейсов... http://www.phpbb.com/bugs/phpbb3/ticket ... post170715

Конкретно в моем случае, Зарегистрированные пользователи получают звание "Непроверенные" (видят часть форума), потом их переводят в группу "Проверенные" и звание они набивают как обычно, в зависимости от числа постов. Потому поведение с удалением звания мне показалось корректным.
kwas
phpBB 1.0.0
Сообщения: 3
Стаж: 17 лет

Кэш меня обижает

Сообщение kwas »

Кэш реально задрал.
Пока юзер не авторизуется он не видит сравнительно недавних сообщений. Показывается состояние форума вплоть до несколькодневной давности. Только авторизуешься - все ОК.
Может быть это можно как-то настроить?
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение nissin »

А может у хостера стоит такое кэширование?
Несколько раз на агаве натыкался.
kwas
phpBB 1.0.0
Сообщения: 3
Стаж: 17 лет

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение kwas »

Именно такое :o
Я, конечно, многого не знаю, но как может хостинг отличать зарегистрированного юзера от незарегистрированного. Это же на уровне скрипта происходит (регистрация то), так сказать, на более высоком.
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение nissin »

например везде принудительно SID ставить.
kwas
phpBB 1.0.0
Сообщения: 3
Стаж: 17 лет

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение kwas »

Это ты что такое сейчас сказал? Плиз, по-подробнее для особо одаренных.
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение nissin »

На главной всё равно не получится, а на остальных страницах этот фокус скорей всего пройдёт.
Правильней будет хостера призвать к ответу.
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение Shredder »

Версия форума: 3.0.6 RC2. Проверял чистую установку в денвере на локалхосте. Не думаю, что остальная информация будет важна, но на всякий случай:
System Windows NT COMP-395C4EF7B3 5.1 build 2600
Server API Apache 2.0 Handler
MySQL(i) 5.0.45-community-nt
PHP Version 5.2.4

Целая масса багов с капчёй:

1 -
Если поставить "Текстовый вариант", задать вопрос и потом его удалить, не меняя после этого текстового варианта в доступных модулях на какой-либо ещё, то он сохраняется в настройках, а при нажатии на регистрацию вывалятся кракозябры и вот это:

Код: Выделить всё

[phpBB Debug] PHP Notice: in file /includes/captcha/plugins/phpbb_captcha_qa_plugin.php on line 392: array_rand() [function.array-rand]: First argument has to be an array
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4187: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3497)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4189: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3497)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4190: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3497)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4191: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3497)
2 -
Также, если ввести неправильные или не соответствующие домену ключи reCaptcha, то выбор пункта reCaptcha из списка всё равно остаётся возможным. В поле предпросмотра капчи в админке при этом написано: "This reCAPTCHA key isn't authorized for the given domain. More info" или же "Invalid public key. Make sure you copy and pasted it correctly.". Могуть быть, наверное, и другие сообщения - здесь просто примеры для двух вариантов, но итог один: на странице регистрации вместо капчи написано то же самое, а после заполнения всех полей и нажатии кнопки подтверждения регистрации, выдаёт: "Неверный код визуального подтверждения", и, как следствие, зарегистрироваться невозможно.

3 -
Не знаю уж, баг или нет, но смотрится как-то неправильно: в subsilver2 при выборе в качестве капчи текстового вопроса вместо "Подтверждение регистрации" (как в prosilver) в заголовке стоит сам вопрос:

subsilver2
[фото пропало]

prosilver
[фото пропало]
Последний раз редактировалось Shredder 09.03.2022 3:54, всего редактировалось 1 раз.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17273
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение rxu »

Shredder
Спасибо за сообщения, будем разбираться.
Изображение
Chance
phpBB 1.4.2
Сообщения: 70
Стаж: 20 лет 1 месяц
Забанен: Бессрочно

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение Chance »

У меня тоже была ошибка номер 1, вылечилось простым комментированием трех или четырех строк.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17273
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение rxu »

А можно поинтересоваться, с какой целью вы оставляете капчу вопрос-ответ включенной, если вы удалили все вопросы?
И что вы получаете в таком случае после комментирования каких-то строк?
Изображение
Chance
phpBB 1.4.2
Сообщения: 70
Стаж: 20 лет 1 месяц
Забанен: Бессрочно

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение Chance »

rxu, я не удалял вопросы. У меня всего один вопрос-с тремя вариантами ответа (аналог антибот).

У меня выскакивало примерно такое же предупреждение
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4187: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3497)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4189: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3497)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4190: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3497)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4191: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3497)

После комментирования строк, варнинги пропали, все остальное работает.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17273
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение rxu »

Chance писал(а):rxu, я не удалял вопросы.
Не могу повторить на чисто установленном RC2.
Изображение

Вернуться в «Поддержка phpBB 3.0.х»