Перенос базы данных с бесплатного сервиса форумов

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
JackaN
phpBB 1.2.0
Сообщения: 16
Стаж: 16 лет 1 месяц
Откуда: Петрозаводск
Благодарил (а): 4 раза

Перенос базы данных с бесплатного сервиса форумов

Сообщение JackaN »

Добрый день,
уважаемые пользователи,

пожалуйста, помогите с маленькой проблемой в базе данных. В августе создал форум на бесплатном хостинге. Версия phpBB: 3.0.x. Сейчас купил хостинг, установил на новом хостинге phpBB3 последней версии. Осталось загрузить стандартный дамп MYSQL со старого форума на новый. Вот здесь и возникла проблема. Я зашёл в phpMyAdmin --> Импорт, загрузил дамп. Выдаёт следующую ошибку:

Код: Выделить всё

Ошибка

SQL-запрос:

#
# phpBB Backup Script
# Dump of tables for phpbb_
# DATE : 10-10-2010 12:30:59 GMT
#
# Table: phpbb_acl_groups
DROP TABLE IF EXISTS phpbb_acl_groups;

Ответ MySQL: Документация
#1046 - No database selected 
ор.PNG
БД - неизвестная мне зона, хотел бы спросить вас, профессионалов, в чём может быть проблема?
Возможно, дело в разных версиях форумов? Или нужно что-то подправить в самом файле?
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
DK7
Former team member
Сообщения: 1008
Стаж: 20 лет 2 месяца
Откуда: Кишинёв
Благодарил (а): 3 раза
Поблагодарили: 25 раз

Re: Проблема с БД

Сообщение DK7 »

выберите слева сверху, базу данных вашего форума, кликните, справа откроется список таблиц. Над ним вкладка sql
Вот там запрос и выполняйте.
JackaN
phpBB 1.2.0
Сообщения: 16
Стаж: 16 лет 1 месяц
Откуда: Петрозаводск
Благодарил (а): 4 раза

Re: Проблема с БД

Сообщение JackaN »

DK7,
спасибо. Установил, но видимо не до конца. Первые 2 минуты новый форум отлично показывался со старой БД, но потом вылезла общая ошибка.

Код: Выделить всё

Общая ошибка
SQL ERROR [ mysqli ]

Unknown column 'forum_options' in 'where clause' [1054]

SQL

SELECT forum_id FROM phpbb_forums WHERE forum_options & 2 <> 0 LIMIT 1

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()

FILE: includes/db/mysqli.php
LINE: 205
CALL: dbal_mysqli->sql_query()

FILE: includes/db/dbal.php
LINE: 170
CALL: dbal_mysqli->_sql_query_limit()

FILE: includes/functions.php
LINE: 4144
CALL: dbal->sql_query_limit()

FILE: index.php
LINE: 142
CALL: page_header()
Снимок1.PNG
Подскажите, пожалуйста, куда следует пойти и что сделать?
У вас нет необходимых прав для просмотра вложений в этом сообщении.
MAzZY
Бывший член :)
Сообщения: 2925
Стаж: 21 год 4 месяца
Благодарил (а): 79 раз
Поблагодарили: 69 раз
Забанен: Бессрочно

Re: Проблема с БД

Сообщение MAzZY »

DK7, вредные советы же

JackaN, бэкап остался? Или лучше удалите все из базу и установите заново форум. Потом загрузите дамп старого форума, но без таблицы _config
Потом будем дальше смотреть
JackaN
phpBB 1.2.0
Сообщения: 16
Стаж: 16 лет 1 месяц
Откуда: Петрозаводск
Благодарил (а): 4 раза

Re: Проблема с БД

Сообщение JackaN »

Попробую переустановить форум. Пожалуйста, не закрывайте тему, возможно у меня появятся вопросы по БД. Если нет - всё равно отпишусь. Заранее спасибо.
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Проблема с БД

Сообщение Пчелкин »

Не знаю как спецы относятся к переезду.Но сам считаю что переезжать надо по такой схеме..
Есть старый форум, есть новый стандартный установленный...
Варианта два...
1. берем новый форум с пустой БД и тупо накатываем все моды, стоявшие на старом..
затем копируем дамп старого и типа восстанавливаемся...(повотрюсь, все моды должны уже стоять на новом)
2. Берем новый форум и смотрим ВСЕ таблицы БД на новом (модов старых нет)
переписываем все таблицы на бумажечку.
смотрим на БД старого и выбрав только те таблицы, что есть на новом , делаем бекап БД
копирем это дамп на новый и типа восстанавливаемся.

Правильно?
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
MAzZY
Бывший член :)
Сообщения: 2925
Стаж: 21 год 4 месяца
Благодарил (а): 79 раз
Поблагодарили: 69 раз
Забанен: Бессрочно

Re: Проблема с БД

Сообщение MAzZY »

Пчелкин писал(а):Правильно?
Первое сообщение прочтите
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Проблема с БД

Сообщение Пчелкин »

#1046 - No database selected
Что то по стариковски сразу и не заметил..
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Проблема с БД

Сообщение nissin »

JackaN
Версии на новом и старом форуме отличаются, нужно обновить БД под новую версию.
install/database_update.php
JackaN
phpBB 1.2.0
Сообщения: 16
Стаж: 16 лет 1 месяц
Откуда: Петрозаводск
Благодарил (а): 4 раза

Проблема с БД (продолжение)

Сообщение JackaN »

итак, у меня возник следующий вопрос: если восстанавливать только категории, форумы, сообщения, пользователей, какие записи нужно выбрать (см. скриншот):
Снимок.PNG
Проблема в том, что у меня не получается скопировать всю базу данных, так как вся БД содержит информацию о модулях (не знаю я, какие модули были установлены на бывшем бесплатном хостинге ;) ), поэтому придётся минимизировать поставленную задачу - так мне будет легче.

Подскажите, пожалуйста. Заранее спасибо.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: Проблема с БД (продолжение)

Сообщение Shredder »

JackaN
phpBB 1.2.0
Сообщения: 16
Стаж: 16 лет 1 месяц
Откуда: Петрозаводск
Благодарил (а): 4 раза

Re: Проблема с БД (продолжение)

Сообщение JackaN »

всё равно не получается - форум выдаёт общую ошибку
General Error
SQL ERROR [ mysql4 ]

Access denied for user 'gunesdenru_phpb0'@'localhost' (using password: YES) [1045]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: Проблема с БД (продолжение)

Сообщение Shredder »

В файле config.php выставьте нужные данные для подключения к БД.
JackaN
phpBB 1.2.0
Сообщения: 16
Стаж: 16 лет 1 месяц
Откуда: Петрозаводск
Благодарил (а): 4 раза

Re: Проблема с БД (продолжение)

Сообщение JackaN »

Начинка config.php:

Код: Выделить всё

<?php
// phpBB 3.0.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'mysql';
$dbhost = 'localhost';
$dbport = '';
$dbname = 'gunesdenru_phpb0';
$dbuser = 'gunesdenru_phpb0';
$dbpasswd = 'пароль';
$table_prefix = 'phpbb_';
$acm_type = 'file';
$load_extensions = '';

@define('PHPBB_INSTALLED', true);
// @define('DEBUG', true);
// @define('DEBUG_EXTRA', true);
?>
База данных: gunesdenru_phpb0

Вроде всё верно. Или не совсем?
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Проблема с БД (продолжение)

Сообщение Пчелкин »

JackaN писал(а):$dbms = 'mysql';
или все же
$dbms = 'mysqli'; ???

Добавлено спустя 1 минуту 50 секунд:
JackaN писал(а):База данных: gunesdenru_phpb0
А админ БД тоже под этим именем?

Добавлено спустя 2 минуты 4 секунды:
JackaN писал(а):$table_prefix = ' ??? phpbb ??? _';
ваш префикс gunesdenru
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70

Вернуться в «Поддержка phpBB 3.0.х»