Обновление версии phpBB3
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
milkywayfarer
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 15 лет 9 месяцев
- Благодарил (а): 1 раз
Re: Обновление версии phpBB3
При обновлении с версии 3.0.5 до 3.0.8, процесс зависает на стадии "Updating data". Что делать?
-
milkywayfarer
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 15 лет 9 месяцев
- Благодарил (а): 1 раз
Re: Обновление версии phpBB3
Да, это была стадия обновления базы данных. Но проблема уже решилась.
Дело в том, что я переношу форум на новый домен и пробую его там сразу обновить.
Что я сделал:
1) Заново сделал дамп БД на старом домене, но только на этот раз в текстовом формате (без .gz-архивации).
2) Импортнул этот дам на новом домене.
3) Вернулся к update'у, которое, на этот раз успешно прошло этап обновления БД.
4) Уперся в новую проблему: Переадресация при входе в центр администрирования. (то, что "Добавлено спустя 4 минуты 28 секунд:")
Добавлено спустя 22 секунды:
*ошибок не было
Добавлено спустя 1 час 24 минуты 42 секунды:
С переадресацией разобрался (http://www.phpbbguru.net/community/topi ... ml#p302017), новый этап обновления и новая проблема.
Стадия "Check files".
Периодически вываливается "502 Bad Gateway", после первого появления помогает обновление страницы, дальше процесс доходит до проверки 109/317 файлов, опять появляется "502 Bad Gateway" и процесс стопится окончательно (обновления страницы уже не помогают).
Кто виноват и что делать?
Дело в том, что я переношу форум на новый домен и пробую его там сразу обновить.
Что я сделал:
1) Заново сделал дамп БД на старом домене, но только на этот раз в текстовом формате (без .gz-архивации).
2) Импортнул этот дам на новом домене.
3) Вернулся к update'у, которое, на этот раз успешно прошло этап обновления БД.
4) Уперся в новую проблему: Переадресация при входе в центр администрирования. (то, что "Добавлено спустя 4 минуты 28 секунд:")
Добавлено спустя 22 секунды:
*ошибок не было
Добавлено спустя 1 час 24 минуты 42 секунды:
С переадресацией разобрался (http://www.phpbbguru.net/community/topi ... ml#p302017), новый этап обновления и новая проблема.
Стадия "Check files".
Периодически вываливается "502 Bad Gateway", после первого появления помогает обновление страницы, дальше процесс доходит до проверки 109/317 файлов, опять появляется "502 Bad Gateway" и процесс стопится окончательно (обновления страницы уже не помогают).
Кто виноват и что делать?
-
Alek$
- Former team member
- Сообщения: 2616
- Стаж: 21 год 1 месяц
- Откуда: Новосибирск
- Поблагодарили: 37 раз
Re: Обновление версии phpBB3
milkywayfarer
Скорее всего, причина в том, что ваш хостер использует веб-сервер nginx в качестве прокси для apache. Поскольку проверка фалов - операция длительная, то nginx не успевает дождаться ответа от apache и возвращает ошибку.
Вариантов два:
1) Обратиться к хостеру, чтобы тот проверил настройки nginx и возможно увеличил время ожидания ответа.
2) В файле install/install_update.php найти фрагмент:
и попытаться поуменьшать число 500 * 1024 до тех пор, пока ошибка не пропадет.
Скорее всего, причина в том, что ваш хостер использует веб-сервер nginx в качестве прокси для apache. Поскольку проверка фалов - операция длительная, то nginx не успевает дождаться ответа от apache и возвращает ошибку.
Вариантов два:
1) Обратиться к хостеру, чтобы тот проверил настройки nginx и возможно увеличил время ожидания ответа.
2) В файле install/install_update.php найти фрагмент:
Код: Выделить всё
if ($num_bytes_processed >= 500 * 1024)
{
return;
}Самая страшная ошибка, это ошибка без видимых причин и конкретных последствий.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
-
milkywayfarer
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 15 лет 9 месяцев
- Благодарил (а): 1 раз
Re: Обновление версии phpBB3
Alek$, огромное спасибо!
Действительно используется ngnix, действительно проблема таймаута.
После такой правки процесс отработал до конца:
Действительно используется ngnix, действительно проблема таймаута.
После такой правки процесс отработал до конца:
Код: Выделить всё
if ($num_bytes_processed >= 100 * 1024)
{
return;
}
-
Murderer
- phpBB 1.0.0
- Сообщения: 8
- Стаж: 17 лет 6 месяцев
- Благодарил (а): 2 раза
Re: Обновление версии phpBB3
mau писал(а):Код: Выделить всё
Обновление базы данных до последней стабильной версии Тип базы данных :: mysql4 Предыдущая версия :: 3.0.7-PL1 Обновлённая версия :: 3.0.8 Обновление структуры базы данных Ход выполнения :: Обновление не требуется Обновление данных Ход выполнения :: . . . . . . . . . . Fatal error: in C:\AppServ\www\forum\includes\dbdbal.php on line 694
Ещё были у когонить данная проблема не из-за мода Ultimate Points?...mau писал(а):694 строчка
trigger_error(false, E_USER_ERROR);
Проблема была из-за мода Ultimate Points
Перед обновлением надо исправить functions_user.php
и все обновилось :D
выскакивает таже ошибка, что выше(при обновлении на хосте или локалке без разницы)
на форуме установленны следующие моды:
Код: Выделить всё
Advanced Similar Topics
Advertisement Management
Medals System MOD for phpBB3
Sitemap FX
Thanks for posts (AJAX ADD-ON)
UMIL - Unified Mod Install Library
User status mod
phpBB Arcade
Благодарность за сообщения
Модуль Loginza для авторизации через социальные сети и OpenID провайдеров.-
axel13
- phpBB 1.4.4
- Сообщения: 100
- Стаж: 21 год 5 месяцев
- Благодарил (а): 2 раза
- Поблагодарили: 1 раз
Re: Обновление версии phpBB3
Помогите пожалуйста, уже уменьшил до 64*256, но все равно на 136-138 файле получаю белый экран..... В хроме ошибка:и попытаться поуменьшать число 500 * 1024 до тех пор, пока ошибка не пропадет.
Ошибка 324 (net::ERR_EMPTY_RESPONSE): Неизвестная ошибка.
Северо-Западный Клуб владельцев автомобилей Chevrolet Lanos, Daewoo Lanos, ZAZ Sens, Doninvest Assol. -=WWW.LANOS.CC=-
-
Alek$
- Former team member
- Сообщения: 2616
- Стаж: 21 год 1 месяц
- Откуда: Новосибирск
- Поблагодарили: 37 раз
Re: Обновление версии phpBB3
axel13
что в error_log?
что в error_log?
Самая страшная ошибка, это ошибка без видимых причин и конкретных последствий.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
-
axel13
- phpBB 1.4.4
- Сообщения: 100
- Стаж: 21 год 5 месяцев
- Благодарил (а): 2 раза
- Поблагодарили: 1 раз
Re: Обновление версии phpBB3
Alek$
прошу прощения за нубизм, а где его смотреть?
прошу прощения за нубизм, а где его смотреть?
Северо-Западный Клуб владельцев автомобилей Chevrolet Lanos, Daewoo Lanos, ZAZ Sens, Doninvest Assol. -=WWW.LANOS.CC=-
-
Alek$
- Former team member
- Сообщения: 2616
- Стаж: 21 год 1 месяц
- Откуда: Новосибирск
- Поблагодарили: 37 раз
Re: Обновление версии phpBB3
Зависит от софта, используемого вашим хостером. Обычно в панели управления хостингом.
Самая страшная ошибка, это ошибка без видимых причин и конкретных последствий.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
-
axel13
- phpBB 1.4.4
- Сообщения: 100
- Стаж: 21 год 5 месяцев
- Благодарил (а): 2 раза
- Поблагодарили: 1 раз
Re: Обновление версии phpBB3
Код: Выделить всё
www.lanos.cc [Wed Dec 22 13:05:08 2010] [error] [client xxxxxxx] File does not exist: /home/l/lanoscc/public_html/gallery, referer: http://www.lanos.cc/
www.lanos.cc [Wed Dec 22 13:05:08 2010] [error] [client xxxxxxx] File does not exist: /home/l/lanoscc/public_html/mchat, referer: http://www.lanos.cc/
www.lanos.cc [Wed Dec 22 13:05:09 2010] [error] [client xxxxxxx] File does not exist: /home/l/lanoscc/public_html/gallery, referer: http://www.lanos.cc/
www.lanos.cc [Wed Dec 22 13:05:09 2010] [error] [client xxxxxxx] File does not exist: /home/l/lanoscc/public_html/mchat, referer: http://www.lanos.cc/
www.lanos.cc [Wed Dec 22 13:05:09 2010] [error] [client xxxxxxx] File does not exist: /home/l/lanoscc/public_html/mchat, referer: http://www.lanos.cc/
причем форум лежит в /home/l/lanoscc/public_html/forum/
а portal.html (она же index) в /home/l/lanoscc/public_html
Северо-Западный Клуб владельцев автомобилей Chevrolet Lanos, Daewoo Lanos, ZAZ Sens, Doninvest Assol. -=WWW.LANOS.CC=-
-
Alek$
- Former team member
- Сообщения: 2616
- Стаж: 21 год 1 месяц
- Откуда: Новосибирск
- Поблагодарили: 37 раз
Re: Обновление версии phpBB3
axel13
Меня интересуют сообщения, появившиеся примерно во время выдачи пустой страницы.
Меня интересуют сообщения, появившиеся примерно во время выдачи пустой страницы.
Самая страшная ошибка, это ошибка без видимых причин и конкретных последствий.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
-
axel13
- phpBB 1.4.4
- Сообщения: 100
- Стаж: 21 год 5 месяцев
- Благодарил (а): 2 раза
- Поблагодарили: 1 раз
Re: Обновление версии phpBB3
Вот это они и есть - я специально запустил обновление и сразу после ошибки снял лог - время сравнил.
Пакет обновления взят с phpbb-seo.com, т.к. у меня стоит seo-mod. В файлах обновления языковые файлы en скопированы в созданную папку ru, т.к. в пакете обновления от phpbb-seo они отсутствуют.
Пакет обновления взят с phpbb-seo.com, т.к. у меня стоит seo-mod. В файлах обновления языковые файлы en скопированы в созданную папку ru, т.к. в пакете обновления от phpbb-seo они отсутствуют.
Северо-Западный Клуб владельцев автомобилей Chevrolet Lanos, Daewoo Lanos, ZAZ Sens, Doninvest Assol. -=WWW.LANOS.CC=-
-
Alek$
- Former team member
- Сообщения: 2616
- Стаж: 21 год 1 месяц
- Откуда: Новосибирск
- Поблагодарили: 37 раз
Re: Обновление версии phpBB3
Ок, подойдем с другой стороны.
Попробуйте в config.php раскомментировать строки
Попробуйте в config.php раскомментировать строки
Код: Выделить всё
// @define('DEBUG', true);
// @define('DEBUG_EXTRA', true);
Самая страшная ошибка, это ошибка без видимых причин и конкретных последствий.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
-
axel13
- phpBB 1.4.4
- Сообщения: 100
- Стаж: 21 год 5 месяцев
- Благодарил (а): 2 раза
- Поблагодарили: 1 раз
Re: Обновление версии phpBB3
Расскомемнтировал:
при попытке обновления, вводе адреса сайт/форум/инсталл/ получаю
при попытке обновления, вводе адреса сайт/форум/инсталл/ получаю
Код: Выделить всё
[phpBB Debug] PHP Notice: in file /includes/hooks/hook_subject_prefix.php on line 58: Undefined index: page_name
[phpBB Debug] PHP Notice: in file /includes/hooks/hook_subject_prefix.php on line 107: Undefined index: page_nameСеверо-Западный Клуб владельцев автомобилей Chevrolet Lanos, Daewoo Lanos, ZAZ Sens, Doninvest Assol. -=WWW.LANOS.CC=-


