Ошибка 500 после установки форума

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
kapxapot
phpBB 1.0.0
Сообщения: 5
Стаж: 15 лет 6 месяцев

Ошибка 500 после установки форума

Сообщение kapxapot »

Здравствуйте!

Я установил версию форума 3.0.8 (взял с официального сайта), на нее поставил пакет русификации.

После этого в системе зарегистрировался еще один пользователь, которого я сделал администратором.

Больше ничего с системой не было сделано. Сайт выдает ошибку 500 как по адресу форума, так и по адресу админки.

Что делать?
Аватара пользователя
Айдар
Former team member
Сообщения: 1687
Стаж: 15 лет 9 месяцев
Откуда: KZN
Благодарил (а): 93 раза
Поблагодарили: 189 раз

Re: Ошибка 500 после установки форума

Сообщение Айдар »

kapxapot писал(а):Что делать?
В первую очередь смотреть error_log. Здесь телепатов нет.
И, в конце концов, переустановить форум. К хостеру обращались? Первый форум ставите на данном хостинге?
In Web We Trust
kapxapot
phpBB 1.0.0
Сообщения: 5
Стаж: 15 лет 6 месяцев

Re: Ошибка 500 после установки форума

Сообщение kapxapot »

Лог посмотрю, спасибо. И сюда выложу его содержимое. Я же о его существовании не знал.

Какой смысл переустанавливать, если он вот только что установлен? На этом хостинге работает IPB, с хостингом точно проблем нет. Опять же, прошу обратить внимание, что после установки форум работал без проблем. Все отображалось без ошибок, админка работала и т.п.
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: Ошибка 500 после установки форума

Сообщение Shredder »

Кеш через ftp попробуйте очистить. Удалить все файлы в папке cache, кроме .htaccess и index.htm
kapxapot
phpBB 1.0.0
Сообщения: 5
Стаж: 15 лет 6 месяцев

Re: Ошибка 500 после установки форума

Сообщение kapxapot »

Shredder, спасибо, попробую.

Айдар, файл лога не нашел. Можете сказать точное его местоположение?
Аватара пользователя
Айдар
Former team member
Сообщения: 1687
Стаж: 15 лет 9 месяцев
Откуда: KZN
Благодарил (а): 93 раза
Поблагодарили: 189 раз

Re: Ошибка 500 после установки форума

Сообщение Айдар »

kapxapot, кто хостер?
In Web We Trust
kapxapot
phpBB 1.0.0
Сообщения: 5
Стаж: 15 лет 6 месяцев

Re: Ошибка 500 после установки форума

Сообщение kapxapot »

Хостинг Masterhost.

Удаление кэша ничем не помогло. Заново он не создается, кстати.
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: Ошибка 500 после установки форума

Сообщение Shredder »

Ну так вы лог-то выложите... Иначе как же мы вам поможем?

Или попробуйте к хостеру обратиться - может, они что-то там нахимичили.
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Ошибка 500 после установки форума

Сообщение nissin »

kapxapot писал(а):Айдар, файл лога не нашел. Можете сказать точное его местоположение?
У Мастерхоста он в панели управления включается и там же просматривается.
Аватара пользователя
Айдар
Former team member
Сообщения: 1687
Стаж: 15 лет 9 месяцев
Откуда: KZN
Благодарил (а): 93 раза
Поблагодарили: 189 раз

Re: Ошибка 500 после установки форума

Сообщение Айдар »

Несмотря на всю бедность мастерхостовского лога ошибок, 500-ую он, как правило, показывает всегда.
Переходите "Древо услуг" - Ваш домен - error_log (третья строка открывшейся таблицы).
In Web We Trust
kapxapot
phpBB 1.0.0
Сообщения: 5
Стаж: 15 лет 6 месяцев

Re: Ошибка 500 после установки форума

Сообщение kapxapot »

Спасибо за помощь! Дело было в правах доступа к файлу config.php в корне форума. Следуя инструкции я выставил для него права 640, но заработало только при 644.
Аватара пользователя
Айдар
Former team member
Сообщения: 1687
Стаж: 15 лет 9 месяцев
Откуда: KZN
Благодарил (а): 93 раза
Поблагодарили: 189 раз

Re: Ошибка 500 после установки форума

Сообщение Айдар »

Хм... впервые слышу о 640! chmod 644 более чем достаточен.
In Web We Trust
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Ошибка 500 после установки форума

Сообщение nissin »

640 более ограниченные права.
А вообще подобная ситуация уже не первый раз у новичков встречается.
Аватара пользователя
Айдар
Former team member
Сообщения: 1687
Стаж: 15 лет 9 месяцев
Откуда: KZN
Благодарил (а): 93 раза
Поблагодарили: 189 раз

Re: Ошибка 500 после установки форума

Сообщение Айдар »

nissin, я в том смысле, что впервые слышу о требовании движка phpbb установить такие права.
In Web We Trust
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Ошибка 500 после установки форума

Сообщение nissin »

language/ru/acp/common.php

Код: Выделить всё

	'WRITABLE_CONFIG'		=> 'Файл <samp>config.php</samp> в настоящее время доступен для записи. Настоятельно рекомендуется изменить право доступа к этому файлу на 640 или по крайней мере на 644 (например: <a href="http://ru.wikipedia.org/wiki/Chmod" rel="external">chmod</a> 640 config.php).',
640 с точки зрения безопасности лучше, но когда php работает как модуль апача и запускается от пользователя apache, он просто не имеет доступ к файлу.

Вернуться в «Поддержка phpBB 3.0.х»