Ошибка 500 после установки форума
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
kapxapot
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 15 лет 6 месяцев
Ошибка 500 после установки форума
Здравствуйте!
Я установил версию форума 3.0.8 (взял с официального сайта), на нее поставил пакет русификации.
После этого в системе зарегистрировался еще один пользователь, которого я сделал администратором.
Больше ничего с системой не было сделано. Сайт выдает ошибку 500 как по адресу форума, так и по адресу админки.
Что делать?
Я установил версию форума 3.0.8 (взял с официального сайта), на нее поставил пакет русификации.
После этого в системе зарегистрировался еще один пользователь, которого я сделал администратором.
Больше ничего с системой не было сделано. Сайт выдает ошибку 500 как по адресу форума, так и по адресу админки.
Что делать?
-
Айдар
- Former team member
- Сообщения: 1687
- Стаж: 15 лет 9 месяцев
- Откуда: KZN
- Благодарил (а): 93 раза
- Поблагодарили: 189 раз
Re: Ошибка 500 после установки форума
В первую очередь смотреть error_log. Здесь телепатов нет.kapxapot писал(а):Что делать?
И, в конце концов, переустановить форум. К хостеру обращались? Первый форум ставите на данном хостинге?
In Web We Trust
-
kapxapot
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 15 лет 6 месяцев
Re: Ошибка 500 после установки форума
Лог посмотрю, спасибо. И сюда выложу его содержимое. Я же о его существовании не знал.
Какой смысл переустанавливать, если он вот только что установлен? На этом хостинге работает IPB, с хостингом точно проблем нет. Опять же, прошу обратить внимание, что после установки форум работал без проблем. Все отображалось без ошибок, админка работала и т.п.
Какой смысл переустанавливать, если он вот только что установлен? На этом хостинге работает IPB, с хостингом точно проблем нет. Опять же, прошу обратить внимание, что после установки форум работал без проблем. Все отображалось без ошибок, админка работала и т.п.
-
Shredder
- Former team member
- Сообщения: 2266
- Стаж: 17 лет 9 месяцев
- Благодарил (а): 283 раза
- Поблагодарили: 584 раза
Re: Ошибка 500 после установки форума
Кеш через ftp попробуйте очистить. Удалить все файлы в папке cache, кроме .htaccess и index.htm
-
kapxapot
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 15 лет 6 месяцев
Re: Ошибка 500 после установки форума
Shredder, спасибо, попробую.
Айдар, файл лога не нашел. Можете сказать точное его местоположение?
Айдар, файл лога не нашел. Можете сказать точное его местоположение?
-
kapxapot
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 15 лет 6 месяцев
Re: Ошибка 500 после установки форума
Хостинг Masterhost.
Удаление кэша ничем не помогло. Заново он не создается, кстати.
Удаление кэша ничем не помогло. Заново он не создается, кстати.
-
Shredder
- Former team member
- Сообщения: 2266
- Стаж: 17 лет 9 месяцев
- Благодарил (а): 283 раза
- Поблагодарили: 584 раза
Re: Ошибка 500 после установки форума
Ну так вы лог-то выложите... Иначе как же мы вам поможем?
Или попробуйте к хостеру обратиться - может, они что-то там нахимичили.
Или попробуйте к хостеру обратиться - может, они что-то там нахимичили.
-
nissin
- phpBB 3.0.4
- Сообщения: 2229
- Стаж: 18 лет 9 месяцев
- Откуда: Астана
- Благодарил (а): 7 раз
- Поблагодарили: 344 раза
Re: Ошибка 500 после установки форума
У Мастерхоста он в панели управления включается и там же просматривается.kapxapot писал(а):Айдар, файл лога не нашел. Можете сказать точное его местоположение?
-
Айдар
- Former team member
- Сообщения: 1687
- Стаж: 15 лет 9 месяцев
- Откуда: KZN
- Благодарил (а): 93 раза
- Поблагодарили: 189 раз
Re: Ошибка 500 после установки форума
Несмотря на всю бедность мастерхостовского лога ошибок, 500-ую он, как правило, показывает всегда.
Переходите "Древо услуг" - Ваш домен - error_log (третья строка открывшейся таблицы).
Переходите "Древо услуг" - Ваш домен - error_log (третья строка открывшейся таблицы).
In Web We Trust
-
kapxapot
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 15 лет 6 месяцев
Re: Ошибка 500 после установки форума
Спасибо за помощь! Дело было в правах доступа к файлу config.php в корне форума. Следуя инструкции я выставил для него права 640, но заработало только при 644.
-
Айдар
- Former team member
- Сообщения: 1687
- Стаж: 15 лет 9 месяцев
- Откуда: KZN
- Благодарил (а): 93 раза
- Поблагодарили: 189 раз
Re: Ошибка 500 после установки форума
Хм... впервые слышу о 640! chmod 644 более чем достаточен.
In Web We Trust
-
nissin
- phpBB 3.0.4
- Сообщения: 2229
- Стаж: 18 лет 9 месяцев
- Откуда: Астана
- Благодарил (а): 7 раз
- Поблагодарили: 344 раза
Re: Ошибка 500 после установки форума
640 более ограниченные права.
А вообще подобная ситуация уже не первый раз у новичков встречается.
А вообще подобная ситуация уже не первый раз у новичков встречается.
-
Айдар
- Former team member
- Сообщения: 1687
- Стаж: 15 лет 9 месяцев
- Откуда: KZN
- Благодарил (а): 93 раза
- Поблагодарили: 189 раз
Re: Ошибка 500 после установки форума
nissin, я в том смысле, что впервые слышу о требовании движка phpbb установить такие права.
In Web We Trust
-
nissin
- phpBB 3.0.4
- Сообщения: 2229
- Стаж: 18 лет 9 месяцев
- Откуда: Астана
- Благодарил (а): 7 раз
- Поблагодарили: 344 раза
Re: Ошибка 500 после установки форума
language/ru/acp/common.php
640 с точки зрения безопасности лучше, но когда php работает как модуль апача и запускается от пользователя apache, он просто не имеет доступ к файлу.
Код: Выделить всё
'WRITABLE_CONFIG' => 'Файл <samp>config.php</samp> в настоящее время доступен для записи. Настоятельно рекомендуется изменить право доступа к этому файлу на 640 или по крайней мере на 644 (например: <a href="http://ru.wikipedia.org/wiki/Chmod" rel="external">chmod</a> 640 config.php).',
