Интеграция Joomla -> phpBB
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
Vostok-All
- phpBB 1.0.0
- Сообщения: 6
- Стаж: 15 лет 5 месяцев
Re: Интеграция Joomla -> phpBB
Походил по форуму, нигде не нашёл ответа.
Прикрепил phpBB к Joomla через RokBridge/
Теперь ситуация такая: при регистрации в Joomla пользователь входит на форум и попадает сразу как зарегистрированный с тем же логином и паролем. В последствии он может войти с этим логином и паролем на форум без захода на Joomla.
Но вот если пользователь регистрируется в форуме (phpBB), его логин и пароль хоть и попадают в Community Builder, но войти на Joomla не представляется возможным.
Связывал phpBB к Joomla уже давно, не могу ни вспомнить как делал, ни найти информации по данному вопросу. Помогите, если не сложно!
Прикрепил phpBB к Joomla через RokBridge/
Теперь ситуация такая: при регистрации в Joomla пользователь входит на форум и попадает сразу как зарегистрированный с тем же логином и паролем. В последствии он может войти с этим логином и паролем на форум без захода на Joomla.
Но вот если пользователь регистрируется в форуме (phpBB), его логин и пароль хоть и попадают в Community Builder, но войти на Joomla не представляется возможным.
Связывал phpBB к Joomla уже давно, не могу ни вспомнить как делал, ни найти информации по данному вопросу. Помогите, если не сложно!
-
Garret_Dark
- phpBB 2.0.16
- Сообщения: 1097
- Стаж: 17 лет 8 месяцев
- Откуда: root/world/russia/
- Благодарил (а): 126 раз
- Поблагодарили: 206 раз
Re: Интеграция Joomla -> phpBB
Всем доброго времени!
Есть сайт на joomla 1.5 с мостом rockbridge RC14 - phpbb 3.0.9.
Форум установлен в папку distribution, мост в forum, все по дефолтовой инструкции в общем.
Все вроде работает нормально кроме форм, тоесть не работает поиск (При нажатии кнопки "Поиск" попадаем на список форумов), не работают модераторские функции (При выборе, например "Перенести тему", выдает ошибку Не указан режим), в форме action указан такого вида:
Если же зайти не по http://site.ru/forum/ а по http://site.ru/distribution/ то формы работают нормально и никаких проблем.
Ребят, что может быть а?
Заранее всем спасибо.
Есть сайт на joomla 1.5 с мостом rockbridge RC14 - phpbb 3.0.9.
Форум установлен в папку distribution, мост в forum, все по дефолтовой инструкции в общем.
Все вроде работает нормально кроме форм, тоесть не работает поиск (При нажатии кнопки "Поиск" попадаем на список форумов), не работают модераторские функции (При выборе, например "Перенести тему", выдает ошибку Не указан режим), в форме action указан такого вида:
Код: Выделить всё
http://site.ru/forum/index.php?f=109&t=266&quickmod=1&redirect=http://site.ru/forum/index.php?f=109&t=266&rb_v=viewtopic&sid=075defcd6e9228322e44fc5a996fc339&rb_v=mcpРебят, что может быть а?
Заранее всем спасибо.
Мои моды:
Полноценный интернет-магазин для phpbb3
Белый список IP для пользователей индивидуально
Парсер сообщений (автозамена)
User FAQ (Пользовательский FAQ)
Google Map MOD 0.4.2 [RUS]
Anti Double IP - Запрет множественных рег с одного IP
PM All in 1 - ЛС "Все включено"
Шкала последней активности пользователя
Поддержка только в указанных темах! В ЛС только по личным вопросам или за WM.
Полноценный интернет-магазин для phpbb3
Белый список IP для пользователей индивидуально
Парсер сообщений (автозамена)
User FAQ (Пользовательский FAQ)
Google Map MOD 0.4.2 [RUS]
Anti Double IP - Запрет множественных рег с одного IP
PM All in 1 - ЛС "Все включено"
Шкала последней активности пользователя
Поддержка только в указанных темах! В ЛС только по личным вопросам или за WM.
-
владимир1983
- phpBB 3.2.6
- Сообщения: 5954
- Стаж: 16 лет 4 месяца
- Откуда: Сергиев Посад
- Благодарил (а): 373 раза
- Поблагодарили: 727 раз
Re: Интеграция Joomla -> phpBB
Garret_Dark, не пробовал jFusion?
С указанным тобой мостом тоже было много проблем.
С указанным тобой мостом тоже было много проблем.
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
Нет человека - нет проблемы. (c)
-
Garret_Dark
- phpBB 2.0.16
- Сообщения: 1097
- Стаж: 17 лет 8 месяцев
- Откуда: root/world/russia/
- Благодарил (а): 126 раз
- Поблагодарили: 206 раз
Re: Интеграция Joomla -> phpBB
владимир1983, да уже этот стоит, не хочется заморачиваться тем более что про jFusion тоже по форумам не всегда лестно отзываются.
А указанная проблема возникала у некоторых (Даже в этой теме кто-то отписывался выше), но решения в сети я так и не нашел, хотя должно же быть...
При том в начале все работало нормально и я понять не могу после чего слетело и почему....
А указанная проблема возникала у некоторых (Даже в этой теме кто-то отписывался выше), но решения в сети я так и не нашел, хотя должно же быть...
При том в начале все работало нормально и я понять не могу после чего слетело и почему....
Мои моды:
Полноценный интернет-магазин для phpbb3
Белый список IP для пользователей индивидуально
Парсер сообщений (автозамена)
User FAQ (Пользовательский FAQ)
Google Map MOD 0.4.2 [RUS]
Anti Double IP - Запрет множественных рег с одного IP
PM All in 1 - ЛС "Все включено"
Шкала последней активности пользователя
Поддержка только в указанных темах! В ЛС только по личным вопросам или за WM.
Полноценный интернет-магазин для phpbb3
Белый список IP для пользователей индивидуально
Парсер сообщений (автозамена)
User FAQ (Пользовательский FAQ)
Google Map MOD 0.4.2 [RUS]
Anti Double IP - Запрет множественных рег с одного IP
PM All in 1 - ЛС "Все включено"
Шкала последней активности пользователя
Поддержка только в указанных темах! В ЛС только по личным вопросам или за WM.
-
владимир1983
- phpBB 3.2.6
- Сообщения: 5954
- Стаж: 16 лет 4 месяца
- Откуда: Сергиев Посад
- Благодарил (а): 373 раза
- Поблагодарили: 727 раз
Re: Интеграция Joomla -> phpBB
Попробуй переустановить мост.
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
Нет человека - нет проблемы. (c)
-
bav55
- phpBB 1.0.0
- Сообщения: 6
- Стаж: 15 лет 5 месяцев
- Откуда: Омск, Россия
Перестал работать вход на форум. jtablesession::Store Failed
Здравствуйте.
Поиском пользовался, аналогичной проблемы ни у кого не нашел.
Прошу помочь вот в каком вопросе:
1. Имеется настроенная конференция phpbb и сайт на joomla 1.5.22; Соединены между собой JFusion в режиме "Форум - мастер, сайт - слейв". Все больше месяца работало прекрасно.
2. Не заходил несколько дней на конференцию и вот проблема:
Пытаемся войти на конференцию.
Если имя или пароль неправильные - корректно отрабатывает и пишет, что данные введены неверно.
в случае, если пароль введен верный, появляется ошибка:
[phpBB Debug] PHP Notice: in file /h/*****/htdocs/libraries/joomla/database/database/mysql.php on line 193: mysql_real_escape_string(): 65 is not a valid MySQL-Link resource
такая строка дублируется 7 раз, затем идут еще две строки:
jtablesession::Store Failed
DB function reports no errors
Ладно бы писала какую-то причину, по которой сессия не может быть сохранена, а то ведь "no errors"
Я не очень хорошо разбираюсь в php, вот несколько моих попыток разобраться в ситуации:
1. Если сделать вход на сайте, а потом открыть страницу форума, то phpbb подхватывает куку, которую положил сайт и показывает, будто пользователь зашел. Выйти дает. Все корректно, без проблем. Но если пытаешься зайти именно на форум - вышеозначенная ошибка.
2. Проверял в базе данных: запись в таблице phpbb_sessions создается при попытке войти на форум с форума, но ошибка все равно остается.
3. Насколько я понимаю PHP_DEBUG у меня отключен (закомментарен в config.php форума) почему же у меня выходят сообщения вида
[phpBB Debug] PHP Notice...
4. Почему ошибка возникает в файле Jooml-ы? Я сначала подумал, что проблема именно в JFusion (мосте). Пробовал отключить мост, ошибка остается.
Описание проблемы: Перестал работать вход на форум. Ошибка jtablesession::Store Failed DB function reports no errors
Произведенные изменения, после которых начались неполадки: Никаких изменений не производилось. Несколько дней не заходил на форум - и вдруг проблемы.
Версия phpBB: 3.0.8
Используемые стили: serenity
Используемые моды:
Версия PHP: PHP Version 5.2.6-1+lenny13
Используемая СУБД и её версия: mysql 5.0.51a
Ссылка на конференцию: http://universology.info/forums
Есть ли у вас тестовый аккаунт: тестового логина нет
Использовался ли поиск для решения проблемы: да
Если да, то какие запросы вы использовали:
Поиском пользовался, аналогичной проблемы ни у кого не нашел.
Прошу помочь вот в каком вопросе:
1. Имеется настроенная конференция phpbb и сайт на joomla 1.5.22; Соединены между собой JFusion в режиме "Форум - мастер, сайт - слейв". Все больше месяца работало прекрасно.
2. Не заходил несколько дней на конференцию и вот проблема:
Пытаемся войти на конференцию.
Если имя или пароль неправильные - корректно отрабатывает и пишет, что данные введены неверно.
в случае, если пароль введен верный, появляется ошибка:
[phpBB Debug] PHP Notice: in file /h/*****/htdocs/libraries/joomla/database/database/mysql.php on line 193: mysql_real_escape_string(): 65 is not a valid MySQL-Link resource
такая строка дублируется 7 раз, затем идут еще две строки:
jtablesession::Store Failed
DB function reports no errors
Ладно бы писала какую-то причину, по которой сессия не может быть сохранена, а то ведь "no errors"
Я не очень хорошо разбираюсь в php, вот несколько моих попыток разобраться в ситуации:
1. Если сделать вход на сайте, а потом открыть страницу форума, то phpbb подхватывает куку, которую положил сайт и показывает, будто пользователь зашел. Выйти дает. Все корректно, без проблем. Но если пытаешься зайти именно на форум - вышеозначенная ошибка.
2. Проверял в базе данных: запись в таблице phpbb_sessions создается при попытке войти на форум с форума, но ошибка все равно остается.
3. Насколько я понимаю PHP_DEBUG у меня отключен (закомментарен в config.php форума) почему же у меня выходят сообщения вида
[phpBB Debug] PHP Notice...
4. Почему ошибка возникает в файле Jooml-ы? Я сначала подумал, что проблема именно в JFusion (мосте). Пробовал отключить мост, ошибка остается.
Описание проблемы: Перестал работать вход на форум. Ошибка jtablesession::Store Failed DB function reports no errors
Произведенные изменения, после которых начались неполадки: Никаких изменений не производилось. Несколько дней не заходил на форум - и вдруг проблемы.
Версия phpBB: 3.0.8
Используемые стили: serenity
Используемые моды:
Версия PHP: PHP Version 5.2.6-1+lenny13
Используемая СУБД и её версия: mysql 5.0.51a
Ссылка на конференцию: http://universology.info/forums
Есть ли у вас тестовый аккаунт: тестового логина нет
Использовался ли поиск для решения проблемы: да
Если да, то какие запросы вы использовали:
-
владимир1983
- phpBB 3.2.6
- Сообщения: 5954
- Стаж: 16 лет 4 месяца
- Откуда: Сергиев Посад
- Благодарил (а): 373 раза
- Поблагодарили: 727 раз
Re: Перестал работать вход на форум. jtablesession::Store Fa
Почините таблицу jos_session
Добавлено спустя 1 минуту 30 секунд:
[FAQ] Пример ремонта (починки) таблицы
Добавлено спустя 1 минуту 30 секунд:
[FAQ] Пример ремонта (починки) таблицы
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
Нет человека - нет проблемы. (c)
-
bav55
- phpBB 1.0.0
- Сообщения: 6
- Стаж: 15 лет 5 месяцев
- Откуда: Омск, Россия
Re: Интеграция Joomla -> phpBB
Владимир, спасибо за совет. Попробовал починить указанную таблицу. Проблема к сожалению осталась.
Затем, попробовал починить все таблицы phpbb - тот же результат :-(
С уважением, Андрей.
Затем, попробовал починить все таблицы phpbb - тот же результат :-(
С уважением, Андрей.
-
владимир1983
- phpBB 3.2.6
- Сообщения: 5954
- Стаж: 16 лет 4 месяца
- Откуда: Сергиев Посад
- Благодарил (а): 373 раза
- Поблагодарили: 727 раз
Re: Интеграция Joomla -> phpBB
Таблица Joomlaвладимир1983 писал(а):jos_session
Где
jos префикс по умолчанию, и у тебя он может отличаться.Расскажи что и как делал.
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
Нет человека - нет проблемы. (c)
-
Raido_pvp
- phpBB 1.0.0
- Сообщения: 2
- Стаж: 14 лет 11 месяцев
Re: Интеграция Joomla -> phpBB
Доброго всем времени суток! Прошу помощи в силу своей неопытности
имею сайт на Joomla -site, с установленным форумом -site/forum/ и мост Jfusion все установлено с нуля, пробовал и на хосте, и на локалке на денвере
Версия Joomla 1.7.1 phpBB3 3.0.9ru JFusion 1.6.0.RC1
настройки для всего этого добра делал от сюда http://joomlaforum.ru/index.php?PHPSESS ... 52046.1410
но видимо потому что там были ранние версии чем у меня, есть проблема- логинюсь через сайт, перехожу на форум автоматом под собой т.е. все ок. а когда пытаюсь зайти через форум, (да и логаут тоже) то встречаю белый экран, в адресной строке site/forum/ucp.php?mode=login и всё.. сделал множествопопыток сделать редирект насильно например на любую другую страничку, ничего не помогает. а так все нормально работает. надеюсь доступно описал трабл
Собссно что я делаю не так, где, ну и чтоб не напороться на ответ про телепатов =), что еще мне надо добавить тут для более детальной информации. спасибо
имею сайт на Joomla -site, с установленным форумом -site/forum/ и мост Jfusion все установлено с нуля, пробовал и на хосте, и на локалке на денвере
Версия Joomla 1.7.1 phpBB3 3.0.9ru JFusion 1.6.0.RC1
настройки для всего этого добра делал от сюда http://joomlaforum.ru/index.php?PHPSESS ... 52046.1410
но видимо потому что там были ранние версии чем у меня, есть проблема- логинюсь через сайт, перехожу на форум автоматом под собой т.е. все ок. а когда пытаюсь зайти через форум, (да и логаут тоже) то встречаю белый экран, в адресной строке site/forum/ucp.php?mode=login и всё.. сделал множество
Собссно что я делаю не так, где, ну и чтоб не напороться на ответ про телепатов =), что еще мне надо добавить тут для более детальной информации. спасибо
-
MAzZY
- Бывший член :)
- Сообщения: 2925
- Стаж: 21 год 4 месяца
- Благодарил (а): 79 раз
- Поблагодарили: 69 раз
- Забанен: Бессрочно
Re: Интеграция Joomla -> phpBB
Убедитесь, что эта версия работает с Джумлой 1.7.хRaido_pvp писал(а):JFusion 1.6.0.RC1
Установите стабильную версию, а не RC
-
bav55
- phpBB 1.0.0
- Сообщения: 6
- Стаж: 15 лет 5 месяцев
- Откуда: Омск, Россия
Re: Интеграция Joomla -> phpBB
2 владимир1983: к сожалению, починка всех таблиц джумлы тоже не помогла
даже не могу понять на что грешить:
1. Может попробовать переустановить форум?
2. Может и базу полностью пересоздать?
3. Может провайдер какой-то софт обновил и начались конфликты?
4. Может кто-то форум взломать пытался?
Что на ваш взгляд более реально?
1. Может попробовать переустановить форум?
2. Может и базу полностью пересоздать?
3. Может провайдер какой-то софт обновил и начались конфликты?
4. Может кто-то форум взломать пытался?
Что на ваш взгляд более реально?
-
Raido_pvp
- phpBB 1.0.0
- Сообщения: 2
- Стаж: 14 лет 11 месяцев
Re: Интеграция Joomla -> phpBB
1.5.6 версия вообще не хочет работать, сразу выдает ошибки в процессе установки, далее вообще фатал. я так полагаю я один с такой неизвестной траблой =( буду ковырять дальше. если получится отпишусь
-
bav55
- phpBB 1.0.0
- Сообщения: 6
- Стаж: 15 лет 5 месяцев
- Откуда: Омск, Россия
Re: Интеграция Joomla -> phpBB
Добрый день!bav55 писал(а):2 владимир1983: к сожалению, починка всех таблиц джумлы тоже не помогла![]()
Дополнительно попытался сделать следующее:
1. Обновил JFusion до 1.5.6.000
2. Обновил phpBB до 3.0.9
Проблема осталась.
Появился тестовый аакаунт для входа на конференцию: login: test пароль: testtest
Страница конференции http://universology.info/forums
Войдя под пользователем test можно увидеть ошибку, которая происходит при входе...
Буду очень признателен за помощь.
С уважением, Андрей.
PS прикладываю скриншоты ошибки и экранов Login Checker от JFusion.
На этих скриншотах меня смущает то, что при тестировании logout, phpbb не удаляет куку.
Ну и при тесте входа какая-то из кук не создается.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
-
bav55
- phpBB 1.0.0
- Сообщения: 6
- Стаж: 15 лет 5 месяцев
- Откуда: Омск, Россия
Re: Интеграция Joomla -> phpBB
Дело не в PHPBB.
Отключив Auth... Mod в плагине JFusion форум стал работать нормально. Включил опять - проблема.
Таким образом, виноват JFusion.
Я почитал на их форуме, но готовых ответов не нашел.
Кому интересно, этот вопрос я задал там:
http://www.jfusion.org/forums/viewtopic ... 499&start=
Отключив Auth... Mod в плагине JFusion форум стал работать нормально. Включил опять - проблема.
Таким образом, виноват JFusion.
Я почитал на их форуме, но готовых ответов не нашел.
Кому интересно, этот вопрос я задал там:
http://www.jfusion.org/forums/viewtopic ... 499&start=

