Fatal error в настройках администратора

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
ksen
phpBB 1.4.0
Сообщения: 36
Стаж: 16 лет
Благодарил (а): 4 раза

Re: Fatal error в настройках администратора

Сообщение ksen »

ksen писал(а):Я ..почему-то вижу пустоту - белый "лист" без единой строчки :(
... у меня этот файл почему-то оказался 0 КБ :(
...Может снести на фиг оба новых форума и залить по новой?
Sheer писал(а): С этим все понятно, Он работает. Вопросов нет.
oops.
у меня было 2 форума пхпбб2.
один из них с Вашей помощью заработал, от второго ПХПББ2 у меня есть только БД, которую Вы мне (если я Вас правильно поняла) посоветовали прицепить к клону работающего ПХПББ2 форума.

Добавлено спустя 2 минуты 11 секунд:
Sheer писал(а):Какого шага? Вам удалось подключиться к новой базе на этапе УСТАНОВКА-->Настройки базы данных
Да. Форумы-3 у меня подключаются как с старой, так и к новой базе. Потом я ввожу настройки администратора и получаю свою Fatal error :(
Последний раз редактировалось ksen 26.11.2011 18:57, всего редактировалось 1 раз.
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Fatal error в настройках администратора

Сообщение Sheer »

Послушайте... Чего вы хотите... Иметь один форум, работающий, но на тройке, или два?
Разберитесь сначала с одним, который работает. Сконвертируйте его в тройку, потом ломайте голову со вторым.
И вы не ответили на вопрос. Вы не написали мне в ЛС (я вам предлагал сообщить параметры подключения к базе) или пришлите мне config.php от работающего форума.

Добавлено спустя 39 секунд:
ksen писал(а):Форумы-3 у меня подключаются как с старой, так и к новой базе
Не понял....
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
ksen
phpBB 1.4.0
Сообщения: 36
Стаж: 16 лет
Благодарил (а): 4 раза

Re: Fatal error в настройках администратора

Сообщение ksen »

Sheer писал(а):или пришлите мне config.php от работающего форума.
В своем уме, такие вещи выкладывать. Удалил

Добавлено спустя 2 минуты 23 секунды:
Sheer писал(а): ksen писал(а):Форумы-3 у меня подключаются как с старой, так и к новой базе
Не понял....
Ну... я первый шаг (подключение к БД), успешно проходила с самого начала.
Сейчас сделала новую базу host700186_1 и попыталась еще раз установить http://jdhforum.jungdoohong.ru/ . Он прекрасно к ней подключился и как всегда выдал ошибку на следующем шаге.

Добавлено спустя 2 минуты 9 секунд:
Sheer писал(а):Послушайте... Чего вы хотите... Иметь один форум, работающий, но на тройке, или два?
Иметь 2 работающих на тройке форума со старыми данными :)
Sheer писал(а):Разберитесь сначала с одним, который работает.
Хорошо, давайте так! )
Последний раз редактировалось Sheer 26.11.2011 20:25, всего редактировалось 1 раз.
Причина: Удален код config.php
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Fatal error в настройках администратора

Сообщение Sheer »

Попросите хостера правильно настроить параметр open_basedir в файле php.ini или же создайте папку myforum в корне сайта, залейте туда файлы из дистрибутива phpBB3 и попытайтесь провести установку.
Зачем вы создаете себе головную боль с субдоменами?
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Fatal error в настройках администратора

Сообщение Пчелкин »

Я тоже про субдомены пытался судачить..как в воду...Так и не понял мысль всех действий...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
ksen
phpBB 1.4.0
Сообщения: 36
Стаж: 16 лет
Благодарил (а): 4 раза

Re: Fatal error в настройках администратора

Сообщение ksen »

Ответ хостера:
Проблема не в этом. Как видно из страницы
инсталляции jdhforum.jungdoohong.ru/install, все требования установщика соблюдены.

Устанавливайте каждый новый форум в свою базу данных.

Если Fatal error: Class 'utf_normalizer' останется, нужно перезаписать контент заново
Я последовала его совету и-таки установила тройку на http://jdhforum.jungdoohong.ru/
Сейчас пытаюсь разобраться с конвертированием.

Добавлено спустя 1 час 25 минут 33 секунды:
Sheer писал(а):Только в config.php прописать другие параметры подключения к БД.
Добавлено спустя 2 минуты 29 секунд:

Код: Выделить всё

<?php
// phpBB 2.x auto-generated config file
// Do not change anything in this file!
$dbms = 'Версия mysql';
$dbhost = 'имя сервера БД';
$dbname = 'имя БД';
$dbuser = 'Имя пользователя БД';
$dbpasswd = 'Пароль к БД';
$table_prefix = 'префикс таблиц БД';
define('PHPBB_INSTALLED', true);
?>
Все вроде поменяла, но результат, увы, не ахти:
phpBB : Critical Error
Could not query config information
DEBUG MODE
SQL Error : 1146 Table 'host700186_1.nar8_config' doesn't exist
SELECT * FROM nar8_config
Line : 215
File : common.php
Собственно: : http://clon.jungdoohong.ru/
(базы и префиксы разные ВЕЗДЕ!)
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Fatal error в настройках администратора

Сообщение Sheer »

Look! Послушайте, давайте отделим мух от котлет.
По правилам конференции phpbbgugru - один вопрос - одна тема.
Установка тройки отдельно, реанимация двойки отдельно, а то я уже начинаю путаться в ваших действиях.
Вторая часть вашего последнего сообщения
ksen писал(а):Сейчас пытаюсь разобраться с конвертированием
Не имеет отношения к этой теме.
Третья
ksen писал(а):Все вроде поменяла, но результат, увы, не ахти:
Тем более. К слову двойка не поддерживается. Но в качестве исключения, скажу
SQL Error : 1146 Table 'host700186_1.nar8_config' doesn't exist
Вы по-английски понимаете, или вам перевести, что означает Table doesn't exist
Нет такой таблицы в базе.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
ksen
phpBB 1.4.0
Сообщения: 36
Стаж: 16 лет
Благодарил (а): 4 раза

Re: Fatal error в настройках администратора

Сообщение ksen »

Sheer писал(а):Look! Послушайте, давайте отделим мух от котлет.
По правилам конференции phpbbgugru - один вопрос - одна тема.
Установка тройки отдельно, реанимация двойки отдельно, а то я уже начинаю путаться в ваших действиях.
Хорошо. Тогда с конвертированием я ухожу в соседнюю тему.
ksen писал(а):Все вроде поменяла, но результат, увы, не ахти:
Тем более. К слову двойка не поддерживается. Но в качестве исключения, скажу
Спасибо!
SQL Error : 1146 Table 'host700186_1.nar8_config' doesn't exist
Вы по-английски понимаете, или вам перевести, что означает Table doesn't exist
Нет такой таблицы в базе.
Что такой таблицы в базе нет - я поняла. Но не поняла, какой конкретный вывод мне делать из этой информации.
Я что-то написала неправильно?
Например, нужно было оставить в config старый префикс, а менять только базу?
Или нужно как-то сделать отсутствующую таблицу?
Или есть еще какой-то (может быть очень простой) ход, который в голову человеку впервые занимающемуся подобным делом, никак в голову придти не может.
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Fatal error в настройках администратора

Сообщение Sheer »

ksen писал(а):какой конкретный вывод
Конкретный вывод такой - в бае нет такой таблицы. Все, что тут непонятного? Более того, в той базе вообще никаких таблиц нет. Вы подключаетесь к абсолютно пустой базе. Зачем? Это вопрос к вам.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
ksen
phpBB 1.4.0
Сообщения: 36
Стаж: 16 лет
Благодарил (а): 4 раза

Re: Fatal error в настройках администратора

Сообщение ksen »

Ладно, Бог с ней, с отсутствующей таблицей. Я скачала новую двойку по Вашей ссылке и даже установила!
Подскажете теперь, как в нее вставить БД с погибшего форума? *умоляющий смайлик*

Добавлено спустя 2 минуты 42 секунды:
http://narnia8.jungdoohong.ru/

Добавлено спустя 1 час 43 минуты 50 секунд:
Хостер загрузил мне БД и она включилась!! :D
там есть всякие глюки: нет входа в административный раздел; когда я не смогла вспомнить старый пароль и попросила его восстановить, мне пришла для активизации ссылка на старый домен. Я вручную вбила новый, активизировалась и меня снова попытались отправить по старому адресу... :?
Наверное, сейчас нет смысла заморачиваться с ловлей этих блох? - просто конвертировать как есть и отлаживать все уже в третьей версии?

Добавлено спустя 1 час 29 минут 11 секунд:
Пока суд да дело, начала конвертировать этот форум. В ответ получила: "На вашей старой конференции найдены конфликтующие имена пользователей. Для завершения преобразования удалите или переименуйте этих пользователей так, чтобы каждому очищенному имени соответствовал только один пользователь старой конференции"
Я бы удалила, но, как я писала выше, там почему-то нет входа в административный раздел! Причем его нет с момента установки, а не то чтобы он исчез после того, как туда поставили побитую жизнью БД! Как же мне теперь быть? :cry:
Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Стаж: 20 лет 4 месяца
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 454 раза

Re: Fatal error в настройках администратора

Сообщение Палыч »

ksen
База phpBB2 ?
Зарегистрируйте нового пользователя
Зайдите в базу данных в таблице ваш_префикс_users найдите его (скорее всего последняя запись) и в поле user_level поставьте 1
Вы сделаете этого пользователя администратором.
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
Аватара пользователя
ksen
phpBB 1.4.0
Сообщения: 36
Стаж: 16 лет
Благодарил (а): 4 раза

Re: Fatal error в настройках администратора

Сообщение ksen »

Спасибо!
Беда в том, что права администратора у меня есть, а входа в раздел нет :(
Вчера сообразила просто пойти по администраторской ссылке. Если на нее нажать дважды - оказываешься в административном разделе :geek:
Еще я вчера скачала мод Userlist. На двойке, которая у меня нормально фурычила все эти годы, мод прекрасно установился и я сейчас убиваю спамеров по 10 000 за раз :twisted:
А вот на этом бедном инвалиде Userlist в адм.разделе не появился :cry: Как Вы полагаете, это можно как-то вылечить? :(

Добавлено спустя 1 час 44 минуты 50 секунд:
Нашла у Вас в архиве еще один способ массового удаления - без всяких модов: Удаление 98% пользователей.
Там его, правда, раскритиковали, но может быть в моем случае еще какие-то ошибки в базе критичными не будут?
Может быть мне стоит воспользоваться именно этим способом?
Аватара пользователя
ksen
phpBB 1.4.0
Сообщения: 36
Стаж: 16 лет
Благодарил (а): 4 раза

Re: Fatal error в настройках администратора

Сообщение ksen »

Из письма хостера: "Мы можем очистить таблицу пользователей напрямую из MySQL. Вам необходимо только уточнить какие таблицы нужно почистить"
Что мне ответить???
Изображение
Аватара пользователя
VVVas
Former team member
Сообщения: 4463
Стаж: 21 год 10 месяцев
Поблагодарили: 13 раз

Re: Fatal error в настройках администратора

Сообщение VVVas »

Вам не нужно очищать таблицу, вам нужно из неё удалить определённых пользователей (то что их много — это не значит что это все пользователи).
я люблю daft punk | новый sugoi.ru
Аватара пользователя
ksen
phpBB 1.4.0
Сообщения: 36
Стаж: 16 лет
Благодарил (а): 4 раза

Re: Fatal error в настройках администратора

Сообщение ksen »

VVVas писал(а):Вам не нужно очищать таблицу, вам нужно из неё удалить определённых пользователей
да, я тоже сразу хостеру ответила, что активных форумчан я удалять не хочу. Он ответил: "Если Вам нужно очистить таблицу с определенным условием, то для этого необходимо написать скрипт, который проверял бы условия. Пришлите нам этот скрипт, и мы выполним его"
Но я даже таблицу из которой нужно удалять не знаю, не то что скрипт :oops:
А я и со вторым форумом, на котором Userlist установился, рано радовалась - список из 10 000 он выдает, но удаление такого количества провести не может - думает, думает и выдает чистый лист :( сейчас постепенно снижаю число... :?

Вернуться в «Поддержка phpBB 3.0.х»