Ошибки после обновления на сервере до Debian 6
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
pavelkim
- phpBB 1.4.4
- Сообщения: 113
- Стаж: 17 лет 1 месяц
- Откуда: Беларусь
- Благодарил (а): 7 раз
Ошибки после обновления на сервере до Debian 6
Подскажите, пожалуйста, стабильно ли работает phpBB3 на Debian 6 Squeeze?
После обновления на сервере системы до вышеуказанной появились баги: у некоторых (!) пользователей не с первого раза отправлялись сообщения, не загружались вложения.
После установки хостером расширения php5-imagick, которое должно было помочь, слетели все права на папки и файлы. Такие как cache, files, images. Соответственно картинки (вложения, аватары) стали не видны.
Права были восстановлены и сейчас стоят:
/cache - 777;
/files - 777 (на файлы - 755);
/images/avatars/upload - 777 (на файлы аватар - 755).
В итоге все-равно у пользователей с переменным успехом отправляются сообщения, а аватары по-прежнему не видны (хотя и не все).
Вот, что на сервере сейчас:
php5.3.
php -v
PHP 5.3.3-7+squeeze8 with Suhosin-Patch (cli) (built: Feb 10 2012 13:05:56)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH
Тех поддержка хостера просит обратится к вам с этим вопросом, поясняя, что функция request_var, прописанная в includes/functions.php почему-то не подключается.
В общем у меня голова кругом идет от этого всего. Может кто-нибудь поможет разобраться?..
Добавлено спустя 1 минуту 10 секунд:
Да, забыл... Форум версии 3.0.9. Пока не обновил из-за портала, который претерпел у меня изменения.
После обновления на сервере системы до вышеуказанной появились баги: у некоторых (!) пользователей не с первого раза отправлялись сообщения, не загружались вложения.
После установки хостером расширения php5-imagick, которое должно было помочь, слетели все права на папки и файлы. Такие как cache, files, images. Соответственно картинки (вложения, аватары) стали не видны.
Права были восстановлены и сейчас стоят:
/cache - 777;
/files - 777 (на файлы - 755);
/images/avatars/upload - 777 (на файлы аватар - 755).
В итоге все-равно у пользователей с переменным успехом отправляются сообщения, а аватары по-прежнему не видны (хотя и не все).
Вот, что на сервере сейчас:
php5.3.
php -v
PHP 5.3.3-7+squeeze8 with Suhosin-Patch (cli) (built: Feb 10 2012 13:05:56)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH
Тех поддержка хостера просит обратится к вам с этим вопросом, поясняя, что функция request_var, прописанная в includes/functions.php почему-то не подключается.
В общем у меня голова кругом идет от этого всего. Может кто-нибудь поможет разобраться?..
Добавлено спустя 1 минуту 10 секунд:
Да, забыл... Форум версии 3.0.9. Пока не обновил из-за портала, который претерпел у меня изменения.
Секреты успешных форумов и сообществ
-
rxu
- phpBB Guru

- Сообщения: 17273
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 633 раза
- Поблагодарили: 2413 раз
Re: Ошибки после обновления на сервере до Debian 6
Дело в том, что phpBB работает не с состемой, а со связкой вебсервер-PHP-СУБД.pavelkim писал(а):После обновления на сервере системы до вышеуказанной появились баги
Поэтому, если обновился PHP, надо смотреть, какие настройки изменились.
В чем конкретно это проявляется?pavelkim писал(а):у пользователей с переменным успехом отправляются сообщения
-
pavelkim
- phpBB 1.4.4
- Сообщения: 113
- Стаж: 17 лет 1 месяц
- Откуда: Беларусь
- Благодарил (а): 7 раз
Re: Ошибки после обновления на сервере до Debian 6
При отправке сообщения с вложением или без появляется следующая ошибка:
Код: Выделить всё
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, info@krolikovod.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Apache/2.2.16 (Debian) Server at krolikovod.com Port 80Секреты успешных форумов и сообществ
-
МайскийЖук
- phpBB 3.0.7-PL1
- Сообщения: 2535
- Стаж: 16 лет 11 месяцев
- Благодарил (а): 17 раз
- Поблагодарили: 366 раз
Ошибки после обновления на сервере до Debian 6
Ошибка-то под номером 500? Обращайтесь к хостеру, пусть настраивает свой хостинг.
Любовь и боль, покой и бой я как любой несу с собой…
-
pavelkim
- phpBB 1.4.4
- Сообщения: 113
- Стаж: 17 лет 1 месяц
- Откуда: Беларусь
- Благодарил (а): 7 раз
Re: Ошибки после обновления на сервере до Debian 6
С хостером я уже вторые сутки общаюсь. Сегодня в итоге поддержка хостера меня отправила сюда.
Добавлено спустя 10 минут 22 секунды:
Если попытаться открыть картинку аватара отдельно в браузере, то выдает ошибку:
Стока 61 вторая сверху:
Добавлено спустя 1 час 39 минут 4 секунды:
Ну, с загрузкой фото на форум вроде разобрались.
Увеличили допустимый размер запроса для FastCGI (я честно говоря не знаю, что это такое) и фото начали преспокойно загружаться. Видимо не хватало времени на какой-то запрос.
Остались невидимыми аватары.
Добавлено спустя 16 минут 7 секунд:
Добавлено спустя 10 минут 22 секунды:
Если попытаться открыть картинку аватара отдельно в браузере, то выдает ошибку:
Код: Выделить всё
Fatal error: Call to undefined function request_var() in /var/www/krolikov/data/www/krolikovod.com/phpforum/download/file.php on line 61Код: Выделить всё
$config = $cache->obtain_config();
$filename = request_var('avatar', '');
$avatar_group = false;
$exit = false;
Ну, с загрузкой фото на форум вроде разобрались.
Увеличили допустимый размер запроса для FastCGI (я честно говоря не знаю, что это такое) и фото начали преспокойно загружаться. Видимо не хватало времени на какой-то запрос.
Остались невидимыми аватары.
Добавлено спустя 16 минут 7 секунд:
из переписки с саппортом хостера:rxu писал(а):Поэтому, если обновился PHP, надо смотреть, какие настройки изменились.
Все упомянутые в документации по установке phpbb3 модули присутствуют на сервере.При обновлении были сохранены оригинальные файлы настроек, но часть параметров более неактуальны либо могут обрабатываться по другому. Пожалуйста, уточните, какие параметры PHP 5.3 необходимы для корректной работы phpBB используемой Вами версии.
Секреты успешных форумов и сообществ
-
Пчелкин
- phpBB 3.3.0
- Сообщения: 11361
- Стаж: 16 лет 8 месяцев
- Благодарил (а): 1832 раза
- Поблагодарили: 1358 раз
Re: Ошибки после обновления на сервере до Debian 6
Серверный ImageMagick остался привязанным?
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
-
pavelkim
- phpBB 1.4.4
- Сообщения: 113
- Стаж: 17 лет 1 месяц
- Откуда: Беларусь
- Благодарил (а): 7 раз
Re: Ошибки после обновления на сервере до Debian 6
Пишут, что этот модуль присутствует.
Секреты успешных форумов и сообществ
-
rxu
- phpBB Guru

- Сообщения: 17273
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 633 раза
- Поблагодарили: 2413 раз
Re: Ошибки после обновления на сервере до Debian 6
Строкаpavelkim писал(а):Fatal error: Call to undefined function request_var() in /var/www/krolikov/data/www/krolikovod.com/phpforum/download/file.php on line 61
require($phpbb_root_path . 'includes/functions.' . $phpEx); в этом файле присутствует?-
pavelkim
- phpBB 1.4.4
- Сообщения: 113
- Стаж: 17 лет 1 месяц
- Откуда: Беларусь
- Благодарил (а): 7 раз
Re: Ошибки после обновления на сервере до Debian 6
Нет, такой строки нету.
Добавлено спустя 3 минуты 31 секунду:
rxu, добавил указанную вами строку. Аватары видны! Большое человеческое спасибо!
Добавлено спустя 3 минуты 31 секунду:
rxu, добавил указанную вами строку. Аватары видны! Большое человеческое спасибо!
Секреты успешных форумов и сообществ
-
rxu
- phpBB Guru

- Сообщения: 17273
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 633 раза
- Поблагодарили: 2413 раз
Re: Ошибки после обновления на сервере до Debian 6
Значит, какое-то из обновлений phpBB3 прошло не полностью. Если модами файл не изменен, лучше перезалить его из дистрибутива соответствующей версии.pavelkim писал(а):Нет, такой строки нету.

