Ошибки форума после обновления на сервере

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
AvCrash
phpBB 1.0.0
Сообщения: 2
Стаж: 14 лет 5 месяцев
Благодарил (а): 1 раз

Ошибки форума после обновления на сервере

Сообщение AvCrash »

Приветствую!
помогите решить вопрос с возникшими ошибками на форуме
Хостер обновил версию PHP до 5.4 и, видимо, mysql до 5.1 версии.
Теперь стали сыпаться ошибки, вроде этих:

Код: Выделить всё

[PHP]Strict Standards: Non-static method utf_normalizer::nfkc() should not be called statically in /home/clients/html/forum/includes/utf/utf_tools.php on line 1663[/PHP]

[PHP]Strict Standards: Non-static method p_master::module_auth() should not be called statically, assuming $this from incompatible context in /home/clients/html/forum/includes/acp/acp_modules.php on line 630 Strict Standards: Non-static method p_master::module_auth() should not be called statically, assuming $this from incompatible context in /home/clients/html/forum/includes/acp/acp_modules.php on line 630 Strict Standards: Non-static method p_master::module_auth() should not be called statically, assuming $this from incompatible context in /home/clients/html/forum/includes/acp/acp_modules.php on line 630 Strict Standards: Non-static method p_master::module_auth() should not be called statically, assuming $this from incompatible context in /home/clients/html/forum/includes/acp/acp_modules.php on line 630 Strict Standards: Non-static method p_master::module_auth() should not be called statically, assuming $this from incompatible context in /home/clients/html/forum/includes/acp/acp_modules.php on line 630 Strict Standards: Non-static method [/PHP]

[PHP]Strict Standards: Non-static method utf_normalizer::nfkc() should not be called statically in /home/clients/html/forum/includes/utf/utf_tools.php on line 1663 Strict Standards: Non-static method phpbb_captcha_factory::get_instance() should not be called statically in /home/clients/html/forum/includes/auth/auth_db.php on line 140 Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method phpbb_captcha_qa::get_instance() should not be called statically in /home/clients/html/forum/includes/captcha/captcha_factory.php on line 38 Strict Standards: Non-static method phpbb_captcha_factory::get_instance() should not be called statically in /home/clients/html/forum/includes/functions.php on line 3066 Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method phpbb_captcha_qa::get_instance() should not be called statically in /home/clients/html/forum/includes/captcha/captcha_factory.php on line 38 [/PHP]
В разных местах форума возникают - при переходе по ссылкам в админ-панели, при логине просто на форум если учетные данные были введены не верно и т.п.
Аватара пользователя
МайскийЖук
phpBB 3.0.7-PL1
Сообщения: 2535
Стаж: 16 лет 11 месяцев
Благодарил (а): 17 раз
Поблагодарили: 366 раз

Ошибки форума после обновления на сервере

Сообщение МайскийЖук »

Версия установленного у вас форума какая? Последняя, надеюсь?
Любовь и боль, покой и бой я как любой несу с собой…
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибки форума после обновления на сервере

Сообщение Sheer »

В файле /includes/startup.php найти (строка 22)

Код: Выделить всё

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED);
После ~E_DEPRECATED в строке добавить & ~E_STRICT
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
AvCrash
phpBB 1.0.0
Сообщения: 2
Стаж: 14 лет 5 месяцев
Благодарил (а): 1 раз

Re: Ошибки форума после обновления на сервере

Сообщение AvCrash »

Sheer, помогло. Ошибки исчезли с глаз.
Скажите, а эти ошибки носят не критичный характер? т.е. их скрытие не повлияет на работу?
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибки форума после обновления на сервере

Сообщение Sheer »

AvCrash писал(а):их скрытие не повлияет на работу?
Нет.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
gudk
phpBB 1.4.0
Сообщения: 32
Стаж: 19 лет 6 месяцев

Re: Ошибки форума после обновления на сервере

Сообщение gudk »

Sheer писал(а):В файле /includes/startup.php найти (строка 22)
у меня нет такого файла.
ошибки типа
trict Standards: Non-static method utf_normalizer::nfc() should not be called statically in /home/gudk/data/www/111.su/includes/utf/utf_tools.php on line 1781

Strict Standards: Non-static method utf_normalizer::recompose() should not be called statically in /home/gudk/data/www/111.su/includes/utf/utf_normalizer.php on line 145


Strict Standards: Non-static method utf_normalizer::nfkc() should not be called statically in /home/gudk/data/www/111.su/includes/utf/utf_tools.php on line 1663

Strict Standards: Non-static method utf_normalizer::recompose() should not be called statically in /home/gudk/data/www/111.su/includes/utf/utf_normalizer.php on line 177
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Ошибки форума после обновления на сервере

Сообщение Пчелкин »

gudk писал(а):/includes/utf/
Заменить все файлы из стандартного дистрибутива пробовали?
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
gudk
phpBB 1.4.0
Сообщения: 32
Стаж: 19 лет 6 месяцев

Re: Ошибки форума после обновления на сервере

Сообщение gudk »

как понять? что надо сделать поясните

Добавлено спустя 5 минут 41 секунду:
Скопировал этот файл из нового дистр и произвел в нем изменения, ошибки при автортизации и выходе пропали.

Есть другая ошибка в админ панели при редактировании шаблона
Strict Standards: Non-static method utf_normalizer::nfc() should not be called statically in /home/gudk/data/www/r55e.su/includes/utf/utf_tools.php on line 1781
после этой строчки пустой экран, ничего нет
редактировать не возможно
что делать?
Последний раз редактировалось gudk 28.07.2012 9:14, всего редактировалось 1 раз.
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Ошибки форума после обновления на сервере

Сообщение Пчелкин »

Скачать дистрибутив ...и папку /utf/ забекапив свою родную, заменить полностью папкой из дистрибутива двига....
Или все ее файлы по тихой менять, там воще то всего два...
А еще лучшще посмотреть на указанные в ошибке строки...чем они похезаны или исправлены...мож что сами модифицировали и ошибку внесли...можно еще свои сравнить с стандартными...тож иногда помогает найти ошибки, например, после автообновления или установки какого-то мода...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
gudk
phpBB 1.4.0
Сообщения: 32
Стаж: 19 лет 6 месяцев

Re: Ошибки форума после обновления на сервере

Сообщение gudk »

переехал на другой сервер. все работает кроме нескольких проблем в админ панели не могу менять все что связано с шаблонами выдает именно эту ошибку Strict Standards: Non-static method utf_normalizer::nfc() should not be called statically in /home/gudk/data/www/123.su/includes/utf/utf_tools.php on line 1781
Файлы обновил на новые
в данной строке какой то бред типа "\xF0\x9D\x99\x86" => "\x6B",

помогите
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибки форума после обновления на сервере

Сообщение Sheer »

gudk писал(а):Файлы обновил на новые
Каким образом? Какой режим использовался для передачи по FTP?
Эта строка должна выглядеть так

Код: Выделить всё

utf_normalizer::nfc($strings);
Смотрите тему на оффсайте http://www.phpbb.com/community/viewtopi ... &t=1660505
gudk писал(а):Есть другая ошибка в админ панели при редактировании шаблона
Да, и кстати - никогда (три раза никогда) не редактируйте шаблоны через ACP!
Почему? Читать тут http://www.phpbbguru.net/kb/styling/how ... ate-style/ - Совет первый
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
1stDragon
phpBB 1.2.1
Сообщения: 25
Стаж: 12 лет 11 месяцев
Благодарил (а): 3 раза
Поблагодарили: 1 раз

Re: Ошибки форума после обновления на сервере

Сообщение 1stDragon »

Версия форума 3.0.11
При переходах с страницы на страницу, выбивает ошибку

Код: Выделить всё

Strict Standards: Non-static method utf_normalizer::recompose() should not be called statically in /forum/includes/utf/utf_normalizer.php on line 145

Strict Standards: Non-static method utf_normalizer::recompose() should not be called statically in /forum/includes/utf/utf_normalizer.php on line 145
Я так понял это из-за приязки к сайту, так как на виртуальном сервере такое не всплывает.
Скопировал код из файла utf_normalizer.php

Код: Выделить всё

/**
	* Validate and normalize a UTF string to NFC
	*
	* @param	string	&$str	Unchecked UTF string
	* @return	string			The string, validated and in normal form
	*/
	public static function nfc(&$str)
	{
		$pos = strspn($str, UTF8_ASCII_RANGE);
		$len = strlen($str);

		if ($pos == $len)
		{
			// ASCII strings return immediately
			return;
		}

		if (!isset($GLOBALS['utf_nfc_qc']))
		{
			global $phpbb_root_path, $phpEx;
			include($phpbb_root_path . 'includes/utf/data/utf_nfc_qc.' . $phpEx);
		}

		if (!isset($GLOBALS['utf_canonical_decomp']))
		{
			global $phpbb_root_path, $phpEx;
			include($phpbb_root_path . 'includes/utf/data/utf_canonical_decomp.' . $phpEx);
		}

		$str = utf_normalizer::recompose($str, $pos, $len, $GLOBALS['utf_nfc_qc'], $GLOBALS['utf_canonical_decomp']);
	}
Sheer писал(а):В файле /includes/startup.php найти (строка 22)

Код: Выделить всё

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED);
После ~E_DEPRECATED в строке добавить & ~E_STRICT
Не получилось скрыть этим методом, но у меня там немного по другому

22 строка

Код: Выделить всё

$level = E_ALL & ~E_NOTICE & ~E_DEPRECATED ;
38 строка

Код: Выделить всё

error_reporting($level)
добавлял & ~E_STRICT но ошибки все еще высвечивает

Добавлено спустя 1 минуту 40 секунд:
вот код с 22 по 28 строку

Код: Выделить всё

$level = E_ALL & ~E_NOTICE & ~E_DEPRECATED;
if (version_compare(PHP_VERSION, '5.4.0-dev', '>='))
{
	// PHP 5.4 adds E_STRICT to E_ALL.
	// Our utf8 normalizer triggers E_STRICT output on PHP 5.4.
	// Unfortunately it cannot be made E_STRICT-clean while
	// continuing to work on PHP 4.
	// Therefore, in phpBB 3.0.x we disable E_STRICT on PHP 5.4+,
	// while phpBB 3.1 will fix utf8 normalizer.
	// E_STRICT is defined starting with PHP 5
	if (!defined('E_STRICT'))
	{
		define('E_STRICT', 2048);
	}
	$level &= ~E_STRICT;
}
error_reporting($level);
1stDragon
phpBB 1.2.1
Сообщения: 25
Стаж: 12 лет 11 месяцев
Благодарил (а): 3 раза
Поблагодарили: 1 раз

Re: Ошибки форума после обновления на сервере

Сообщение 1stDragon »

Та же ошибка выбивает при создании нового подфорума через админпанель

Добавлено спустя 1 час 16 минут 45 секунд:
Проверил сейчас эту ошибку на виртуальной машине, полет нормальный этих ошибок нет и форумы прекрасно создаются...
Аватара пользователя
Stilch
phpBB 1.2.0
Сообщения: 15
Стаж: 15 лет 3 месяца
Благодарил (а): 1 раз
Поблагодарили: 2 раза

Re: Ошибки форума после обновления на сервере

Сообщение Stilch »

Пропишите в самом файле: /includes/utf/utf_tools.php и в тех где появляется ошибка

Код: Выделить всё

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT);
IL76
phpBB 1.0.0
Сообщения: 4
Стаж: 12 лет 2 месяца

Re: Ошибки форума после обновления на сервере

Сообщение IL76 »

Господа,

Не могу зарегистрироваться на своем форуме выдает

Что делать посоветуете?
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Вернуться в «Поддержка phpBB 3.0.х»