Проблема с кирилличными никами
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
Re: Ошибка при входе пользователей с Русскими никами
Скачал его еще вчера. Только ничего не нагуглил как его запустить. Можете объяснить подробно? И что должно получиться? На сервере в полях username_clean и username ники станут на кириллице?
-
rxu
- phpBB Guru

- Сообщения: 17271
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Ошибка при входе пользователей с Русскими никами
В поле username_clean ники не должны выглядеть так же, как и в username. То, что там есть (тт, 6, r, φ и прочее) - это нормально.CARNET писал(а):в полях username_clean и username ники станут на кириллице?
Re: Ошибка при входе пользователей с Русскими никами
А я то думал, что скрипт username_clean.php исправляет эти символы. Запустил этот скрипт, по совету Пчелкин'а. На сервере, в отличие от денвера, поля username_clean и username у русских ников как были, так и остались вида d092d0b0d0bbd0b5d180d0b0. Что со скриптом, что без скрипта... Для чего он нужен так и осталось не выясненным...
-
Пчелкин
- phpBB 3.3.0
- Сообщения: 11361
- Стаж: 16 лет 8 месяцев
- Благодарил (а): 1832 раза
- Поблагодарили: 1358 раз
Re: Ошибка при входе пользователей с Русскими никами
Это скрипт должен исправить траблы с русскими никами при входе...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
-
DeathMan
- phpBB 2.0.7a
- Сообщения: 648
- Стаж: 19 лет 4 месяца
- Откуда: Курская обл.
- Благодарил (а): 73 раза
- Поблагодарили: 8 раз
Re: Проблема с кириличными никами
После обновления 3.0.9 до 3.0.10 (сборка от phpbbguru) стала часто проявляться проблема с первого поста (пользователь не может зайти, пишет не тот пароль или нет такого пользователя, в админке по нику поиск не осуществляется, пишет такого нету)
Решаю проблему геморное:
ищу сообщения от пользователя на форуме, нажимаю на его ник, попадаю в профиль через админку, переименовываю на англ, затем обратно на русский и все работает, но периодически слетает.
Вопрос, при попытке сделать через STK Reclean Usernames выдало:
на запрос в SQL через myphpadmin
выдает след.:
Так же переименовал Татьяна на Татьяна1 и снова сделал reclean usernames в STK появился след. пользователь, но в админке по поиску Татьяна снова появилась Татьяна только с другим email (т.е. другой пользователь), думаю так щас с большинством ников на форуме
Попробовал сделать рекомендацию от сюда, запустить файл Невозможность выбора пользователей с русскими никами username_clean.php и вот что он выдал
Запрет на регистрацию Русских ников неприемлем! Русские ники(запрет).
У меня есть пользователь с уникальным ником, т.е. второй раз такой ник вряд ли кто то будет регистрировать (т.е. исключен дубликат данного ника), так вот с этим пользователем у меня чаще всего проблема эта проявляется (ник: полуночница@)
все таблицы у меня в utf8_bin только вот в конце непоятка какая то:

то есть у меня нет там ненормальной кодировки.
Сдается мне что что то забыли создатели phpbb 3.0.10 внести с кириллицей... И как вообще может быть такое, что бы была возможность регистрации одинаковых ников (такое же должно быть исключено в коде phpbb)?
Решаю проблему геморное:
ищу сообщения от пользователя на форуме, нажимаю на его ник, попадаю в профиль через админку, переименовываю на англ, затем обратно на русский и все работает, но периодически слетает.
Вопрос, при попытке сделать через STK Reclean Usernames выдало:
Код: Выделить всё
Общая ошибка
SQL ERROR [ mysql4 ]
Duplicate entry 'тaтƅянa' for key 2 [1062]
SQL
UPDATE phpbb_users SET username_clean = 'тaтƅянa' WHERE user_id = 505
BACKTRACE
FILE: [ROOT]/includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()
FILE: [ROOT]/stk/tools/support/reclean_usernames.php
LINE: 53
CALL: dbal_mysql->sql_query()
FILE: [ROOT]/stk/index.php
LINE: 388
CALL: reclean_usernames->run_tool()
Код: Выделить всё
select user_id, username, username_clean from phpbb_users where `username`='Татьяна'
select user_id, username, username_clean from phpbb_users where `username`='татьяна'
select user_id, username, username_clean from phpbb_users where `username_clean`='тaтƅянa'
select user_id, username, username_clean from phpbb_users where `username_clean`='татьяна'
Код: Выделить всё
Ошибка
SQL-запрос: Документация
SELECT user_id, username, username_clean
FROM phpbb_users
WHERE `username` = 'Татьяна'
SELECT user_id, username, username_clean
FROM phpbb_users
WHERE `username` = 'татьяна'
SELECT user_id, username, username_clean
FROM phpbb_users
WHERE `username_clean` = 'тaтƅянa'
SELECT user_id, username, username_clean
FROM phpbb_users
WHERE `username_clean` = 'татьяна'
LIMIT 0 , 30
Ответ MySQL: Документация
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'select user_id, username, username_clean from phpbb_users where `username`='та' at line 2
Код: Выделить всё
Общая ошибка
SQL ERROR [ mysql4 ]
Duplicate entry 'aлeĸcaндp' for key 2 [1062]
SQL
UPDATE phpbb_users SET username_clean = 'aлeĸcaндp' WHERE user_id = 746
BACKTRACE
FILE: [ROOT]/includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()
FILE: [ROOT]/stk/tools/support/reclean_usernames.php
LINE: 53
CALL: dbal_mysql->sql_query()
FILE: [ROOT]/stk/index.php
LINE: 388
CALL: reclean_usernames->run_tool()
Код: Выделить всё
Общая ошибка
SQL ERROR [ mysql4 ]
Duplicate entry 'aлeĸcaндp' for key 2 [1062]
SQL
UPDATE phpbb_users SET username_clean = 'aлeĸcaндp' WHERE user_id = 746
BACKTRACE
FILE: [ROOT]/includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()
FILE: [ROOT]/username_clean.php
LINE: 54
CALL: dbal_mysql->sql_query()
это не понял где посмотреть можноrxu писал(а):Чему равен параметр mbstring.func_overload в настройках PHP?
Запрет на регистрацию Русских ников неприемлем! Русские ники(запрет).
У меня есть пользователь с уникальным ником, т.е. второй раз такой ник вряд ли кто то будет регистрировать (т.е. исключен дубликат данного ника), так вот с этим пользователем у меня чаще всего проблема эта проявляется (ник: полуночница@)
все таблицы у меня в utf8_bin только вот в конце непоятка какая то:
FEAR93 писал(а):, я понял теперь Вас)))) зашол в структуру этой phpbb_login_attempts таблицы и везде latin1_swedish_ci стоят. Теперь проблема решилась, ники Русскими буквами заходят без проблем, что я сделал (для тех, у кого эта проблема). Зашол в структуру базы phpbb_login_attempts и изменил кодировки везде latin1_swedish_ci на utf8_bin
то есть у меня нет там ненормальной кодировки.
Сдается мне что что то забыли создатели phpbb 3.0.10 внести с кириллицей... И как вообще может быть такое, что бы была возможность регистрации одинаковых ников (такое же должно быть исключено в коде phpbb)?
У вас нет необходимых прав для просмотра вложений в этом сообщении.
phpbb3 - сила!
-
rusmiass
- phpBB 1.0.0
- Сообщения: 4
- Стаж: 14 лет 10 месяцев
- Благодарил (а): 1 раз
-
shakal
- phpBB 1.4.2
- Сообщения: 72
- Стаж: 20 лет 3 месяца
- Откуда: Новокузнецк
- Благодарил (а): 9 раз
- Поблагодарили: 1 раз
Re: Невозможность выбора пользователей с русскими никами
cianid писал(а):таже проблема с русскими никами возникла.
применил файлик. в процессе его работы возникла ошибка:
Общая ошибка
SQL ERROR [ mysqli ]
Duplicate entry 'С‡epРЅaСЏ ДёoС€Дёa' for key 2 [1062]
SQL
UPDATE phpf_users SET username_clean = 'С‡epРЅaСЏ ДёoС€Дёa' WHERE user_id = 12523
BACKTRACE
FILE: includes/db/mysqli.php
LINE: 163
CALL: dbal->sql_error()
FILE: username_clean.php
LINE: 54
CALL: dbal_mysqli->sql_query()
как быть дальше?
у меня такая же проблема. только вот дублирующих ников нет.nissin писал(а):Переименовать пользователей с дублирующими никами.
SQL ERROR [ mysqli ]
Duplicate entry 'дoмoвoй' for key 'PRIMARY' [1062]
Произошла ошибка SQL при выборке на этой странице. Пожалуйста, сообщите администратору, если ошибка будет повторяться.
т.е. если через админку поменять логин на любой другой хоть ляляляляля то все равно такая ошибка. как быть? а вот если через админку этому же юзеру сделать сначало английский логин а потом опять русский то все норм..... как быть то?
-
shakal
- phpBB 1.4.2
- Сообщения: 72
- Стаж: 20 лет 3 месяца
- Откуда: Новокузнецк
- Благодарил (а): 9 раз
- Поблагодарили: 1 раз
Re: Проблема с кириличными никами
Описание проблемы: не пускает новых пользователей с русским ником
Произведенные изменения, после которых начались неполадки: сборка была скачана с phpbb3 со встроенными модулями
Версия phpBB: 3,0,9
Используемые стили: prosilver
Используемые моды:
Версия PHP: 5,3
Используемая СУБД и её версия:
Ссылка на конференцию: http://forum.domostroy42.ru
Есть ли у вас тестовый аккаунт: домовой пароль qwerty
Использовался ли поиск для решения проблемы: да. прочитал все темы касающиеся данной тематике. но ответа и решения не нашел. поствил stk дубликатов не вывлено
Если да, то какие запросы вы использовали:
при этом вылетает ошибка такого рода
SQL ERROR [ mysqli ]
Duplicate entry 'дoмoвoй' for key 'PRIMARY' [1062]
Произошла ошибка SQL при выборке на этой странице. Пожалуйста, сообщите администратору, если ошибка будет повторяться. вход новых пользователей на латинице нормальный.
Произведенные изменения, после которых начались неполадки: сборка была скачана с phpbb3 со встроенными модулями
Версия phpBB: 3,0,9
Используемые стили: prosilver
Используемые моды:
Версия PHP: 5,3
Используемая СУБД и её версия:
Ссылка на конференцию: http://forum.domostroy42.ru
Есть ли у вас тестовый аккаунт: домовой пароль qwerty
Использовался ли поиск для решения проблемы: да. прочитал все темы касающиеся данной тематике. но ответа и решения не нашел. поствил stk дубликатов не вывлено
Если да, то какие запросы вы использовали:
при этом вылетает ошибка такого рода
SQL ERROR [ mysqli ]
Duplicate entry 'дoмoвoй' for key 'PRIMARY' [1062]
Произошла ошибка SQL при выборке на этой странице. Пожалуйста, сообщите администратору, если ошибка будет повторяться. вход новых пользователей на латинице нормальный.
-
rxu
- phpBB Guru

- Сообщения: 17271
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Невозможность выбора пользователей с русскими никами
Проверьте кодировку таблицы пользователей и ее полей в базе данных.
-
shakal
- phpBB 1.4.2
- Сообщения: 72
- Стаж: 20 лет 3 месяца
- Откуда: Новокузнецк
- Благодарил (а): 9 раз
- Поблагодарили: 1 раз
Re: Невозможность выбора пользователей с русскими никами
да проверял. стоит UTF-8. просто снес тот форум и поставил ваш. и все стало нормально.rxu писал(а):Проверьте кодировку таблицы пользователей и ее полей в базе данных.
-
shakal
- phpBB 1.4.2
- Сообщения: 72
- Стаж: 20 лет 3 месяца
- Откуда: Новокузнецк
- Благодарил (а): 9 раз
- Поблагодарили: 1 раз
Re: Проблема с кириличными никами
Люди помогите. была проблема с русскими.устранил переставив форум. щас проблема с ником admin/ вылетает точ то такая же ошибка. форум брал у вас. что за карма такая. что делать.
SQL ERROR [ mysqli ]
Duplicate entry 'admin' for key 'PRIMARY' [1062]
Произошла ошибка SQL при выборке на этой странице. Пожалуйста, сообщите администратору, если ошибка будет повторяться.
Добавлено спустя 38 минут 58 секунд:
вывел такую закономерность. что дело точно не в базе а где то в php. т.к на переносе базы на чистый форум все работает нормально. но в один прекрасный момент появляется ошибка. дублей так же нету. а если в самой базе пользователю добавить букву s и сохранить получиться логин admins а потом ее так же убрать до первоначального вида. то админ входит нормально. где тут загвоздка понять не могу. помогите разобраться
SQL ERROR [ mysqli ]
Duplicate entry 'admin' for key 'PRIMARY' [1062]
Произошла ошибка SQL при выборке на этой странице. Пожалуйста, сообщите администратору, если ошибка будет повторяться.
Добавлено спустя 38 минут 58 секунд:
вывел такую закономерность. что дело точно не в базе а где то в php. т.к на переносе базы на чистый форум все работает нормально. но в один прекрасный момент появляется ошибка. дублей так же нету. а если в самой базе пользователю добавить букву s и сохранить получиться логин admins а потом ее так же убрать до первоначального вида. то админ входит нормально. где тут загвоздка понять не могу. помогите разобраться
-
Pazh
- Former team member
- Сообщения: 2317
- Стаж: 16 лет 10 месяцев
- Благодарил (а): 42 раза
- Поблагодарили: 506 раз
Re: Проблема с кириличными никами
shakal сделай проверку и переиндексацию таблиц БД
Помощь в ЛС/email только за WM или ЮMoney
-
shakal
- phpBB 1.4.2
- Сообщения: 72
- Стаж: 20 лет 3 месяца
- Откуда: Новокузнецк
- Благодарил (а): 9 раз
- Поблагодарили: 1 раз
Re: Проблема с кириличными никами
а как это сделать.?Pazh писал(а):shakal сделай проверку и переиндексацию таблиц БД

