Проблема с вложениями

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
AndreyGibson
phpBB 1.0.0
Сообщения: 3
Стаж: 13 лет 2 месяца

Re: Проблема с вложениями

Сообщение AndreyGibson »

Dсе, снимаю вопрос, оказывается я при создании домена не указал поддержку PHP. Спасибо за советы)
Аватара пользователя
magellan
phpBB 1.4.2
Сообщения: 61
Стаж: 14 лет 2 месяца
Благодарил (а): 5 раз
Поблагодарили: 5 раз

Re: Проблема с вложениями

Сообщение magellan »

Столкнулся со следующей проблемой: изменяю настройки вложений, поле "Максимальный размер файла", выставляю размер 10 KiB, сохраняю настройки. Раньше стояло 155 KiB.
На пробу загружаю файл (не с админского аккаунта, а с обычного) размером 100 KiB и он загружается. Загружаю файл размером 200 KiB и выдает: "Слишком большой размер вложения. Максимальный разрешенный размер: 155 KiB.".
Из-за чего может быть, что старый размер файла остается?
Помогите, пожалуйста, разобраться.
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Проблема с вложениями

Сообщение Пчелкин »

От настроек в php.ini....есть еще и такое на хостингах...
magellan писал(а):(не с админского аккаунта, а с обычного)
Уверен? На админов ограничения не расспространяются
magellan писал(а):10 KiB,
А откуда у тебя эти КИБ ???? Там КБ вроде ж...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
Аватара пользователя
magellan
phpBB 1.4.2
Сообщения: 61
Стаж: 14 лет 2 месяца
Благодарил (а): 5 раз
Поблагодарили: 5 раз

Re: Проблема с вложениями

Сообщение magellan »

Да, уверен, обычный аккаунт.

Всегда были KiB. (см.скриншот)
3275c5aafd42.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: Проблема с вложениями

Сообщение rxu »

magellan писал(а):выставляю размер 10 KiB, сохраняю настройки. Раньше стояло 155 KiB.
А после сохранения админка показывает 10, или 155?
Изображение
Аватара пользователя
magellan
phpBB 1.4.2
Сообщения: 61
Стаж: 14 лет 2 месяца
Благодарил (а): 5 раз
Поблагодарили: 5 раз

Re: Проблема с вложениями

Сообщение magellan »

10
Аватара пользователя
sdakasadist
phpBB 2.0.0
Сообщения: 236
Стаж: 13 лет 9 месяцев
Благодарил (а): 62 раза
Поблагодарили: 20 раз

Re: Проблема с вложениями

Сообщение sdakasadist »

magellan, у меня была такая проблема , но оказалось всё из-за хостера, хостер мне писал что настройки прописывать ещё и в user.ini в корне сайта (у меня так, не знаю как в вашем случае) , я прописывал и в этот файл и в админке форума , но ничего не получалось, потом написал хостеру , он перезагрузил сервер и изменения вступили в силу. Может и вам стоит к хостеру обратиться?
Изображение
Аватара пользователя
Pazh
Former team member
Сообщения: 2317
Стаж: 16 лет 10 месяцев
Благодарил (а): 42 раза
Поблагодарили: 506 раз

Re: Проблема с вложениями

Сообщение Pazh »

для вступления в силу любых изменений в php.ini нужно перезагрузить apache
Помощь в ЛС/email только за WM или ЮMoney
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Проблема с вложениями

Сообщение Slash »

Описание проблемы: При добавлении в пост вложения, например картинки, затем ее удалив и перезагрузит страницу выходит ошибка:

Код: Выделить всё

Произошла общая ошибка: Общая ошибка 
» Вам запрещён доступ к этому файлу.

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/message_parser.php
LINE: 1854
CALL: trigger_error()

FILE: [ROOT]/posting.php
LINE: 431
CALL: parse_message->get_submitted_attachment_data()
Файл: includes/message_parser.php, строка 1854:

Код: Выделить всё

			trigger_error('NO_ACCESS_ATTACHMENT', E_USER_ERROR);
Файл: posting.php, строка 431:

Код: Выделить всё

$message_parser->get_submitted_attachment_data($post_data['poster_id']);
На папку files, стоят права 777.
Произведенные изменения, после которых начались неполадки: не могу даже придставить, обнаружил этот косяк только недавно.
Версия phpBB: 3.0.11
Используемые стили: просильвер, сабсильвер2
Используемые моды:

Код: Выделить всё

Adaptive Hide BBcodes
Advanced Similar Topics
Advertisement Management
Buttons menu MOD
Display new posts count since last visit for phpBB3
Download Topic and Post for phpBB3
First post on every page for phpBB3
Google поиск по сайту
HighSlide 4.1.8 Attachment MOD
IP пользователя в мини профиле
Last post topic on index for phpBB3
Length of service for phpBB3
List subforums in columns (Список подфорумов в столбик)
Manage attachments module for phpBB3
Mods Database
NV Newspage
NV Recent Topics
phpBB SEO Dynamic Meta Tags
Post number in viewtopic
Posts merging - Склеивание сообщений / постов
Prime Links
Quick Reply phpBB 3.0.6
Quote Post Back Link (QPBL)
Simple Url To Link Name before posting
Sitemap FX
Support Toolkit
th23 Error Pages
Topic actions shedule
User Reputation Points
Автор темы
Антибот 100500
Возраст в мини профиле
Выпадающая форма входа (Dropdown login box)
Выпадающее меню
Закругленные углы для prosilver
Запрет редактирования если сообщение не последнее в теме
Индикатор папок ЛС
Количество вложений на главной странице
Количество предупреждений в мини профиле
Количество сообщений пользователя в теме
Кто был на конференции сегодня
Парсер сообщений (автозамена)
Перенос профилей налево/направо в один клик
Поиск по разделу на главной странице
Пометка Друг в мини профиле
Просмотр проголосовавших пользователей
Русские буквы в URL
Спасибо за сообщение (система рейтинга)
Статус темы в виде значка
Версия PHP: 5.3.21
Используемая СУБД и её версия: MySQL 5.1.67-log
Использовался ли поиск для решения проблемы: Да.
Если да, то какие запросы вы использовали: Вам запрещён доступ к этому файлу. Нашел несколько сообщений, но там решалось с модом Анонимный форум - этого мода у меня нет.
Аватара пользователя
владимир1983
phpBB 3.2.6
Сообщения: 5954
Стаж: 16 лет 4 месяца
Откуда: Сергиев Посад
Благодарил (а): 373 раза
Поблагодарили: 727 раз

Re: Проблема с вложениями

Сообщение владимир1983 »

Файл удаляется? Или ошибка появляется после клика на кнопку удалить?
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
Аватара пользователя
bumbr
phpBB 1.4.4
Сообщения: 129
Стаж: 15 лет 3 месяца
Откуда: Беларусь
Благодарил (а): 44 раза
Поблагодарили: 24 раза

Re: Проблема с вложениями

Сообщение bumbr »

magellan
Вкладка Сообщения
limit.jpg
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: Проблема с вложениями

Сообщение Shredder »

Raisin
"Баг" (если это баг) - стандартный, на соей памяти был всегда.
Аватара пользователя
владимир1983
phpBB 3.2.6
Сообщения: 5954
Стаж: 16 лет 4 месяца
Откуда: Сергиев Посад
Благодарил (а): 373 раза
Поблагодарили: 727 раз

Re: Проблема с вложениями

Сообщение владимир1983 »

Shredder как воспроизвести?
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Проблема с вложениями

Сообщение Татьяна5 »

владимир1983, добавить вложение, удалить, нажать f5
Идет повторный запрос на удаление файла, которого уже нет
Аватара пользователя
Slash
phpBB 2.0.10
Сообщения: 794
Стаж: 15 лет 7 месяцев
Благодарил (а): 101 раз
Поблагодарили: 79 раз

Re: Проблема с вложениями

Сообщение Slash »

владимир1983 писал(а):Файл удаляется? Или ошибка появляется после клика на кнопку удалить?
Файл удаляется.
Вот зразу после удаления, если обновить страницу и выходит эта ошибка (правда не знаю зачем обновлять, но косяк все же есть...).
Shredder писал(а):если это баг
Возможно, была такая мысль...

Вернуться в «Поддержка phpBB 3.0.х»