Массовая рассылка ЛС

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
mrTimex
phpBB 1.4.1
Сообщения: 49
Стаж: 13 лет 3 месяца
Благодарил (а): 2 раза

Re: Массовая рассылка ЛС

Сообщение mrTimex »

под дебагом вы подразумеваете error.log от веб сервера?

Добавлено спустя 1 минуту 16 секунд:
PHP Fatal error: Allowed memory size of 167772160 bytes exhausted (tried to allocate 32 bytes)

Добавлено спустя 4 минуты 31 секунду:
P.S. Для тех кто не знает что это значит. Нехватка памяти на выполнение скрипта. Для решения нужно:
1. или в файле настрроек php.ini увеличить php_value memory_limit до того что пишется в ошибке
или
2. в файле htaccess
добаавить строчку php_value memory_limit с нужным числом и не забыть указать буковку "M" означающую мегабайты
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Массовая рассылка ЛС

Сообщение Татьяна5 »

mrTimex писал(а):под дебагом вы подразумеваете
дебаг
mrTimex
phpBB 1.4.1
Сообщения: 49
Стаж: 13 лет 3 месяца
Благодарил (а): 2 раза

Re: Массовая рассылка ЛС

Сообщение mrTimex »

включил дебаг вызвал ошибку, где смотреть отчет?
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Массовая рассылка ЛС

Сообщение Татьяна5 »

Вверху экрана на проблемных страницах
mrTimex
phpBB 1.4.1
Сообщения: 49
Стаж: 13 лет 3 месяца
Благодарил (а): 2 раза

Re: Массовая рассылка ЛС

Сообщение mrTimex »

не совсем понял где
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13159
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Массовая рассылка ЛС

Сообщение Татьяна5 »

Значит ничего не пишет, смотреть лог сервера
mrTimex
phpBB 1.4.1
Сообщения: 49
Стаж: 13 лет 3 месяца
Благодарил (а): 2 раза

Re: Массовая рассылка ЛС

Сообщение mrTimex »

по логам понял что нехватает памяти для выполнения скрипта)) об этом я уже написал сверху. как поправить я тоже уже написал для тех кому может пригодится
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Массовая рассылка ЛС

Сообщение Пчелкин »

mrTimex писал(а):вызвал ошибку
И как ты ее вызвал?
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
mrTimex
phpBB 1.4.1
Сообщения: 49
Стаж: 13 лет 3 месяца
Благодарил (а): 2 раза

Re: Массовая рассылка ЛС

Сообщение mrTimex »

запустил личное сообщение, апач плюнул 500 ошибку, глянул логи апача и понял что за ошибка. победил ее увеличив память под скрипт до 512М, вылезла сделующая ошибка Got a packet bigger than 'max_allowed_packet' bytes [1153] ))) это уже мускул ругается на нехватку для выполнения скрипта. Надо увеличивать и это значение. Хорошо что у меня свой сервак. а что делают люди на хостинге если нужно рассылку сделать? может есть мод какой, чтоб делил и кусками рассылала ЛС?
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Массовая рассылка ЛС

Сообщение Пчелкин »

Нормальные серверы справляются с 125000 лс емкостью по 1200 знаков каждый спокойно...
При этом даже не обязательно
mrTimex писал(а):Хорошо что у меня свой сервак.
Ибо - твоя причина: всего лишь в бардак в БД...Когда была последняя оптимизация таблиц? Не упомнишь? Зря...
Не такие уж и великие запросы на рассылку в ЛС, чтоб ошибку 500 давать...не верю...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
mrTimex
phpBB 1.4.1
Сообщения: 49
Стаж: 13 лет 3 месяца
Благодарил (а): 2 раза

Re: Массовая рассылка ЛС

Сообщение mrTimex »

оптимизация таблиц давно не было. форум достался по наследству. Подскажите как лучше провести оптимизацию. и много ли это займет времени при
Всего сообщений: 298665 • Тем: 10849 • Пользователей: 130802
Аватара пользователя
Пчелкин
phpBB 3.3.0
Сообщения: 11361
Стаж: 16 лет 8 месяцев
Благодарил (а): 1832 раза
Поблагодарили: 1358 раз

Re: Массовая рассылка ЛС

Сообщение Пчелкин »

NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
mrTimex
phpBB 1.4.1
Сообщения: 49
Стаж: 13 лет 3 месяца
Благодарил (а): 2 раза

Re: Массовая рассылка ЛС

Сообщение mrTimex »

поставил патч, запустил оптимизацию, пошла ошибка 500 тайм аут, обновил страницу пишет
Проводится обновление сервера, форум будет доступен в 04:00 01/03/2013.
вопроса, долго будет обновляться и почему такую дату написал ?

И еще стала недоступна закладка модули, при переходе на нее 500 ошибка
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Массовая рассылка ЛС

Сообщение Sheer »

Делай вручную в phpMyAdmin. Каждую таблицу в отдельности.

Добавлено спустя 44 секунды:
А может еще и какие-то таблицы чинить надо.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
mrTimex
phpBB 1.4.1
Сообщения: 49
Стаж: 13 лет 3 месяца
Благодарил (а): 2 раза

Re: Массовая рассылка ЛС

Сообщение mrTimex »

а форум как сейчас включить? в логе администрирования написанно что оптимизация была. я чтоб не вызывать ошибку стал потаблично, глюк произшел когда стал работать с таблицей сообщений posts я как админ вижу форум но висит предупреждение "Информация: Форум в настоящий момент отключен."
собственно как включить?
я лучше ночью продолжу

Вернуться в «Поддержка phpBB 3.0.х»