Ошибки в логах при переходе на PHP 5.6 с 5.3 у старой версии форума

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибки в логах при переходе на PHP 5.6 с 5.3 у старой версии форума

Сообщение Sheer »

Правила, пункт: 2.5
Biba писал(а): но кодировка неверная
Она верная.Просто ломается из-за того, что заголовок выводится не в том месте, где должен.
Biba писал(а):headers already sent by
Чтобы кодировка не менялась в таких ситуациях, в файле .htaccess добавить в конец

Код: Выделить всё

AddDefaultCharset UTF-8
Biba писал(а): можно ли как-то решить данную проблему?
Можно.
1. Подавить вывод ошибки
2. Исправить то, что находится in file /includes/functions_content.php on line 242
А что у вас там находится, нам неведомо, кроме того, что там вызывается функция preg_replace()
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Biba
phpBB 2.0.1
Сообщения: 251
Стаж: 15 лет 10 месяцев
Благодарил (а): 97 раз
Поблагодарили: 1 раз

Re: Ошибки в логах при переходе на PHP 5.6 с 5.3 у старой версии форума

Сообщение Biba »

Спасибо.

В 242 строке functions_content.php у меня следующее:

Код: Выделить всё

    $text = preg_replace('/ +/', ' ', strtr($text, "\t\n\r\x0C ", '     '), $text); 
Последний раз редактировалось Sheer 16.12.2015 12:47, всего редактировалось 1 раз.
Причина: bb-код
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибки в логах при переходе на PHP 5.6 с 5.3 у старой версии форума

Сообщение Sheer »

Код: Выделить всё

    $text = @preg_replace('/ +/', ' ', strtr($text, "\t\n\r\x0C ", '     '), $text);  
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Biba
phpBB 2.0.1
Сообщения: 251
Стаж: 15 лет 10 месяцев
Благодарил (а): 97 раз
Поблагодарили: 1 раз

Re: Ошибки в логах при переходе на PHP 5.6 с 5.3 у старой версии форума

Сообщение Biba »

Большое спасибо, проблема ушла.

А можно уточнить, чем была вызвана ошибка, т.к. мне не сильно понятно, как "@" смогло её убрать :oops:
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибки в логах при переходе на PHP 5.6 с 5.3 у старой версии форума

Сообщение Sheer »

Ошибка в том, что в версии php5.6 в качестве четвертого параметра функции preg_replace требуется аргумент типа long, а передается строка (string)
Собачка @ перед именем функции подавляет вывод диагностического сообщения.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Biba
phpBB 2.0.1
Сообщения: 251
Стаж: 15 лет 10 месяцев
Благодарил (а): 97 раз
Поблагодарили: 1 раз

Re: Ошибки в логах при переходе на PHP 5.6 с 5.3 у старой версии форума

Сообщение Biba »

Спасибо ещё раз.

Сейчас обнаружилась ещё одна проблема (но она не связана с "@")

При нажатии на "Найти сообщения пользователя" - они выводятся (кодировка верная и ошибки не сыпятся вверху страницы), но сообщения БЕЗ текста (прикладываю скриншот).
printscr.jpg
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
LavIgor
Former team member
Сообщения: 3468
Стаж: 12 лет 4 месяца
Благодарил (а): 41 раз
Поблагодарили: 935 раз

Re: Ошибки в логах при переходе на PHP 5.6 с 5.3 у старой версии форума

Сообщение LavIgor »

Biba, по запросу в Гугле первый сайт как раз phpbb.com.
https://www.phpbb.com/community/viewtop ... &t=2114604
Попробуйте сделать правки из второго сообщения.

Отправлено спустя 1 минуту 35 секунд:
Sheer писал(а): Собачка @ перед именем функции подавляет вывод диагностического сообщения.
Собачкой нужно пользоваться лишь в крайних случаях, этот не из таких.
Biba
phpBB 2.0.1
Сообщения: 251
Стаж: 15 лет 10 месяцев
Благодарил (а): 97 раз
Поблагодарили: 1 раз

Re: Ошибки в логах при переходе на PHP 5.6 с 5.3 у старой версии форума

Сообщение Biba »

LavIgor, всё работает отлично (ошибка с пустыми сообщениями тоже пропала).

Большое спасибо!

-----------------

P.S. А можно ли как-то убрать следующую ошибку (она обсуждалась ранее в этой теме - все действия были произведены - часть ошибок ушла, но вот эта осталась):

[16-Dec-2015 18:13:54 Europe/Helsinki] PHP Deprecated: Function set_magic_quotes_runtime() is deprecated in /home/lawportal/public_html/phpBB3/style.php on line 30

Вернуться в «Поддержка phpBB 3.0.х»