Ошибка 500 после очистки кеша

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
InTheWeb
phpBB 1.4.0
Сообщения: 31
Стаж: 11 лет
Благодарил (а): 14 раз
Поблагодарили: 3 раза

Re: Ошибка 500 после очистки кеша

Сообщение InTheWeb »

Siava писал(а): InTheWeb, навскидку.. а какое значение $acm_type в config.php у вас указано?

Код: Выделить всё

<?php
// phpBB 3.0.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'mysqli';
$dbhost = '127.0.0.1';
$dbport = '';
$dbname = '';
$dbuser = '';
$dbpasswd = '';
$table_prefix = 'phpbb_';
$acm_type = 'file';
$load_extensions = '';

@define('PHPBB_INSTALLED', true);
@define('DEBUG', true);
@define('DEBUG_EXTRA', true);
?>
Сейчас такое. Ставил 'none'.

Отправлено спустя 1 минуту 29 секунд:
лол... Открываю /stk и опять 500... :|
Аватара пользователя
LavIgor
Former team member
Сообщения: 3468
Стаж: 12 лет 4 месяца
Благодарил (а): 41 раз
Поблагодарили: 935 раз

Re: Ошибка 500 после очистки кеша

Сообщение LavIgor »

InTheWeb писал(а): Открываю /stk и опять 500...
Значит, правилось что-то ещё, а не только шаблон.
Например, 500-ю ошибку также может вызвать ошибка в .htaccess.
Аватара пользователя
InTheWeb
phpBB 1.4.0
Сообщения: 31
Стаж: 11 лет
Благодарил (а): 14 раз
Поблагодарили: 3 раза

Re: Ошибка 500 после очистки кеша

Сообщение InTheWeb »

LavIgor писал(а): Значит, правилось что-то ещё, а не только шаблон.
Например, 500-ю ошибку также может вызвать ошибка в .htaccess.
В корне форума вообще не было .htaccess'a. Хех.
Аватара пользователя
LavIgor
Former team member
Сообщения: 3468
Стаж: 12 лет 4 месяца
Благодарил (а): 41 раз
Поблагодарили: 935 раз

Re: Ошибка 500 после очистки кеша

Сообщение LavIgor »

InTheWeb, а в дистрибутиве он есть.
Аватара пользователя
Борис Бердичевский
phpBB 3.0.0 RC1
Сообщения: 1457
Стаж: 18 лет 8 месяцев
Откуда: Израиль, Беэр-Шева
Благодарил (а): 45 раз
Поблагодарили: 81 раз

Re: Ошибка 500 после очистки кеша

Сообщение Борис Бердичевский »

По датам можно определить, какие файлы вы "зацепили" при правках. Похоже, что так.
После нескольких лет общения здесь и техсопровождения форумов я наконец понял, что ничего не понимаю в phpBB!
Аватара пользователя
InTheWeb
phpBB 1.4.0
Сообщения: 31
Стаж: 11 лет
Благодарил (а): 14 раз
Поблагодарили: 3 раза

Re: Ошибка 500 после очистки кеша

Сообщение InTheWeb »

LavIgor писал(а): InTheWeb, а в дистрибутиве он есть.
Но ведь ранее всё работало отлично, никаких предпосылок к ошибкам.
Борис Бердичевский писал(а): По датам можно определить, какие файлы вы "зацепили" при правках. Похоже, что так.
Да, несколько раз редактировались некоторые .php файлы (posting и viewtopic.php), но если бы была ошибка, были бы соответствующие надписи на главной + админка бы работала, но тут ничего не работает.
Аватара пользователя
Борис Бердичевский
phpBB 3.0.0 RC1
Сообщения: 1457
Стаж: 18 лет 8 месяцев
Откуда: Израиль, Беэр-Шева
Благодарил (а): 45 раз
Поблагодарили: 81 раз

Re: Ошибка 500 после очистки кеша

Сообщение Борис Бердичевский »

Придётся провести "муравьиную" работу и выявить всё, что не соответствует дистрибутиву. Может быть попорчена функция, общая для всех показов.

И ещё одна идея: проверьте права доступа к папке cache.
После нескольких лет общения здесь и техсопровождения форумов я наконец понял, что ничего не понимаю в phpBB!
Аватара пользователя
InTheWeb
phpBB 1.4.0
Сообщения: 31
Стаж: 11 лет
Благодарил (а): 14 раз
Поблагодарили: 3 раза

Re: Ошибка 500 после очистки кеша

Сообщение InTheWeb »

Борис Бердичевский писал(а): И ещё одна идея: проверьте права доступа к папке cache.
777.
Аватара пользователя
Борис Бердичевский
phpBB 3.0.0 RC1
Сообщения: 1457
Стаж: 18 лет 8 месяцев
Откуда: Израиль, Беэр-Шева
Благодарил (а): 45 раз
Поблагодарили: 81 раз

Re: Ошибка 500 после очистки кеша

Сообщение Борис Бердичевский »

Что-то вообще видно на вашем домене? Может, ошибка у хостера.
После нескольких лет общения здесь и техсопровождения форумов я наконец понял, что ничего не понимаю в phpBB!
Аватара пользователя
InTheWeb
phpBB 1.4.0
Сообщения: 31
Стаж: 11 лет
Благодарил (а): 14 раз
Поблагодарили: 3 раза

Re: Ошибка 500 после очистки кеша

Сообщение InTheWeb »

Борис Бердичевский писал(а): Что-то вообще видно на вашем домене? Может, ошибка у хостера.
Всё работает. Даже UCP, которая связана с форумом - работает. Значит, база данных исправна.
Такое ощущение, что что-то заело попросту.
Аватара пользователя
LavIgor
Former team member
Сообщения: 3468
Стаж: 12 лет 4 месяца
Благодарил (а): 41 раз
Поблагодарили: 935 раз

Re: Ошибка 500 после очистки кеша

Сообщение LavIgor »

InTheWeb писал(а): Что самое интересное — не работает ничего на форуме, абсолютно.
Разве может быть такое, что при ошибке в админке, не работает и форум?
InTheWeb писал(а): Даже UCP, которая связана с форумом - работает.
Противоречие.
Аватара пользователя
InTheWeb
phpBB 1.4.0
Сообщения: 31
Стаж: 11 лет
Благодарил (а): 14 раз
Поблагодарили: 3 раза

Re: Ошибка 500 после очистки кеша

Сообщение InTheWeb »

Не совсем корректно выразился. UCP - отдельная панель управления аккаунтами игрового проекта.
Просто БД связана.
Аватара пользователя
Борис Бердичевский
phpBB 3.0.0 RC1
Сообщения: 1457
Стаж: 18 лет 8 месяцев
Откуда: Израиль, Беэр-Шева
Благодарил (а): 45 раз
Поблагодарили: 81 раз

Re: Ошибка 500 после очистки кеша

Сообщение Борис Бердичевский »

Ещё один "дурацкий" совет: попытаться зайти с другого браузера, с другого компьютера...
После нескольких лет общения здесь и техсопровождения форумов я наконец понял, что ничего не понимаю в phpBB!
Аватара пользователя
InTheWeb
phpBB 1.4.0
Сообщения: 31
Стаж: 11 лет
Благодарил (а): 14 раз
Поблагодарили: 3 раза

Re: Ошибка 500 после очистки кеша

Сообщение InTheWeb »

Борис Бердичевский писал(а): Ещё один "дурацкий" совет: попытаться зайти с другого браузера, с другого компьютера...
Пробовал, спасибо. То же самое.
В общем, не знаю как бороться. Очень расстраивает, что phpBB ошибки даже вывести не может.
Stan_S
phpBB 1.4.0
Сообщения: 32
Стаж: 11 лет 10 месяцев
Благодарил (а): 4 раза
Забанен: Бессрочно

Re: Ошибка 500 после очистки кеша

Сообщение Stan_S »

InTheWeb, Это ошибка сервера =) Обратитесь к хостеру =)) Или проверьте настройки в панели управления хостингом. =)) У вас наверно VDS?

Вернуться в «Поддержка phpBB 3.0.х»