Сообщаем об ошибках phpBB 3.0.x разработчикам
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
rxu
- phpBB Guru

- Сообщения: 17270
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Как вариант, проверьте права доступа (и/или владельца) к этому файлу на сервере. Возможно, вебсервер просто не может его прочесть.
-
Shredder
- Former team member
- Сообщения: 2266
- Стаж: 17 лет 9 месяцев
- Благодарил (а): 283 раза
- Поблагодарили: 584 раза
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Обнаружен следующий баг с "Важными" темами:
Убираем у пользователя или группы форумное право "Может размещать сообщения без одобрения" (т.е. ставим на премодерацию), затем заходим в "Важную" тему из любого форума, где нет этого права, и если в форуме есть хоть одна нормальная (не "Важная") тема, то после редактирования "Важной" она ("Важная") идёт на модерацию, но после одобрения темы значок "ждущих модерации тем" на главной странице форума не снимается, см. скриншот
А если в форуме вообще не было никаких тем, кроме "Важных", то результат ещё плачевнее: на этапе редактирования вы получите SQL-ошибку:
Убираем у пользователя или группы форумное право "Может размещать сообщения без одобрения" (т.е. ставим на премодерацию), затем заходим в "Важную" тему из любого форума, где нет этого права, и если в форуме есть хоть одна нормальная (не "Важная") тема, то после редактирования "Важной" она ("Важная") идёт на модерацию, но после одобрения темы значок "ждущих модерации тем" на главной странице форума не снимается, см. скриншот
А если в форуме вообще не было никаких тем, кроме "Важных", то результат ещё плачевнее: на этапе редактирования вы получите SQL-ошибку:
Общая ошибка
SQL ERROR [ mysqli ]
BIGINT UNSIGNED value is out of range in '(`forum_db`.`phpbb_forums`.`forum_topics` - 1)' [1690]
SQL
UPDATE phpbb_forums SET forum_topics = forum_topics - 1, forum_posts = forum_posts - 1 WHERE forum_id = 5
BACKTRACE
FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()
FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()
FILE: [ROOT]/includes/db/mysqli.php
LINE: 189
CALL: dbal->sql_error()
FILE: [ROOT]/includes/functions_posting.php
LINE: 2503
CALL: dbal_mysqli->sql_query()
FILE: [ROOT]/posting.php
LINE: 1160
CALL: submit_post()
У вас нет необходимых прав для просмотра вложений в этом сообщении.
-
xisp
- phpBB 3.0.0 RC7
- Сообщения: 1798
- Стаж: 14 лет 4 месяца
- Благодарил (а): 152 раза
- Поблагодарили: 215 раз
- Забанен: Бессрочно
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
При вставке скопированного смайлика из вконтаке, или любого другого символа юникода с шестью знаками в коде (ХЗ как сказать), вываливается ошибка БД:
В тексте ошибки смайл заменил на текст, а то не отправляется с аналогичной ошибкой
К примеру идём сюда и копируем первый смайлик, колонка "Крякозябра".
В новой бета 3.1 ситуация аналогичная.
Код: Выделить всё
SQL ERROR [ mysqli ]
Incorrect string value: '\xF0\x9F\x98\x8A' for column 'post_text' at row 1 [1366]
SQL
INSERT INTO guru3_posts (forum_id, poster_id, icon_id, poster_ip, post_time, post_approved, enable_bbcode, enable_smilies, enable_magic_url, enable_sig, post_username, post_subject, post_text, post_checksum, post_attachment, bbcode_bitfield, bbcode_uid, post_postcount, post_edit_locked, topic_id) VALUES (57, 40783, 0, '96.44.189.101', 1398580160, 1, 1, 1, 1, 1, '', 'Re: Расширения - это просто!', 'тут_был_смайл', '5deda34cd95f304948d2bc1b4a62c11e', 0, '', 'dj8hyzkk', 1, 0, 41507)
BACKTRACEК примеру идём сюда и копируем первый смайлик, колонка "Крякозябра".
В новой бета 3.1 ситуация аналогичная.
phpBBex
-
rxu
- phpBB Guru

- Сообщения: 17270
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Смайлики, которые отображаются на той странице, и отправляются без ошибки. Остальные и на странице не отображены. Проблемы с кодировкой. ❤
-
xisp
- phpBB 3.0.0 RC7
- Сообщения: 1798
- Стаж: 14 лет 4 месяца
- Благодарил (а): 152 раза
- Поблагодарили: 215 раз
- Забанен: Бессрочно
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Покажите. У меня ошибка.rxu писал(а):Смайлики, которые отображаются на той странице, и отправляются без ошибки.
Кодировка нормальная, просто их нет в вашем шрифте.rxu писал(а):Остальные и на странице не отображены. Проблемы с кодировкой.
Собственно даже квадратики не пропускает.
phpBBex
-
rxu
- phpBB Guru

- Сообщения: 17270
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Сообщением выше, сердечко в конце поста.xisp писал(а):Покажите. У меня ошибка.
-
xisp
- phpBB 3.0.0 RC7
- Сообщения: 1798
- Стаж: 14 лет 4 месяца
- Благодарил (а): 152 раза
- Поблагодарили: 215 раз
- Забанен: Бессрочно
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Сердечко имеет пятизначный номер. Попробуйте просто квадратик.rxu писал(а):Сообщением выше, сердечко в конце поста.
Вот:

phpBBex
-
xisp
- phpBB 3.0.0 RC7
- Сообщения: 1798
- Стаж: 14 лет 4 месяца
- Благодарил (а): 152 раза
- Поблагодарили: 215 раз
- Забанен: Бессрочно
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Не тот же. Я же вижу, что код короткий. Копируйте прямо с первой строчки. У меня же вышло. Вот, обвёл (если у вас квадратик- копируйте его):
https://i.minus.com/i2jyKfQCmQpgK.png
https://i.minus.com/i2jyKfQCmQpgK.png
Последний раз редактировалось xisp 27.04.2014 9:15, всего редактировалось 1 раз.
phpBBex
-
rxu
- phpBB Guru

- Сообщения: 17270
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Да, символы с пятизначным кодом отправляются, с шестизначным - нет.
Видимо, не попадают в последовательность UTF-8.
Видимо, не попадают в последовательность UTF-8.
-
xisp
- phpBB 3.0.0 RC7
- Сообщения: 1798
- Стаж: 14 лет 4 месяца
- Благодарил (а): 152 раза
- Поблагодарили: 215 раз
- Забанен: Бессрочно
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
В том то и дело, что попадают. Там вообще больше миллиона значений.rxu писал(а):Видимо, не попадают в последовательность UTF-8.
Ну в общем об ошибке сообщил, надеюсь, кто- нибудь багрепорт оформит.
phpBBex
-
rxu
- phpBB Guru

- Сообщения: 17270
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
xisp
Я так думаю, что это известное ограничение MySQL, которое допускает только 3-байтовые символы UTF8.
4-байтовые возможны только в MySQL 5.5+ при смене кодировки поля с utf8 to utf8mb4. Оно?
Я так думаю, что это известное ограничение MySQL, которое допускает только 3-байтовые символы UTF8.
4-байтовые возможны только в MySQL 5.5+ при смене кодировки поля с utf8 to utf8mb4. Оно?
-
xisp
- phpBB 3.0.0 RC7
- Сообщения: 1798
- Стаж: 14 лет 4 месяца
- Благодарил (а): 152 раза
- Поблагодарили: 215 раз
- Забанен: Бессрочно
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Можно было бы их кодировать в мнемоники HTML. Падать с ошибкой БД, раскрывая префикс и структуру БД, совсем не обязательно.rxu писал(а):Я так думаю, что это известное ограничение MySQL, которое допускает только 3-байтовые символы UTF8.
ИМХО, форум должен корректно переваривать любые введённые данные, отбрасывая или кодируя ошибочные.
Не прокатило. Хотя я особо не вникал. может, где не допоменял. Поковыряю на досуге.rxu писал(а):при смене кодировки поля с utf8 to utf8mb4. Оно?
phpBBex
-
staiki
- phpBB 2.0.2
- Сообщения: 318
- Стаж: 14 лет 3 месяца
- Откуда: Киев Украина
- Благодарил (а): 76 раз
- Поблагодарили: 9 раз
- Забанен: Бессрочно
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Всем доброго времени суток.В субботу 14.06 после массовой рассылки почты произошел какой-то сбой.Через каждые 15 минут начало рассылать всем дубли.В воскресенье 15.06 рассылка в админке показало что ушла но пользователи писем не получили.Обратился к хостеру он написал следующее:
Как исправить "Массовая рассылка почты"?До субботы каждый день отправлял было всё нормально и никто ничего не трогал в шаблонах.
ЗЫ.Если вопрос не в тему-перенесите.Спасибо.
Код: Выделить всё
Мы проверили Вашу услугу и видим, что рассылка не осуществлялась из-за превышения лимита на отправку писем.
Также мы проверили работу почтового сервера, проблем выявлено не было.
Скорее всего, причина в работе самого скрипта, либо скрипт инициирует сразу много попыток отправить почту, либо в работе скрипта произошел сбой и он зациклил старую рассылку.
Рекомендуем Вам, по вопросу работы скрипта рассылки почты, обратиться к разработчику.ЗЫ.Если вопрос не в тему-перенесите.Спасибо.
http://staiki.net/index.php Форум Компьютерная Помощь
-
Sheer
- Former team member
- Сообщения: 12113
- Стаж: 19 лет 7 месяцев
- Откуда: Калининград не Кенигсберг
- Благодарил (а): 54 раза
- Поблагодарили: 2756 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.

