Уважаемые пользователи!
Напоминаем, что с 7 ноября 2020 года phpBB Group прекратила выпуск обновлений для phpBB версии 3.2.
С учетом этого, рекомендуется обновить конференции до версии 3.3.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.2 до отдельного объявления.

[FAQ] Проблемы со входом в администраторский раздел

Темы по наиболее часто задаваемым вопросам по phpBB 2.0.x. Читать в первую очередь!
Аватара пользователя
DJ_FOMA
phpBB 1.2.0
Сообщения: 18
Стаж: 14 лет 8 месяцев
Откуда: Лиски

Сообщение DJ_FOMA »

При входе в админку в форуме phpBB 2.0.22 вот такая фигня!!

Код: Выделить всё

Внутренняя ошибка сервера
Server Internal Error
Ошибка 500
Комментарий: Сервер столкнулся с внутренней ошибкой и не смог завершить Ваш запрос. Также вероятно, что сервер перегружен или была ошибка в CGI скрипте (скрипте CGI-BIN или Perl).
Как исправить подскажите плиззззззззззз!!!!!
Thug
phpBB 1.4.0
Сообщения: 38
Стаж: 15 лет 1 месяц

Сообщение Thug »

Похоже на неотрабатывающий скрипт.
Какие модификации кода делали? Моды ставили?
Аватара пользователя
DJ_FOMA
phpBB 1.2.0
Сообщения: 18
Стаж: 14 лет 8 месяцев
Откуда: Лиски

Сообщение DJ_FOMA »

Thug
За месяц до этой проблемы не чё ваще не делал с форумом!
На правильном ли мы пути и стоит ли туда идти?
Hidden251
phpBB 1.0.0
Сообщения: 1
Стаж: 14 лет 3 месяца
Откуда: Moscow

Сообщение Hidden251 »

Доброго времени суток всем...
Стояла у меня phpbb 2.0.22 скачал и установил MOD на 2.0.23
И всё бы ничего, но при переходе в админку, левый фрейм весь белый белый...:-) Где копать?
заранее благодарен
Squall
phpBB 1.0.0
Сообщения: 1
Стаж: 14 лет 3 месяца

Сообщение Squall »

Could not locate remote server
Пишет мне форум при попытки зайти либо выйти под любым логином!
Потом после обновления странице всетаки заходит в форум но только в опере. А в админку все ровно не пускает пишет тоже самое!
Что это помогите плз!
Iftin
phpBB 2.0.7
Сообщения: 573
Стаж: 17 лет 1 месяц
Откуда: Moscow

Сообщение Iftin »

Спасибо! реальный совет написал, только что исправил ошибку. Ошибка возникла связи с переездом на новый хостинг левый фрейм, был белым, не загружался. =) :wink:

Zlodey12 писал(а):
Очень многие пользователи писал(а):"не отображается левый фрейм (навигация) в админке"
У меня такое происходило после установки двух модов - Download Manager (pafiledb) и Board Statistics.
Перелопатив эту тему и тему про "статистику" (всего 23 страницы) увидел, что эта проблема возникает очень у многих, но решение предложено не было. Самое умное, что я тут почерпнул - это давнишнее сообщение Эксперта, о том, чтобы включить уровень ошибок E_ALL в Common.php, т.е. вместо строки:
error_reporting (E_ERROR | E_WARNING | E_PARSE)
ставим:
error_reporting (E_ALL | E_ERROR | E_WARNING | E_PARSE)
Далее заходим в администраторский раздел и после его загрузки видим в левом фрейме кучу всяких сообщений об ошибках, и в самом низу - то, что нам надо - ошибка, не позволяющая загружаться навигационной панели.
После установки Статистики 2.1.5 сообщение будет примерно таким:

Fatal error: Cannot redeclare renumber_order()
(previously declared in ...\forum\admin\admin_forums.php:173) in
...\forum\admin\admin_statistics.php on line 145

Даже не зная английского, но посмотрев что находится в этих строках, понимаем - в двух разных файлах вызываются две разные функции, но имеющие одинаковое имя renumber_order.
Правим файл admin_statistics.php, и название функции renumber_order заменяем на другое, например, на renumber_order_stat или renumber_order2. Заменяем все вхождения в данном файле!!!
ВСЁ!!! Админка работает как надо. Да, не забываем вернуть уровень ошибок в коммон.пхп как был).
С остальными модами решается так же, по крайней мере admin_pa_catauth.php из pafiledb после правки так же перестал вешать админку.
Как ни странно, в данных конкретных случаях нет конфликта модов. Но почему у одних всё работает нормально, а у других нет? Не знаю.. возможно это зависит от версии PHP, SQL или еще чего... (ведь у многих это происходило после переезда на новый хостинг)


P.S. Муть под чертой ниже - для облегчения поиска этого сообщения )
---------------------------------------------------------------------------------
не загружается навигация в администраторском разделе пустой левый фрейм Board Statistics 2.1.5 перестала показываться левая панель в админке левая часть пустая пустой лист слева в админ-панели панель навигации не отображается пропала навигация по администраторскому разделу
Bookvoed
phpBB 1.0.0
Сообщения: 7
Стаж: 14 лет 3 месяца

Сообщение Bookvoed »

Всем здрасте, может подскажете по поводу проблемы. Форум отображается нормально, авторизация пользователей на форуме проходит нормально, при попытке входа в админку запроса пароля нет, появляется сообщение:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@forum.mysite.ru and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Только сразу ногами не бейте - изменения в файлы pagestart.php и functions.php вносил, проверял настройки в базе - куки отключены, адрес форума (домен третьего уровня) и путь к скрипту указаны верно (/).

Особенность ситуации в том, что форум свежевосстановленный, при этом база данных перекодировалась из utf8 в ср1251.
Аватара пользователя
Rayden
Former team member
Сообщения: 3739
Стаж: 17 лет
Поблагодарили: 3 раза

Сообщение Rayden »

Переведи эту строку:
More information about this error may be available in the server error log

И последуй этому совету.

Добавлено спустя 57 секунд:

А почему куки отключены?
phpBB2 FAQ
phpBB3 FAQ
Bookvoed
phpBB 1.0.0
Сообщения: 7
Стаж: 14 лет 3 месяца

Сообщение Bookvoed »

я дико извиняюсь, неправильно были выставлены права на папки и файлы :oops: ... у семи нянек :)
Volwebnik
phpBB 1.0.0
Сообщения: 4
Стаж: 14 лет 3 месяца

Сообщение Volwebnik »

После "включения имитации прав пользователя" - не попасть в админку..
как корректо выключить эту имитацию?
Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Стаж: 16 лет 1 месяц
Откуда: Питер
Благодарил (а): 1 раз
Поблагодарили: 27 раз

Сообщение Палыч »

Volwebnik
Войти под своей учётной записью и щелкнуть Восстановить права доступа в верхнем меню.
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
S_H
phpBB 1.0.0
Сообщения: 1
Стаж: 14 лет 2 месяца

Сообщение S_H »

Здраствуйте.
Не могу войти в админ панель.
1. Захожу под админом на форум.
2. Выбираю "Перейти в администраторский раздел".
3. Повторно ввожу пароль и нажимаю ОК.
Грузиться пустая белая страница.

Пробовал удалять pagestart.php. Не помогло.
Пробовал менять код на

if (!$userdata['session_admin'])
{
redirect(append_sid("../login.$phpEx?redirect=admin/index.php&admin=1", true));
}
Не помогло.

Версия форума 2.0.23.

Зарание благодарен за ответ.
skl
phpBB 1.0.0
Сообщения: 4
Стаж: 14 лет 2 месяца

Сообщение skl »

Доброго времени суток. Подскажите советом.
Возникла такая проблемка:
1. При входе на форум логин и пароль принимает только со второго раза. Сессия длится менее минуты, хотя выставлено 3600сек.
2. При попытке войти в админ раздел загружается левая панелька, а вместо правой опять паявляется панель с запросом логина и пароля...
Аватара пользователя
PavlegSS
phpBB 1.4.4
Сообщения: 160
Стаж: 14 лет 8 месяцев

Сообщение PavlegSS »

FAQ, настройки куков проверь
skl
phpBB 1.0.0
Сообщения: 4
Стаж: 14 лет 2 месяца

Сообщение skl »

Проверял, все как описано выше.... Другие пользователи на работу форума не жалуются...

Добавлено спустя 1 час 24 минуты 23 секунды:

С первым вопросом разобрался... Заходит с первого раза, помог МОД КУККИ...

Добавлено спустя 12 минут 28 секунд:

пробовал это:

Код:
if (!$userdata['session_admin'])
{
redirect(append_sid("login.$phpEx?redirect=admin/index.php&admin=1", true));
}


меняйте на

Код:
if (!$userdata['session_admin'])
{
redirect(append_sid("../login.$phpEx?redirect=admin/index.php&admin=1", true));
}
Не помогло... появилась 404 ошибка!

Вернуться в «FAQ (phpBB 2.0.x)»