Пчелкин писал(а):Хостер поймет...
Поймёт, но немного не то.
Эта ошибка никак не связана с хостингом,
Пчелкин. И с хостером тоже.
Причина проста.
Форум сжимает данные собственными средствами, а не средствами веб-сервера. То есть генерирует код страницы, затем отдаёт правильные заголовки браузеру (о том, что контент сжат), после чего сжимает код страницы и отдаёт его. Во время генерации кода страницы, в PHP возникает ошибка обработки, информация о которой отправляется браузеру. Текстом. В то время, как браузер ждёт сжатые данные. Сжатых данных он не находит, поэтому и возникает такая ошибка несоответствия пришедших данных и того, что ожидалось.