Ошибка SQL ERROR [ mysql4 ] 1033

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
maminsite
phpBB 1.2.0
Сообщения: 11
Стаж: 11 лет 8 месяцев
Благодарил (а): 2 раза

Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение maminsite »

Доброе время суток!
Обновили на сервере PHP на новую PHP: 5.4
Теперь на форуме стали возникать ошибки.
При заходе в профиль любого аккаунта стала выдаваться такое сообщение:

Код: Выделить всё

Общая ошибка
SQL ERROR [ mysql4 ]

Incorrect information in file: './u38065/phpbb_profile_fields.frm' [1033]

SQL

SELECT l.*, f.* FROM phpbb_profile_lang l, phpbb_profile_fields f WHERE f.field_active = 1 AND l.lang_id = 2 AND l.field_id = f.field_id ORDER BY f.field_order

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/includes/functions_profile_fields.php
LINE: 66
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/includes/ucp/ucp_profile.php
LINE: 439
CALL: custom_profile->generate_profile_fields()

FILE: [ROOT]/includes/functions_module.php
LINE: 507
CALL: ucp_profile->main()

FILE: [ROOT]/ucp.php
LINE: 334
CALL: p_master->load_active()
Что надо сделать, чтобы исправить ошибку?
Последний раз редактировалось Sheer 08.01.2015 21:16, всего редактировалось 1 раз.
Причина: bb-код
Аватара пользователя
владимир1983
phpBB 3.2.6
Сообщения: 5954
Стаж: 16 лет 4 месяца
Откуда: Сергиев Посад
Благодарил (а): 373 раза
Поблагодарили: 727 раз

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение владимир1983 »

Используй STK для решения проблемы.

Добавлено спустя 1 минуту 53 секунды:
Локализацию у нас можешь найти поиском.

Добавлено спустя 4 минуты 45 секунд:
Ну и FAQ.
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
maminsite
phpBB 1.2.0
Сообщения: 11
Стаж: 11 лет 8 месяцев
Благодарил (а): 2 раза

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение maminsite »

К сожалению я не программист, а поиск по ошибке 1033 не помог. Ткните носом, плиз, куда смотреть
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение Sheer »

Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
maminsite
phpBB 1.2.0
Сообщения: 11
Стаж: 11 лет 8 месяцев
Благодарил (а): 2 раза

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение maminsite »

не помогает восстановление таблицы в phpmyadmin. ошибка после операции восстановления
#1033 - Incorrect information in file: './u38065/phpbb_profile_fields.frm'
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение Sheer »

maminsite
Какой тип базы данных вы используете? mysql, mysql(i), или другой?
Какой тип у таблицы phpbb_profile_fields InnoDB или MyISAM ?
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
владимир1983
phpBB 3.2.6
Сообщения: 5954
Стаж: 16 лет 4 месяца
Откуда: Сергиев Посад
Благодарил (а): 373 раза
Поблагодарили: 727 раз

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение владимир1983 »

И ещё, с какой на какую версию MYSQL обновляли?
Сам обновлял? Выполнял # mysql_upgrade?
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
maminsite
phpBB 1.2.0
Сообщения: 11
Стаж: 11 лет 8 месяцев
Благодарил (а): 2 раза

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение maminsite »

Сейчас MySQL 5.5.35-1+wheezy1+mh1-log
Какая была точно не помню, но на форуме в админке висело сообщение, что эта версия больше не поддерживается, поэтому решили обновить.

Не сами - все было по заявке автоматом на мастерхосте.

Добавлено спустя 6 минут 2 секунды:
Sheer писал(а):Какой тип у таблицы phpbb_profile_fields InnoDB или MyISAM ?
у "phpbb_profile_fields_data" MyISAM utf8_bin
у "phpbb_profile_fields_lang" и др. - тоже самое
Но у некоторых и
"phpbb_profile_fields" в том числе стоит "используется"

Добавлено спустя 3 минуты 57 секунд:
Видимо эти таблицы, где "используется" и не работают
в том числе и таблица линеечек метрики тоже не работает - в этом тоже проблема, но это не форум.
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение Sheer »

Резервная копия есть?
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
maminsite
phpBB 1.2.0
Сообщения: 11
Стаж: 11 лет 8 месяцев
Благодарил (а): 2 раза

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение maminsite »

У меня нет, у хостера не знаю.

Добавлено спустя 6 минут 8 секунд:
О, от сентября есть резервное копирование форума
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение Sheer »

maminsite писал(а):У меня нет
А обязана быть. Обратитесь к хостеру, пусть фиксят. И еще, может быть это будет им полезно.

Код: Выделить всё

    Stop MySQL
    Backup phpbb_profile_fields.frm, phpbb_profile_fields.MYI, phpbb_profile_fields.MYD files
    Delete them from your mysql data directory (/var/lib/mysql usually)
    Start MySQL
    CREATE the table again
    Stop MySQL
    Copy the .MYD and .MYI files back into the datadir, replacing the ones there.
    Start MySQL
    Profit
Добавлено спустя 1 минуту 20 секунд:
maminsite писал(а):от сентября есть резервное копирование форума
Попробуйте удалить эту таблицу и потом восстановить ее из копии. Только одну таблицу, ни в коем случае не всю базу!


Добавлено спустя 2 минуты 22 секунды:
Или попробуйте создать таблицу заново

Код: Выделить всё

DROP TABLE IF EXISTS `phpbb_profile_fields`;
CREATE TABLE IF NOT EXISTS `phpbb_profile_fields` (
  `field_id` mediumint(8) unsigned NOT NULL AUTO_INCREMENT,
  `field_name` varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  `field_type` tinyint(4) NOT NULL DEFAULT '0',
  `field_ident` varchar(20) COLLATE utf8_bin NOT NULL DEFAULT '',
  `field_length` varchar(20) COLLATE utf8_bin NOT NULL DEFAULT '',
  `field_minlen` varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  `field_maxlen` varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  `field_novalue` varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  `field_default_value` varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  `field_validation` varchar(20) COLLATE utf8_bin NOT NULL DEFAULT '',
  `field_required` tinyint(1) unsigned NOT NULL DEFAULT '0',
  `field_show_novalue` tinyint(1) unsigned NOT NULL DEFAULT '0',
  `field_show_on_reg` tinyint(1) unsigned NOT NULL DEFAULT '0',
  `field_show_on_vt` tinyint(1) unsigned NOT NULL DEFAULT '0',
  `field_show_profile` tinyint(1) unsigned NOT NULL DEFAULT '0',
  `field_hide` tinyint(1) unsigned NOT NULL DEFAULT '0',
  `field_no_view` tinyint(1) unsigned NOT NULL DEFAULT '0',
  `field_active` tinyint(1) unsigned NOT NULL DEFAULT '0',
  `field_order` mediumint(8) unsigned NOT NULL DEFAULT '0',
  PRIMARY KEY (`field_id`),
  KEY `fld_type` (`field_type`),
  KEY `fld_ordr` (`field_order`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin AUTO_INCREMENT=1 ;
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
maminsite
phpBB 1.2.0
Сообщения: 11
Стаж: 11 лет 8 месяцев
Благодарил (а): 2 раза

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение maminsite »

Я вам написала в личку

Добавлено спустя 1 час 7 минут 39 секунд:
Удалила таблицу и создала - помогло! Спасибо большое!!!
А вот еще несколько таблиц неработающих:
phpbb_captcha_answers
phpbb_captcha_questions
phpbb_qa_confirm
Можно и их исправить?
Аватара пользователя
xisp
phpBB 3.0.0 RC7
Сообщения: 1798
Стаж: 14 лет 4 месяца
Благодарил (а): 152 раза
Поблагодарили: 215 раз
Забанен: Бессрочно

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение xisp »

Да, тем же способом, только сначала удалите ответы, заложенные в капчу (если использовали), а после восстановления верните обратно.
phpBBex
Аватара пользователя
владимир1983
phpBB 3.2.6
Сообщения: 5954
Стаж: 16 лет 4 месяца
Откуда: Сергиев Посад
Благодарил (а): 373 раза
Поблагодарили: 727 раз

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение владимир1983 »

maminsite писал(а):несколько таблиц
Все может быть гораздо хуже.
Обратись к тому кто апдейтил MYSQL. Прям как есть все проблемы и опиши. Тамошний сапорт восстановит битые frm данные либо с бекапа который они сделали перед апдейтом, либо используют mysql_upgrade для таблиц. Возможно и не запускали после апдейта.
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
maminsite
phpBB 1.2.0
Сообщения: 11
Стаж: 11 лет 8 месяцев
Благодарил (а): 2 раза

Re: Ошибка SQL ERROR [ mysql4 ] 1033

Сообщение maminsite »

Вот еще с порталом фихня, наверху строчки ошибки: maminsite.ru/forum/portal.php

Добавлено спустя 2 минуты 3 секунды:
владимир1983 писал(а):
maminsite писал(а):несколько таблиц
Все может быть гораздо хуже.
Обратись к тому кто апдейтил MYSQL. Прям как есть все проблемы и опиши. Тамошний сапорт восстановит битые frm данные либо с бекапа который они сделали перед апдейтом, либо используют mysql_upgrade для таблиц. Возможно и не запускали после апдейта.
Ок, напишу в поддержку хостера
Последний раз редактировалось maminsite 09.01.2015 13:25, всего редактировалось 1 раз.

Вернуться в «Поддержка phpBB 3.0.х»